Archived

This topic is now archived and is closed to further replies.

Guest Nick_N

Moving vehicles and herky jerky motion . . .

Recommended Posts

Much of the time the moving cars and so forth have a slight stutter in their motion. Sometimes they are silky smooth, but most of the time there is a slight stutter. I have vehicle slider at about 16, and use Ultimate Terrain to bump up car counts.My question is this: do any of you experience perfectly smooth vehicle motion most or all of the time? I have a hunch it's sort of a canary in the coalmine of an indicator that things aren't set up 100% optimally. Overall FSX is very very smooth on my current configuration, but again, the lil' vehicles betray a slight hitch in their getalong . . .Your experience?Noel

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

With the latest UTX USA patch which enabled/increased car traffic on side streets and essentially increased its CPU use I would set that at no more than 8%. I did run 12 before the last UTX update. The changes have increased car traffic by quite a bit and due to limits in the FSX system in order to turn car traffic off you can not simply set the silder to ZERO... you must disable it in UTX or the forrtprint for car traffic is still active on the system even with a zero FSX slider setting.and yes, its an indication you may very well be exceeding the system ability and priority is causing the traffic to run stammered

Share this post


Link to post
Share on other sites

>what type of system do you have Noel?Sorry Clayton, here it is . . .QX9650 w/ Retail HSF|ASUS P5E3 Premium WiFi|4GB Muskin Ascent 7-6-6-18 1T DDR3-1600|EVGA 8800GT|Seagate SATA 2 x 2|Seagate Cheetah 15K.x|XP Pro SP2|Vista 64--maybe never to be installed

Share this post


Link to post
Share on other sites

>and yes, its an indication you may very well be exceeding the>system ability and priority is causing the traffic to run>stammeredYeah, it seems so I guess. Nick, what is your take on this conundrum: if you set frame lock to UNLIMITED, you get a nice (arguably, in some situations) prioritization that improves both frame rate and fluidity. I find that it's really a very nice compromise. But, as you know, you can now be prone to frame rate spikes, causing a certain kind of jerkiness in motion. Is there not happy way to take advantage of what UNLIMITED does, and avoid frame rate spikes? This seems critical, but I don't have a formula. Thanks in advance for anything you may know.

Share this post


Link to post
Share on other sites

Tnx a lot Nick. You saved my day. Changed MB and re-installed FSX but could not figure out why I was having lower performance than before: and then I read this thread about UTX&FSX and trafic slider to ZERO not doing the job. That was my problem: Car trafic at ZERO in FSX so no vehicles are moving, fine I would think. But no you have to disable UTX road tfc. Tnx a million again Nick, it is a small detail but on my setup, it makes a WHOLE lot of difference. In hvy urban area with just 6 on road tfc, I would loose a good 10 fps. The choice is clear.With fps locked at 24, I can now run Bloom and water mid2x and it is smooth as silk.CheersPierre

Share this post


Link to post
Share on other sites

I set the FPS slider to unlimited in heavy CPU situations like major airport/clouds/traffic/complex aircraft, and lock the frames out in the country where I get good FPS. I find when I start seeing FPS jumping over 50 routinely, it's time to lock the frames or it will stutter.It's too bad they didn't program a slider for us that would allow us to set an average FPS point that would lock the frame above it, and unlimit the frames below it automatically.I didn't know about the UTX traffic affecting the slider at zero either, thanks for that.

Share this post


Link to post
Share on other sites

One other thing you can do also. If you go to the FTX website (the Australian Scenery one), they have a free download in their download section that adjusts the AI ground vehicle traffic speed. Ground traffic will exceed 180 kilometers per hour in default FSX sometimes. Makes for funny "Keystone Cops" type of traffic movements on the roads and airports at times. Those high speeds also increase the "displacement" of the ground traffic from frame to frame, so at lesser frame rates, the ground traffic can appear "jerky".The free download adjusts all the ground traffic speeds to more realistic values. No more fuel trucks drag racing around the airport aprons, either. Worked great when I installed it. Just follow the simple instructions included to backup the files it changes. No brainer.FalconAF

Share this post


Link to post
Share on other sites

Falcon,Can you please guide me to the link to download this program to decrease the AI vehicles speed?Thanks

Share this post


Link to post
Share on other sites

Oops! It's not on their "Free Downloads" page. I thought that's where I got it, but I might have actually got it as part of one of their ORBX AU scenery addons.If you do a GOOGLE search using "Slower_Vehicles_Tweak", the first link that comes up is one to their support forum. I don't know if it is available for download there or not. You would have to register for the forum to find out. It's a really small file, only about 100+ kb in size.You may find other links during that GOOGLE search. I don't know for sure now if the file was intended as freeware or not. If not, then those other links would be "pirated" copies of it. I don't advocate that if it ISN'T intended as freeware. FalconAF

Share this post


Link to post
Share on other sites

>>and yes, its an indication you may very well be exceeding>the>>system ability and priority is causing the traffic to run>>stammered>>Yeah, it seems so I guess. >>Nick, what is your take on this conundrum: if you set frame>lock to UNLIMITED, you get a nice (arguably, in some>situations) prioritization that improves both frame rate and>fluidity. I find that it's really a very nice compromise. >But, as you know, you can now be prone to frame rate spikes,>causing a certain kind of jerkiness in motion. Is there not>happy way to take advantage of what UNLIMITED does, and avoid>frame rate spikes? This seems critical, but I don't have a>formula. Thanks in advance for anything you may know.>Plain and simple... its just a FSX quarkI run unlimited under high CPU load and then slide it down to 30 locked when I get outside of urbanI will slide it back up to unlimited when I notice the issue and will sometimes look for the cause if I dont see enough AG or weather in the area.. found a few bad addons that way too.

Share this post


Link to post
Share on other sites

>Tnx a lot Nick. You saved my day. Changed MB and re-installed>FSX but could not figure out why I was having lower>performance than before: and then I read this thread about>UTX&FSX and trafic slider to ZERO not doing the job. That was>my problem: Car trafic at ZERO in FSX so no vehicles are>moving, fine I would think. But no you have to disable UTX>road tfc. Tnx a million again Nick, it is a small detail but>on my setup, it makes a WHOLE lot of difference. In hvy urban>area with just 6 on road tfc, I would loose a good 10 fps. The>choice is clear.>With fps locked at 24, I can now run Bloom and water mid2x and>it is smooth as silk.>Cheers>PierreYou are welcome PierreI read about it some time ago in the UTX forums. Many who are on the 'edge' of perf need to know about that with UTX because it can cause some strange issues on slower systems or system that are being pushed very hard.Its frustrating when you can't figure out what caused something to change out of nowhere. I noticed the change before reading about it in the UTX forums as soon as I installed the 1.3 patch.. I know it was coming from UTX because of the traffic increase but what I did not know is setting the slider to zero will not take the footprint off the system.. so I learn something new myself

Share this post


Link to post
Share on other sites

Try this and see if it helps. Set your pre render to 1 in the nvidia control panel. The default is 3. This limits the number of frames your CPU can render before they are sent to the GPU. In my case I was getting surges in FPS that were very annoying and by setting it to 1 has more or less eliminated them. I also can with a prerender of 1 leave my FPS unlimited all the time. Also make sure you have VSYNC locked and I also use the tripple buffer feature. Maybe these settings will help you like it helped me.Jim

Share this post


Link to post
Share on other sites

>Try this and see if it helps. Set your pre render to 1 in the>nvidia control panel. The default is 3. This limits the number>of frames your CPU can render before they are sent to the GPU.>In my case I was getting surges in FPS that were very annoying>and by setting it to 1 has more or less eliminated them. I>also can with a prerender of 1 leave my FPS unlimited all the>time. Also make sure you have VSYNC locked and I also use the>tripple buffer feature. Maybe these settings will help you>like it helped me.>>JimNice, Jim, I will definitely try this. Thank you kindly . . .QX9650 w/ Retail HSF|ASUS P5E3 Premium WiFi|4GB Muskin Ascent 7-6-6-18 1T DDR3-1600|EVGA 8800GT|Seagate SATA 2 x 2|Seagate Cheetah 15K.x|XP Pro SP2|Vista 64--maybe never to be installed

Share this post


Link to post
Share on other sites

>>I run unlimited under high CPU load and then slide it down to>30 locked when I get outside of urbanNick that is exactly what I am doing, which makes sense, as we get there by a little trial and error sometimes.

Share this post


Link to post
Share on other sites