Sign in to follow this  
Guest Jeffreymg

How To Increase Frame Rates

Recommended Posts

I have a P4 3.2 with a ATI 1600 512 ram on card and 2 gig of ram on the computer,now I am running FS9 and with sliders in the middle on everything getting 5fps on just about all flights.I uninstalled the sim and defrag hard drive with Diskkeeper and used spysweeper and my virus program.I removed alot of trash on HD,I reinstalled FS9 and added back my sceneries and add-on payware aircraft and still getting same 5fps.What can I do next to increase fps? JeffG

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I will start off the replies by suggesting you post your FS9.cfg, and also describe the locations you're getting 5 fps from. If it's say, Reno, Nevada, then I believe you'd have a serious issue that a good config sleuth can fix.-John

Share this post


Link to post
Share on other sites

Ok Here's my FS9 config file:[PANELS]IMAGE_QUALITY=1UNITS_OF_MEASURE=0QUICKTIPS=1PANEL_MASKING=1PANEL_STRETCHING=1[Weather]WindshieldPrecipitationEffects=1MinGustTime=10MaxGustTime=500MinGustRampSpeed=1MaxGustRampSpeed=200MinVarTime=5MaxVarTime=50MinVarRampSpeed=10MaxVarRampSpeed=75TurbulenceScale=1.000000DefaultVisibility=0DynWx_MedianDewPointSpread=10.000000DynWx_ProbCloudFormForMedianDewPoint=0.000500DynWx_MaxDewPointSpread=50.000000DynWx_ProbCloudFormForMaxDewPoint=0.000125DynWx_ProbCloudFormForMinDewPoint=0.100000DynWx_DryTempLapsePer1000Meters=9.000000DynWx_ProbCloudFormForDryTempLapse=0.000500DynWx_MoistTempLapsePer1000Meters=3.300000DynWx_ProbCloudFormForMoistTempLapse=0.040000DynWx_MaxProbCloudChangePerMinute=0.040000DynWx_MultiplierForDynamicWeatherLevelMild=0.500000DynWx_MultiplierForDynamicWeatherLevelNormal=1.000000DynWx_MultiplierForDynamicWeatherLevelHigh=3.000000DynWx_MultiplierForDynamicWeatherLevelExtreme=10.000000DynWx_TempChangePercentageForOvercastClouds=0.750000DynWx_TempChangePercentageForMinDewPoint=0.700000DynWx_MaxTempChangePerMinute=0.060000WeatherServerAddress=fs2k.zone.comWeatherServerPort=80WeatherGraphDataInDialog=0DynamicWeather=3LOADWEATHER=1MAX_UNLIMITED_VIS=128747CLOUD_DRAW_DISTANCE=43D_CLOUD_PERCENT=100DETAILED_CLOUDS=1CLOUD_COVERAGE_DENSITY=7DownloadWindsAloft=0DisableTurbulence=0CloudsImpostorRingRadius=64000.000000[iNTERNATIONAL]ASLAT=2ASLON=1MEASURE=0[MISC]COM_RATE=7LOG_TIME=0FOREIGN_TRANSLATOR=0LOG_FILE=[sTARTUP]DEMO=0LOADSIM=1LOADWINDOW=1SHOW_OPENING_SCREEN=1STARTUP_DEMO=[GRAPHICS]FULL_SCREEN=0PERFORMANCE_MODE=0DEF_PERF_MODE=7TEXT_SCROLL=1AUTO_LOD=0DETAIL_TEXTURE=1WATER_EFFECTS=0TERRAIN_USE_VECTOR_MAP=1TERRAIN_USE_VECTOR_OBJECTS=1EFFECTS_QUALITY=2GROUND_SHADOWS=0SMOOTH_VIEW=1IMAGE_SMOOTHING=1TEXTURE_MAX_LOAD=512COCKPIT_HIGH_LOD=1AIRCRAFT_SHADOWS=0LANDING_LIGHTS=1IMAGE_QUALITY=0TEXTURE_BLDG=1TEXTURE_GND=1TEXTURE_WATER=1AIRCRAFT_TEXTURE=1SEE_SELF=1TEXTURE_QUALITY=3LOD_TARGET_FPS=17NUM_LIGHTS=8[REALISM]INDASPD=0PFactor=0.000000Torque=0.000000GyroEffect=0.000000CrashTolerance=0.000000General=1.000000UnlimitedFuel=FalseTrueAirspeed=FalseAutoCoord=FalseRealMixture=TrueStressDamage=FalseGEffect=FalseManualLights=TrueGyroDrift=FalseCrashWithDyn=FalseCrashDetection=0[CONTROLS]KBDAIL=64KBDELEV=64KBDRUD=64PAN_RATE=400[uSERINTERFACE]MAP_ORIENTATION=2PAUSE_ON_LOST_FOCUS=0PROMPT_ON_EXIT=1PageID=3OpenATCOnCreate=0SITUATION=SelectFlightLevel=0SelectFlightTitle=0[sOUND]SOUND=1SOUND_FADER1=0.500000SOUND_FADER2=0.100000SOUND_FADER3=0.300000SOUND_FADER4=0.800000SOUND_FADER5=0.500000SOUND_FADER6=-0.800000SOUND_QUALITY=2[DISPLAY.Device.Radeon X1600 Series.0]Mode=1280x960x16[DISPLAY]UPPER_FRAMERATE_LIMIT=25TEXTURE_BANDWIDTH_MULT=100TextureMaxLoad=10[TERRAIN]TERRAIN_ERROR_FACTOR=70.000000TERRAIN_MIN_DEM_AREA=10.000000TERRAIN_MAX_DEM_AREA=100.000000TERRAIN_MAX_VERTEX_LEVEL=19TERRAIN_TEXTURE_SIZE_EXP=8TERRAIN_AUTOGEN_DENSITY=2TERRAIN_USE_GRADIENT_MAP=1TERRAIN_EXTENDED_TEXTURES=0TERRAIN_DEFAULT_RADIUS=0.000000TERRAIN_EXTENDED_RADIUS=0.000000TERRAIN_EXTENDED_LEVELS=232[sCENERY]IMAGE_COMPLEXITY=2DYNAMIC_SCENERY=1DYN_SCN_DENSITY=2DAWN_DUSK_SMOOTHING=0SUNGLARE=0LENSFLARE=0[AIRtoCONTAINER]SIM1=Cessna Skylane 182R RGSIM2=Learjet 45SIM3=Schweizer 2-32 SailplaneSIM4=Sopwith CamelSIM5=Extra 300SSIM6=Boeing 737-400[APL]CACHE_WAV_FILES=1[TrafficManager]TrafficDensity=40IFROnly=0EnableAirline=1EnableGeneralAviation=1[AContain]ShowLabels=1ShowUserLabel=0ShowLabelManufacturer=0ShowLabelModel=1ShowLabelTailNumber=0ShowLabelDistance=0ShowLabelAltitude=0ShowLabelAirline=0ShowLabelAirlineAndFlightNumber=0ShowLabelFlightPlan=0ShowLabelContainerId=0ShowLabelAirspeed=0ShowLabelHeading=0LabelDelay=3000LabelColor=FFFF0000[sLEW]MaxLateralRate=40000.000000MaxVerticalRate=1000.000000MaxPitchRate=360.000000MaxBankRate=360.000000MaxHeadingRate=360.000000[VirtualCopilot]VirtualCopilotActive=0[MULTIPLAYER]ALWAYS_SHOW_INITIAL_DIALOG=1SESSION_NAME=SquawkBox (jeffrey)PLAYER_NAME=DAL600GUARANTEED_MESSAGES=0MAX_PLAYERS=8MAX_OBSERVERS=0TICKS_PER_SYNC=90PACKETS_PER_SEC=4COLLISION_SECS=2FOLLOWING_MULTIPLIER=5ALLOW_PLANE_MODEL_SEND=0ALLOW_PLANE_MODEL_RECEIVE=0ALLOW_TEXTURE_SEND=0ALLOW_TEXTURE_RECEIVE=0MAX_SEGMENT_SIZE=100MAX_SEGMENTS_PER_SEC=1CONNECTION_TYPE=0PROTOCOL_SELECTION=0ALLOW_DESCRIPTIVE_SEND=1ALLOW_DESCRIPTIVE_RECEIVE=1AUTOPILOT_LOCK=0DISTANCE_DISPLAY=0ADF_TRACK=0ALLOW_NAME_TAG_DISPLAY=1CLIENT_CONNECT_USE_CUSTOM_PORT=0CLIENT_CONNECT_PORT=23456CLIENT_HOST_USE_CUSTOM_PORT=0CLIENT_HOST_PORT=23456HOST_CONNECT_USE_CUSTOM_PORT=0HOST_CONNECT_PORT=23456[sIM]SYSCLOCK=1[ATC]AutoOpenAirTrafficWindow=0UsePilotVoice=1ShowATCText=0PilotVoice=1[MAIN]Location=497,190,1145,716HideMenuNormal=0HideMenuFullscreen=1Maximized=1[FACILITIES]COUNTRY=STATE=CITY=GTL_BUTTON=6225[FlightPlanMap]SHOW_AIRPORTS=1SHOW_VORS=1SHOW_NDBS=1SHOW_APPROACHES=1SHOW_INTERSECTIONS=1SHOW_VICTOR=0SHOW_JET=0SHOW_AIRSPACE=1SHOW_FLIGHTPLAN=1SHOW_WEATHERSTATIONS=0SHOW_WEATHERSYSTEMS=0SHOW_DATATAGS=1SHOW_TERRAIN=1show_waypoints=1show_airways=1show_markers=1show_volume_boundaries=1show_ac_twr=1[KEYBOARD_MAIN]SELECT_1=49,8SELECT_2=50,8SELECT_3=51,8SELECT_4=52,8MINUS=189,8PLUS=187,8ZOOM_1X=8,8SOUND_TOGGLE=81,8ENGINE=69,8SIM_RATE=82,8XPNDR=84,8SLEW_TOGGLE=89,8EGT=85,8SMOKE_TOGGLE=73,8STROBES_TOGGLE=79,8PAUSE_TOGGLE=80,8PAUSE_TOGGLE#1=19,8ATC=192,8ATC#1=145,8ADF=65,8VIEW_MODE=83,8HEADING_GYRO_SET=68,8DME=70,8GEAR_TOGGLE=71,8ANTI_ICE_TOGGLE=72,8JET_STARTER=74,8JOYSTICK_CALIBRATE=75,10ALL_LIGHTS_TOGGLE=76,8SITUATION_SAVE=186,8VIEW_WINDOW_TO_FRONT=222,8AP_MASTER=90,8FREQUENCY_SWAP=88,8COM_RADIO=67,8VOR_OBS=86,8BAROMETRIC=66,8NAV_RADIO=78,8MAGNETO=77,8BRAKES=190,8SPOILERS_TOGGLE=191,8SITUATION_RESET=186,10FLAPS_UP=116,8THROTTLE_FULL=115,8THROTTLE_INCR_SMALL=114,8THROTTLE_DECR=113,8FLAPS_DOWN=119,8THROTTLE_CUT=112,8VIEW=111,8ELEV_TRIM_DN=36,8ELEV_DOWN=38,8INCREASE_THROTTLE=33,8AILERONS_LEFT=37,8CENTER_AILER_RUDDER=12,8AILERONS_RIGHT=39,8ELEV_TRIM_UP=35,8ELEV_UP=40,8DECREASE_THROTTLE=34,8VIEW_FORWARD=38,41VIEW_FORWARD_RIGHT=33,41VIEW_RIGHT=39,41VIEW_REAR_RIGHT=34,41VIEW_REAR=40,41VIEW_REAR_LEFT=35,41VIEW_LEFT=37,41VIEW_FORWARD_LEFT=36,41VIEW_DOWN=12,41RUDDER_LEFT=45,8RUDDER_RIGHT=135,8BRAKES_LEFT=122,8BRAKES_RIGHT=123,8AP_ATT_HOLD=84,10AP_LOC_HOLD=79,10AP_APR_HOLD=65,10AP_HDG_HOLD=72,10AP_ALT_HOLD=90,10AP_WING_LEVELER=86,10AP_BC_HOLD=66,10AP_NAV1_HOLD=78,10EXIT=67,10ABORT=3,10READOUTS_FLIGHT=90,9PANEL_TOGGLE=219,9VIEW_MODE_REV=83,9PANEL_LIGHTS_TOGGLE=76,9LANDING_LIGHTS_TOGGLE=76,10PARKING_BRAKES=190,10MINUS_SHIFT=189,9PLUS_SHIFT=187,9FLAPS_INCR=118,8FLAPS_DECR=117,8PROP_PITCH_LO=115,10PROP_PITCH_INCR_SMALL=114,10PROP_PITCH_DECR=113,10PROP_PITCH_HI=112,10MIXTURE_RICH=115,11MIXTURE_INCR_SMALL=114,11MIXTURE_DECR=113,11MIXTURE_LEAN=112,11SCRIPT_EVENT_1=219,10SCRIPT_EVENT_2=221,10YAW_DAMPER_TOGGLE=68,10CENTER_NT361_CHECK=57,11CLOSE_VIEW=221,8NEW_VIEW=219,8NEW_MAP=221,9NEXT_VIEW=9,10PREV_VIEW=9,11VIEW_TYPE=83,10VIEW_TYPE_REV=83,11RADIO_VOR1_IDENT_TOGGLE=49,10RADIO_VOR2_IDENT_TOGGLE=50,10RADIO_DME1_IDENT_TOGGLE=52,10RADIO_ADF_IDENT_TOGGLE=53,10GEAR_PUMP=71,10SPOILERS_ARM_TOGGLE=191,9PITOT_HEAT_TOGGLE=72,9AP_AIRSPEED_HOLD=82,10AUTO_THROTTLE_ARM=82,9AUTO_THROTTLE_TO_GA=71,11LANDING_LIGHT_UP=38,11LANDING_LIGHT_DOWN=40,11LANDING_LIGHT_LEFT=37,11LANDING_LIGHT_RIGHT=39,11LANDING_LIGHT_HOME=12,11PAN_RESET=46,9KNEEBOARD_VIEW=121,8MP_PLAYER_CYCLE=84,11MP_PLAYER_SNAP=70,11MP_GO_OBSERVER=79,11MP_CHAT=221,11MP_ACTIVATE_CHAT=13,8PANEL_1=49,9PANEL_2=50,9PANEL_3=51,9PANEL_4=52,9PANEL_5=53,9PANEL_6=54,9PANEL_7=55,9PANEL_8=56,9PANEL_9=57,9AP_MACH_HOLD=77,10VIEW_FORWARD_UP=38,42VIEW_FORWARD_RIGHT_UP=33,42VIEW_REAR_RIGHT_UP=34,42VIEW_REAR_UP=40,42VIEW_REAR_LEFT_UP=35,42VIEW_FORWARD_LEFT_UP=36,42VIEW_UP=12,42INVOKE_HELP=191,10INVOKE_HELP#1=191,11TOGGLE_AIRCRAFT_LABELS=76,11ENGINE_AUTO_START=69,10INC_COWL_FLAPS=86,11DEC_COWL_FLAPS=67,11USER_INTERRUPT=27,8AILERON_TRIM_LEFT=37,10AILERON_TRIM_RIGHT=39,10RUDDER_TRIM_LEFT=45,10RUDDER_TRIM_RIGHT=135,10TOGGLE_FLIGHT_DIRECTOR=70,10TOGGLE_AFTERBURNER=115,9TOGGLE_MASTER_BATTERY_ALTERNATOR=77,9TOGGLE_AIRCRAFT_EXIT=69,9PANEL_HUD_TOGGLE=87,8SNAP_TO_PANEL=45,41MARKER_SOUND_TOGGLE=51,10TOGGLE_WATER_RUDDER=87,9TOGGLE_PUSHBACK=80,9KEY_CHASE_VIEW_NEXT=87,10KEY_CHASE_VIEW_PREV=87,11HEADING_BUG_SELECT=72,11ALTITUDE_BUG_SELECT=90,11CHASE_VIEW_TOGGLE=81,10EYEPOINT_UP=13,9EYEPOINT_DOWN=8,9EYEPOINT_RIGHT=13,11EYEPOINT_LEFT=8,11EYEPOINT_FORWARD=8,10EYEPOINT_BACK=13,10EYEPOINT_RESET=32,8AIRSPEED_BUG_SELECT=82,11TOGGLE_TAILWHEEL_LOCK=71,9ROTOR_BRAKE=66,9ROTOR_CLUTCH_SWITCH_TOGGLE=190,9ROTOR_GOV_SWITCH_TOGGLE=188,9VIRTUAL_COPILOT_TOGGLE=88,11VIRTUAL_COPILOT_ACTION=88,10[KEYBOARD_SLEW]SLEW_TOGGLE=89,8SLEW_ALTIT_UP_FAST=115,8SLEW_ALTIT_UP_SLOW=114,8SLEW_ALTIT_FREEZE=113,8SLEW_ALTIT_DN_FAST=112,8SLEW_ALTIT_PLUS=81,8SLEW_ALTIT_MINUS=65,8SLEW_PITCH_DN_FAST=119,8SLEW_PITCH_DN_SLOW=118,8SLEW_PITCH_FREEZE=117,8SLEW_PITCH_UP_FAST=116,8SLEW_PITCH_PLUS=57,8SLEW_PITCH_MINUS=48,8READOUTS_SLEW=90,9SLEW_BANK_MINUS=36,8SLEW_AHEAD_PLUS=38,8SLEW_BANK_PLUS=33,8SLEW_LEFT=37,8SLEW_FREEZE=12,8SLEW_RIGHT=39,8SLEW_HEADING_MINUS=35,8SLEW_AHEAD_MINUS=40,8SLEW_HEADING_PLUS=34,8SLEW_RESET=32,8TOGGLE_AIRCRAFT_LABELS=76,11EYEPOINT_UP=13,9EYEPOINT_DOWN=8,9EYEPOINT_RIGHT=13,11EYEPOINT_LEFT=8,11EYEPOINT_FORWARD=8,10EYEPOINT_BACK=13,10I placed my plane at Craig Airport in Jacksonville Fl which is a GA airport very little in complex scenery and frames were 7-8 fps. Jeff

Share this post


Link to post
Share on other sites

Hi,Something is up with your system. There are age old machines that can run those FPS.It's always hard to troubleshoot these on a forum. Some things to look at:MB drivers.DirectX.Video driversBIOS settings.Run dxdiag and see if any tests run poorly.Jimhttp://www.hifisim.com/Active Sky V6 Development Team Active Sky V6 Proud SupporterHiFi Beta TeamRadar Contact Supporter: http://www.jdtllc.com/AirSource Member: http://www.air-source.us/FSEconomy Member:http://www.fseconomy.com/

Share this post


Link to post
Share on other sites

Hi Jeff, sorry to hear of your problems. I agree with the others that this seems like system issues. We have almost identical rigs and your performance should be much better. Are you trying to fly in full-screen or windowed mode?Aside from the other good suggestions, I might also look at how much heat you may be developing, especially your video board. I use ATI Tray Tools to give me my VC and system enviroment temps. Otherwise, something like Motherboard Monitor works as well. I also wonder if your PSU is up to the task under load? What's it rated for?Hope it helps.Regards, KendallDell 8400 3.2 GHZ H.T.800 FSB/2MB L22 GB 533 DDR2X800XT 256MB/Catalyst driver - 6.12's6x EATM AA/16x HQ A/FDiamond Xtreme/Logitech X-530'sDual Monitor: Dell 2405/1905CH Yoke/Pedals

Share this post


Link to post
Share on other sites

Hey, My system is close to yours, vid card is different ATI 9800 pro I gig ramand at Craig with my settings I get 34 fps with my full cockpit including a working overhead panel with ton;s O'Stuff. I have included my FS9.cfg file for you to try. Save your own or rename it and replace with mine. NOTE********THE ONE CHANGE YOU WILL HAVE TO MAKE IS IN THE DISPLAY SECTION. Place your display ATI 1600 etc on that line square brackets and all. I have made a note on that line in the cgf file as well to Remind you. When all is done go test and post results.Douglashttp://forums.avsim.net/user_files/168436.jpghttp://forums.avsim.net/user_files/168437.jpg

Share this post


Link to post
Share on other sites

Services. How much stuff do you have running in the background when you are using FS? That can be a really big culprit with this kind of issue. When my system boots up it usually has 35 processes loaded, which is still not bad compared to many systems I've seen. Before I use FS, I always shut down my anti-virus (can be a cause all by itself) and I turn off all but minimum necessary processes. I use a nice little utility called SmartClose and when I start FS I have only 16 processes. Even on my system I can see a difference when I don't. Give it a shot.

Share this post


Link to post
Share on other sites

I want to thank everyone for their tips and I will try all when I get home Friday from the fire station and see how it goes. JeffG

Share this post


Link to post
Share on other sites

You should try FSAutostart. It shuts down any unnecessary services and programs and defrags memory. Dave

Share this post


Link to post
Share on other sites

Jeff, just so you can use this as a weather-vane,PS4 3.2ATI X800XT 256 meg With every slider (FS9) full on, I get 30 plus frames anywhere on the ground and approach, and 30 to 50 in the air.I have not turned off (tweaked) any XP services and have Norton's running in the background all the time.Definitely you should be getting mid to high 20's.Sound's like a hardware issue.Mitch R.

Share this post


Link to post
Share on other sites

Jeff... was sometime ago you posted this... have you got any solution to this issue yet, since I have the same problem, and as far as I concern it's something strange going on. The fps is constant at 7 fps, even if I set to minimal graphic settings, or even ultra full... it is still 7 fps. I have also changed video drivers, no luck. Still haven't installed fs9 again, will do that. But I would guess something with fs... since I've tried the stuff everyone talking about. My thing happened just over ne night. I run fs without problms, and when I woke up the next morning, everything was crap. Have no idea, have you solved this yet?Thanks

Share this post


Link to post
Share on other sites

Seeing Mitch;s performance in FS makes me start to think something is up with my system. Im lucky if I lock at 30. Or is this normal for a aging system like mine? My vid card is a generation or two newer than his. And back in the day or P4 vs AMD, the AMD's won. Not the case today though. Should I be getting better fps? If I load my sliders, Its a ppt presentation. Even with half sliders like mine, im high teens to mid 20's.

Share this post


Link to post
Share on other sites

In high traffic areas with 51% AI (UT using tweaked Ardvark and EVAI stuff) I get the same mid 20's range using add on stuff (PMDG planes and Fly Tampa airports for example).16XAF 4XAA 1600X1200X32

Share this post


Link to post
Share on other sites

I think I located my problem to why I got the low framerates that weren't "movable" when pulling the sliders down.I found out that when I installed my microsoft force feedback pro (the first version they made, not the second) I got my frames locked at 7 fps. As soon as I deleted the joystick from the list in windows, the frames got back up. I tried this several times just to be sure. And that's it. Why this happen I have no idea, but I tried to disable forece feedback inside fs2004 (this was only a long shot). And guess what, the frames got up again. The fact that I doesn't have the cables (can't find them) to get force feedback, it didn't matter. The thing is it has always worked before. Should I post this somewhere else for other to see? Since I've asked this question before, and never got an answer like this. What do you think?

Share this post


Link to post
Share on other sites

In the clouds, Im typically bouncing around at 15-20. Id be happy if I could get mid 20's. Even in the PMDG VC, I get about 13-15 just panning.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this