Sign in to follow this  
hmar

Undeclared OOM (Out Of Memory) errors?

Recommended Posts

Hi,There is a tweak to sharpen the virtual cockpit by a setting in fS9.cfgunder the "Panels" section:VIRTUAL_COCKPIT_TEXTURES_SCALE=2.0However I got in troubles with Out Of Memory errors on a 2Gbyte machine ,with heavies however and mostly while switching between panels but sometimes also without reason. Today I removed the line from above and it seems that my OOM errors are gone! Hugo

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>Interesting, have never seen this one.Me neither; totally new one for me. Anyone else messed with this setting and seen results (for good or ill)?

Share this post


Link to post
Share on other sites

Hello,Get this...I too heard about this one some time ago that FS9 was having some problems with 2GB of RAM.Anyways, I used to have 1GB and today I actually upgraded to 2 GB by adding 2 more sticks of 512 MB.I tried to start FS9 and it said that my system didn't have enough memory. I have both FSX and 9 on the same PC so I decided to go and check that out on FSX, no problem other than poor FPS. Closed it down and re-attempted to run FS9. It started no problem. :-hmmm

Share this post


Link to post
Share on other sites

Been running mine (FS9) with 2GB ram for a couple years now and no problems.I only get OOM errors with the F1 Super80 on flights longer than an hour.Shame too as I really love that plane.

Share this post


Link to post
Share on other sites

I was thinking of getting 2 gigs. Maybe I'll stay with 1 gig.JimCYWG

Share this post


Link to post
Share on other sites

"I tried to start FS9 and it said that my system didn't have enough memory."Yes, but did you also increase your Virtual Memory setting?

Share this post


Link to post
Share on other sites

To change Virtual Memory:System > Advanced > Performance > Settings > Advanced > Virtual Memory > Change > check either Custom Size or System Managed and enter new value (usually 1.5 the amount of RAM installed, so for 2Gb RAM make it 3Gb).

Share this post


Link to post
Share on other sites

I've only been out of memory in one spot in over 6 months. I had a memory leak somewhere in Switzerland that was gobbling away the memory even when paused and got that fixed. You won't have a problem with 2 Gb, in fact you will be all smiles. I set my VM for 2 gb. default and 4 mb. max. If it's using half that much VM it will be stuttering so bad you won't fly anyway.

Share this post


Link to post
Share on other sites

>>I only get OOM errors with the F1 Super80 on flights longer>than an hour.>I had that problem, but having read somebody's tip in one of the forums, I changed the options so that it did not load all the 2D panels at startup, but only loaded them as needed. Once I'd done that, the OOM problems went away.

Share this post


Link to post
Share on other sites

>>>>I only get OOM errors with the F1 Super80 on flights longer>>than an hour.>>>I had that problem, but having read somebody's tip in one of>the forums, I changed the options so that it did not load all>the 2D panels at startup, but only loaded them as needed. Once>I'd done that, the OOM problems went away.Can anyone elaborate on it, please? Does it mean you can't use some of the panels in one flight session, or what do you mean by loading all the 2D panels at startup (same as opening?)?Thanks.

Share this post


Link to post
Share on other sites

>To change Virtual Memory:>>System > Advanced > Performance > Settings > Advanced >>Virtual Memory > Change > check either Custom Size or System>Managed and enter new value (usually 1.5 the amount of RAM>installed, so for 2Gb RAM make it 3Gb). This is wrong advice if your're using Win XP as your operating system. You should check the box to let windows manage your page or VM memory. 1 gig of quality ram is perfect for FS9. I would recommend running "File Monitor" at the same time as FS9 to see what files FS is trying to access when out of memory occurs.That tip was for older oS's ie WIN 98 and earlier.I have 5 programs running at the same time when using FS9 and I don't experience any out of memory issues.Bill M

Share this post


Link to post
Share on other sites

Default System Managed VR is always set by XP at 1.5 times the amount of RAM installed. Yes, the tip did once apply to older OSs, but it still seems to hold true.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this