Archived

This topic is now archived and is closed to further replies.

JSACKS

3GB Enabler fix for FS2004 - Follow-up question

Recommended Posts

Well, thanks to some welcome assistance from Pedro Lima, I managed to instal the 3GB Enabler and edit my system for the 3GB switch. All seems to be working fine now. However, I do not observe any difference in frames or fluidity of the sim. My question is: am I supposed to see any difference in how the sim runs (i.e., should it run visibly smoother and more fluidly), or is this switch just hopefully going to ensure that I don't see any more OOMs (which is no small thing in itself) ? JS

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

FS9, if working properly, should't use more than 1,3-1,4GB of RAM. I turned off my swap file, and I never have any OOMs... Only if I start opening applications while flying, like Photoshop and similar. Then OF COURSE, an OOM might happen.

Share this post


Link to post
Share on other sites

Yeah, I hear ya, mate, but I did get an OOM even with 2GB RAM installed. Anyway, so far so good.I am now thinking actually about whether I should raise the RAM from 2GB to 3GB (in matched pairs of course) just to help things along a little more smoothly.JS

Share this post


Link to post
Share on other sites

Hi GuysCould somebody please point me towards any previous threads on this subject. I'd like to enable all my RAM.

Share this post


Link to post
Share on other sites

The 3GB switch is a fantastic find and after having many problems with OOM usually on finals in my favourite PMDG 747-400 albeit I was running lots of addons (radar contact,active sky, ultimate terrain, Fly Tampa airports etc etc) and I now able to complete 8 -10 hr flights even when my page file ends up at 2.2 GB in size....

Share this post


Link to post
Share on other sites

Does the sim run any SMOOTHER or MORE FLUIDLY on your PC after programming the 3GB switch ?JS

Share this post


Link to post
Share on other sites

I have 3GB, could you help me install the switch thing you're talking about, because my system only seems to recognize 2. Thanks!Jeff

Share this post


Link to post
Share on other sites

Don't ya just love it when folk do that..... rave about how good something they got is, but then keep it a secret....?

Share this post


Link to post
Share on other sites

My searches just end up in forums and all sorts of chat about it but I can't find the darn thing.

Share this post


Link to post
Share on other sites

Hello,Adding the 3GB switch is very simple. You first need to locate your machines Boot.ini file which should be located in the root of your main system drive. (Be aware that this file may be hidden and marked as read-only initially.) You will want to open this file in a program such as Notepad to edit it properly.Before adding the 3GB switch though it is important to note that the switch is very picky, and requires that every device and driver on your system be fully WinXP compatible in order to work at all. If anything in the system is not compatible, Windows will not load at all when restarting with the 3GB switch activated. The only way to then remove the switch from the Boot.ini file so that Windows can load is to either mount the drive in another system and manually change the boot.ini file, or reformat the drive and re-install Windows. Both solutions are far from ideal.To safely add the 3GB switch we recommend adding a second instance of the OS in the boot.ini, and add the /3GB switch to that second version.----- default boot.ini without 3GB Switch -----This is what a default boot.ini file will look like. (This may differ from system to system.)[boot loader]timeout=30default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS [operating systems]multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Pro"======================================================================----- updated boot.ini with 3GB Switch -----This is what the updated version should look like. Notice the /3GB that has been added to the second instance of the OS line.[boot loader]timeout=30default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS [operating systems]multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Pro"multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Pro with /3GB" /3GBOnce you have updated your boot.ini file accordingly and have saved the changes, simply restart your system for the changes to take affect. When your system reboots you will be given the option to choose either the standard Windows XP version or the 3GB switch enabled Windows XP version. If you choose the 3GB version and it fails to allow Windows to properly load, just restart your system and you will be given the two options once again, where you can then choose the standard Windows XP version to load. Either way, if it works or doesn't, you can then remove whatever line you don't need in the boot.ini file. Alternately, you may wish to leave both settings so that you can choose to boot without the 3GB switch should you ever have problems with drivers installed in the future. The boot loader will default to the first option listed in the file. So you may want to put the /3GB option first. You may also wish to lower the timeout value to something quicker so that you don't have to wait for 30 seconds or press enter with each boot.

Share this post


Link to post
Share on other sites

Dougal,You have to modify your FS9.exe to use more virtual address space than 2GB.I use a program called CFF explorer.I followed the advice in an earlier thread in the FSX forum and it fixed this prob for me in XP pro. There are detailed instructions there.I will search and post a link...... if I can find it.Stu.Here it is, posted by Markus: QUOTEI got several Out of memory erros when I fly with the great Alphasim SR71 longer distances. Sometimes the error occured five minutes after takeoff. The error occured under SP1 too.So I tried a solution I found for make STALKER ready for run with Windows Vista. The solution seems to work with FSX too. I got no error on flights which crashed before regulary with OOM.Try this only if you have at least 2 GByte of RAM and at your own risk.First download the explorer from http://www.ntcore.com/exsuite.phpNext make a copy from fsx.exe. Than start "CFF Explorer" and open the orginal fsx.exe file.Now go to NT Header/File Header and click File Header. Ther you find a button labeld "click here". Click it. And select the mark at "App can handle> 2gb adressest "Save the modified EXE, overwrite the orginal one (You have youre copy saved?).If you run Windows Vista 64 or Windows XP 64 youre ready and didnt need to read on. The rest is only for Windows Vista 32 or maybe Windows XP.Now make Windows Vista (32-Bit) ready to support more than 2 GByte.Open a command prompt with Administration rights. You find it under "Programs->Accessories->Command prompt" click right and select "run as administrator".Enter "bcdedit /set IncreaseUserVA 3072" (without quotes) in the command window and press enter.After that restart windowsFor Windows XP there is a similar setting for the boot.ini, but I have no Link to it, should be found be google.For me it solve the problem.Too reset the Increased User Adressspace just start the commandline prompt with Admin right again and enter "bcdedit /set IncreaseUserVA 2048"Please post youre results here, so we can see if this is a solution or a workaround only.ByeMarkusUNQUOTE.Here is my WinXP boot.ini file for your comparison[boot loader]timeout=30default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS[operating systems]multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /3GB /userva=2560All the best Stu.

Share this post


Link to post
Share on other sites

I understand the interest that others have in this procedure but I would like to repeat my original question (see top of thread) as follows in the hope that somebody will be able to address it for me. Here goes:" Am I supposed to see any difference in how the sim runs (i.e., should it run visibly smoother and more fluidly), or is this switch just hopefully going to ensure that I don't see any more OOMs (which is no small thing in itself) ? "Thanks !JS

Share this post


Link to post
Share on other sites

Thank you for this detailed write up. I also found the Microsoft link to their discription on this.I am OK with trying this, ie not frightened to "mess" around with my computer, in fact I do a lot of things technical so I understand this.Now I am wondering, do you think this word improve FPS or blurries in FSX?

Share this post


Link to post
Share on other sites

NoYou wont notice any difference in smoothness or fluidity.... but it will remove those nasty OOM's... Bye the way I see you are still trying to find a fix for those oversized lights on Aerosofts Heathrow scenery when using the Matrox Triple Head 2 Go... have you had a reply from the support team?

Share this post


Link to post
Share on other sites

Thanks for help here, and sorry to the original poster for hijacking the thread.I'm running a dual boot system - XP-Pro & Vista HP. It appears that i have no operational boot.ini file.Under Vista i installed the recommended 'VistaBootPRO_3.3.0' which takes over the boot process.Does this mean i can't install the switch?

Share this post


Link to post
Share on other sites

OK, Hamish, thanks, nice to get a reply to the question! Much appreciated.Re Heathrow 2008, no response whatsoever despite posting on the developers' forum at simflight and writing two emails to the company direct with 13 attached screenshots of the problem. How's that for customer service? ("Thank you for a lovely product")!JS

Share this post


Link to post
Share on other sites

>FS9, if working properly, should't use more than 1,3-1,4GB of>RAM. I turned off my swap file, and I never have any OOMs...>Only if I start opening applications while flying, like>Photoshop and similar. Then OF COURSE, an OOM might happen.I get a window pop up saying error encountered, and have to close, while still running. While running several internet and email applications I get a system crash! Monitor just turns itself off, and computer stays on, like nothing happened.

Share this post


Link to post
Share on other sites