Sign in to follow this  
Noel

Does anyone know what variables in FS9.cfg affect the zone of sharpness?

Recommended Posts

As I look topdown (with a zoom level that gives a diameter of about 50 miles) from FL350 I see razor sharpness up to about 15 miles from center, then quite obviously the sharp textures stop and replaced by some blurrier textures from there on out. You can see some swapping around of this super sharp/super soft texture loads and I wonder what each of the texture variables in FS9.cfg actually affect. My system runs FS9 flawlessly, but I do wonder if there isn't a way to FORCE the sim to retain more of those sharper textures AT HIGH ALTITUDE. At lower levels is very crisp. Here are my current settings. I'm hoping to get solid information about what actually variables each one affects, and what sorts of numbers are VALID. I know there are lots of testimony about what works n doesn't but does anyone truly understand what the programmers were manipulating with these variables?[DISPLAY.Device.NVIDIA GeForce 8800 GT.0]Mode=1600x1200x32TriLinear=1[DISPLAY]UPPER_FRAMERATE_LIMIT=41TEXTURE_BANDWIDTH_MULT=280TextureMaxLoad=7 RUNWAY_LIGHTS_SURFACE_SCALAR=0.5 <---- My preferred option RUNWAY_LIGHTS_VASI_SCALAR=0.5 <---- ditto RUNWAY_LIGHTS_APPROACH_SCALAR=0.5 <---- dittoRUNWAY_LIGHTS_STROBE_SCALAR=0.5 <---- ditto[TERRAIN]TERRAIN_ERROR_FACTOR=100.000000TERRAIN_MIN_DEM_AREA=10.000000TERRAIN_MAX_DEM_AREA=100.000000TERRAIN_MAX_VERTEX_LEVEL=19TERRAIN_TEXTURE_SIZE_EXP=8TERRAIN_AUTOGEN_DENSITY=4TERRAIN_USE_GRADIENT_MAP=1TERRAIN_EXTENDED_TEXTURES=1TERRAIN_DEFAULT_RADIUS=9.500000TERRAIN_EXTENDED_RADIUS=4.500000TERRAIN_EXTENDED_LEVELS=4Much appreciate any insights you may have.NoelQX9650 w/ Retail HSF|8GB Muskin PC-6400|ASUS P5E|EVGA 8800GT @700|Seagate SATA 2 x 4|Seagate Cheetah 15K.x|XP Pro|Vista 64--soon to be installed

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>TERRAIN_DEFAULT_RADIUS=9.500000>TERRAIN_EXTENDED_RADIUS=4.500000>TERRAIN_EXTENDED_LEVELS=4Those are the variables you are looking for. 4 is however the highest number FS will recognize. Anything above 4 will have no effect.And since all 3 variables are set to max already you can't increase the zone of sharpness any further. That's just how the engine works.

Share this post


Link to post
Share on other sites

Interesting you should say that. How come the default FS9.cfg had a number in the hundreds of thousands for TEL?Heres my config if you are interested. I run an 8600GTS 256MB and I have zero blurries at FL300 out as far as I can see.[DISPLAY.Device.NVIDIA GeForce 8600 GTS.0]Mode=1920x1200x32TriLinear=1MipBias=8[DISPLAY]UPPER_FRAMERATE_LIMIT=30TEXTURE_BANDWIDTH_MULT=100TextureMaxLoad=10//RUNWAY_LIGHTS_SURFACE_SCALAR=0.5//RUNWAY_LIGHTS_VASI_SCALAR=0.5//RUNWAY_LIGHTS_APPROACH_SCALAR=0.5//RUNWAY_LIGHTS_STROBE_SCALAR=0.5[TERRAIN]TERRAIN_ERROR_FACTOR=100.000000TERRAIN_MIN_DEM_AREA=10.000000TERRAIN_MAX_DEM_AREA=100.000000TERRAIN_MAX_VERTEX_LEVEL=20TERRAIN_TEXTURE_SIZE_EXP=8TERRAIN_AUTOGEN_DENSITY=5TERRAIN_USE_GRADIENT_MAP=1TERRAIN_EXTENDED_TEXTURES=1TERRAIN_DEFAULT_RADIUS=9.500000TERRAIN_EXTENDED_RADIUS=4.500000TERRAIN_EXTENDED_LEVELS=3

Share this post


Link to post
Share on other sites

Anyone heard of a detailed explanation by the developers about exactly what these variables affect, and their actual allowable variables? Very tough to get to the bottom of this subject!QX9650 w/ Retail HSF|8GB Muskin PC-6400|ASUS P5E|EVGA 8800GT @700|Seagate SATA 2 x 4|Seagate Cheetah 15K.x|XP Pro|Vista 64--soon to be installed

Share this post


Link to post
Share on other sites

I missed seeing your thread and posted a similar one just now. The sharp demarcation line between the hi-res horizon and that low-res one is awful. I hope there's some type of fix for this as well.EDIT: See my thread for some pics showing examples of the cut-off line.Here are my settings:[TERRAIN]TERRAIN_ERROR_FACTOR=100.000000TERRAIN_MIN_DEM_AREA=10.000000TERRAIN_MAX_DEM_AREA=100.000000TERRAIN_MAX_VERTEX_LEVEL=21TERRAIN_TEXTURE_SIZE_EXP=8TERRAIN_AUTOGEN_DENSITY=5TERRAIN_USE_GRADIENT_MAP=1TERRAIN_EXTENDED_TEXTURES=1TERRAIN_DEFAULT_RADIUS=9.500000TERRAIN_EXTENDED_RADIUS=5TERRAIN_EXTENDED_LEVELS=1307992

Share this post


Link to post
Share on other sites

Alexander I think it's built in to the game. I don't think anyone has come up with a workaround for this particular issue other than to decrease visibility. I did read some compelling stuff thatTERRAIN_MAX_VERTEX_LEVEL=21 is best left at 20 unless run 9m terrain.QX9650 w/ Retail HSF|8GB Muskin PC-6400|ASUS P5E|EVGA 8800GT @700|Seagate SATA 2 x 4|Seagate Cheetah 15K.x|XP Pro|Vista 64--soon to be installed

Share this post


Link to post
Share on other sites

Thank you, Noel. It's a shame, too, because everything else is working (and looking) fantastic. It's my only major gripe with FS9 at the moment. I'm surprised that there isn't an FS9.cfg setting that would simply push the higher-res horizon farther out.Thanks again, my friend.

Share this post


Link to post
Share on other sites

Howdy, Since no one replied to my message ( http://forums.avsim.net/dcboard.php?az=sho...id=39926&page=2 ) which has some of the same questions, I did some testing. And found this.TERRAIN_USE_GRADIENT_MAP= Sun/Dusk/Dawn smoothing, in UI 0/1TERRAIN_EXTENDED_TEXTURES= Show Extended textures, in UI 0/1I used "top down" view to test this.TERRAIN_DEFAULT_RADIUS=Always ON, EXCEPT at High Altitudes because your line of site overlooks the boundry, it may automatically shut off too. The number = Texture radius NM to show always divided by 10, MAX 45 miles.TERRAIN_EXTENDED_RADIUS=Reliant on the TERRAIN_EXTENDED_TEXTURES switch above, if OFF, or low setting, High altitudes textures can be comprimised. the number = Texture radius NM to show divided by 10, MAX 99 miles. TERRAIN_EXTENDED_LEVELS=Could be any number (why?) but if anything over 0 means the extended textures can be active. Not in UI. The number given by a rebuild of the .cfg "may" be a bandwith calculation. As mine = my frame rate * 10 from the CFG rebuild. See below - TEXTURE_BANDWIDTH_MULT=23 If you have ~0.5-1 second stutters fairly regularly the following key may help especially on a lower end system. It got rid of mine completely. AUTO_LOD=0 What happens here, if on, is that LOD is calculated by your FRate, if its near your FR lock it will increase the LOD. More buildings etc.. Hence the loading of more stuff = stutter during flight. Then it finds out it over did it. Erases the higher LOD, then repeats again. Another stutter.If you have the micro stutters 0.1 seconds or so. The following will help.TEXTURE_BANDWIDTH_MULT=23 FSInsider says for a 1:1 texture load without overload of GPU, it should equal your target frame rate. But most GPUs have a read ahead of 3 frames so should this equal FR + 3 ? Or, FR * 3 ? I am still testing this. I get more micro stutters at 132 than 23.. Mine used to be 400 uggh!! If too low the textures have to catch up. Blurry to suddenly sharp. Well anyway my FS experience has quadrupled.. It's like I got a brand new system.. Happy camper here.RomanProud "TEAM AVSIM" RTW race member.XP Pro, FS9, FR Locked @ 23, AMD 1800+ OCd to 1900+, APIC MProc Mod (24 IRQs), Latency Mods, ECS K7S5a V1.1, 7 fans, 1 gig, 100 & 60 Gig 7200rpm HD, ASUS/NVidia GeForce 64mb AGP on 21", NVidia FX5500 vivo 256mb (CRAP) on 18", Nvidia 93.71s ( The highest can go for the GeForce3 & 5500 combined ), Savage4 32mb on 15", BV services mods.

Share this post


Link to post
Share on other sites

A detailed investigation and explanation (more of a book, really) is available here, but it is in German. He also has some test scenery files that you can use to prove to yourself how those terrain cfg lines work.http://www.jobia.de/scott s..

Share this post


Link to post
Share on other sites

WOW!! A book i would say... Would anyone like to translate 502 pages from German to English?I caught some of it, looks well written and describes the scenery engine from step one.Roman Proud "TEAM AVSIM" RTW race member.XP Pro, FS9, FR Locked @ 23, AMD 1800+ OCd to 1900+, APIC MProc Mod (24 IRQs), Latency Mods, ECS K7S5a V1.1, 7 fans, 1 gig, 100 & 60 Gig 7200rpm HD, ASUS/NVidia GeForce 64mb AGP on 21", NVidia FX5500 vivo 256mb (CRAP) on 18", Nvidia 93.71s ( The highest can go for the GeForce3 & 5500 combined ), Savage4 32mb on 15", BV services mods.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this