Archived

This topic is now archived and is closed to further replies.

thepilot

nHancer and cloud textures

Recommended Posts

Hello guysI noticed that nHancer causes my framerate to go down rapidly when there is a solid overcast or a bunch of clouds in my sim.I average about 8-10 frames when it comes to that :(Yesterday I turned off nHancer and guess what? Same conditions, but this time 50 frames! I'm using ActiveSky's textures.Needless to say, I want to maintain this framerate -if possible- with nHancer...Anyone got a work around on this?Regards,

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Marius,I'm in the same position as you are, if you do find a cure then Please post it here to let us all know.Many thanks.

Share this post


Link to post
Share on other sites

which options and features are activated/deactivated in nhancer ? What type of clouds are installed (dxt3 or 32bit)?Ron

Share this post


Link to post
Share on other sites

just a guess, but nhancer enables aa at the driver level. So with clouds in the mix performance suffers. Simple as that, I think.

Share this post


Link to post
Share on other sites

Install and run the latest version of Nhancer. It does NOT need to boot with Windows or have a tray icon since the service runs in the background and will properly influence the settings. When it is first run select NO to have it run with Windows or have it place an icon on the tray. With any driver above 163.xx Nhancer can no longer delete the profiles as it did in the past, instead the way you OVERRIDE the FSX and FS9 profiles is do the following: NOTE: you can see IMAGES of the following settings at the BOTTOM of this thread: http://www.simforums.com/forums/forum_post...?TID=25186&PN=1a. Scroll down the profile list until you find the Microsoft Flight Simulator 2004 (or) Microsoft Flight Simulator X profile. Click on it once to highlight it. Once it is highlighted, click the DUPLICATE button. You will get a message, select YES to complete the duplication. What that will do is DEACTIVATE the Nvidia profile and ACTIVATE your new duplicate. b. With the new profile in the list, make sure there is a bullet in PROFILE on the right. Go down the list on the right and select the following: AA: For FSX select SUPERSAMPLING and 8xS (use 8xS Steve)NOTE: Slower cards and systems in FSX, set to MUTISAMPLING and 4X or SUPERSAMPLING and 4xS Under the next box, check GAMMA CORRECTION DO NOT ENABLE THE SECOND SUPERSAMPLE FEATURE IN THIS AREA UNCHECK "ENHANCED AA" if it is checked by defaultAF: CHECKED Bullet in: 16X VERTICAL SYNC: CHECKED, Bullet in: FORCE ONOPTIMIZATIONS Tab: Texture Filtering CHECKED Bullet in - High Quality Trilinear Opt CHECKED, Bullet in - Off Aniso. sample opt. CHECKED, Bullet in - Off Negative LOD BIAS, CHECKED, Bullet in - Clamp Check the next three items but do not change their values COMPATABILITY TAB: Place a CHECK in all header values but only change the following if needed: Force Mip-Maps = NONE Conformant Texture Clamp = ON Hi Dynamic Range HDR (Enabled)All others should be at their default values. Under the CPU Multicore Support, REGARDLESS OF THE TYPE OF CPU YOU USE: FOR WINDOWSXP SET CPU TO SINGLE FOR WINDOWS VISTA SET CPU TO MULTICORE Repeat the above for any other game profile as you may need it. c. In the main Nhancer Window, set the bullet to GLOBAL Set the SAME settings on GLOBAL as you did above. Close Nhancer and reboot. d. Open the Nivida Control panel (right click desktop, select Nvidia Control Panel) Show the ADVANCED settings. Under Managed 3D, make sure the Multi Display Mixed GPU is set to SINGLE DISPLAY MODE if you are ONLY using one video card and monitor. If you use more than one, leave the setting on defaultConfirm Vertical Sync is indeed set to FORCE ONClick APPLY. FOR LCD: Under

Share this post


Link to post
Share on other sites

Great config advise but nhancer's latest version 2.41 has been out for about three weeks now and is no longer labeled as a beta build.

Share this post


Link to post
Share on other sites

I had the same problem. I got my FPS back up after I binned nHancer. It also starts a background Service called Nhancer Support or something like that. I got it out of curioisity and then realized that the nVidia software that came with my card did the same thing lol so why would I need nHancer. The FPS-drop sealed its fate :(

Share this post


Link to post
Share on other sites

It's ok Maxihard just use the latest version - you can check for new beta's if you wish.Have you tried my suggestions listed above? Have they worked for you?Thanks.

Share this post


Link to post
Share on other sites

AFAIK, all nHancer does is set the video card driver settings in the registry or in the game profiles, same as nvidia control panel. It's just a different way of getting to the settings. At one point, you couldn't change a default game profile (that was included with the driver) using the nvidia control panel, so it was helpful for that. Once you have your settings, there is no need to run nHancer at all.scott s..

Share this post


Link to post
Share on other sites

Donnie that list I posted was when 2.41 was beta so use the release version

Share this post


Link to post
Share on other sites

Thanks guys but I'm not the one looking for help, this time anyway!

Share this post


Link to post
Share on other sites

When you say "it does not need to start with windows", it applies for the latest revision or any version?I have NhancerService.exe running in the background. Does it mean Nhancer acts?ThanksGhiom

Share this post


Link to post
Share on other sites

You do not need the service running.As said above, NHancer makes changes on the driver level, meaning once you make a chage it's changed in the driver.Nothing needs to run in the back ground once you make the change.

Share this post


Link to post
Share on other sites

I have this same issue.E6600 OC'd to 2.8GHz and SLi-ed 7950GT's and since installing nHancer to fix the Anti-aliasing problems, frames drop to less than 5 frames per second in FS2004 when many 3d clouds are around, or in a high density area.This is just getting ridiculous. Anytime one issue is resolved, it makes something else not work properly. Even setting the AA to '2x', I get the same performance. Single digits, anywhere.

Share this post


Link to post
Share on other sites

Well your paying for the great image quality with framerates.Try looking at FS9 with out NHancers "enhancements". It looks terrible, all jaggy and stair stepped.You can't smooth the jagged edges with no cost to performance. You can get away with that in most cases. But when you have a truck load of clouds to be rendered (like on a high over cast day) it would choke even the toughest of systems....

Share this post


Link to post
Share on other sites