Jump to content

Archived

This topic is now archived and is closed to further replies.

martinlest2

Can anyone explain this CTD?

Recommended Posts

I am posting this here rather than the CTD forum, as I solved the problem but thought someone here might have some reason for why I was getting a CTD with this scenery. It mysifies me rather ..Hi there.The proble was this: every time I landed at Helsinki airport, EFHK (a third-party add-on) I would get a CTD - one second I am taxiing to or from the runway, the next FS9 has just vanished. No error messages, the fs9.exe process just ends abruptly. I tried looking at what was happening with Process Monitor, but got no clues from that.So I gradually closed down all my active sceneries and retried at EFHK until I found the culprit, and then reactivated it and gradually removed bgl files from its scenery folder until I found the one or ones that were causing the problem. It came down to about half a dozen lwm_xxx bgl files in FinnTerrain. When I remove them, no CTD. Put them back - FS9 disappears from my screen.My questions..1. Why would these lwm files cause fs9.exe to shut off so abruptly? I tried disabling UT Europe, but even with all my other addons disabled, and after replacing my tweaked FS9/scenery/Eure/scenery folder (where all the Scandinavian files are of course) with the default folder from the FS9 CD-ROMs, I still get the CTD. Only when I remove about 6 files from the FinnTerrain scenery folder does the CTD stop happening. So waht's going on here?2. Why might I always get the CTD only after a delay of a few minutes of opening up a flight at the airport (or after landing there?)? For a good five minutes I can slew around the airport, change from cockpit to spot view and so on; then, it suddenly shuts off. Why this delay? (It made it a pain to troubleshoot, because after removing each scenery and/or bgl I had tpo wait 5-10 minutes to get, or not get, the CTD!).Maybe some guru here would have an idea about this. I'd really like to get some insight into what might have been going on, at a PC 'techy' level, if you like...Many thanks,Martin


Martin Stebbing, EGLF (UK)

Share this post


Link to post
Share on other sites

I am no guru...You may have duplicate AFCAD files in the area. Use ScanAFD available in the library. By switching back and forth between views in your 'heavy' addon scenery area the CPU might just give up....might all be too much for it. Also, and because I am a simple soul who learns things the hard way, your CPU or graphics card may be overheating. Have you dusted out your machine recently? I know it might sound a little crazy, but it happens.


Supporter.png

 

John

Share this post


Link to post
Share on other sites

I don't know if this has anything to do with it, but is your scenery.cfg file sorted so that entry Area.xxx and Layer=xxx are the same for all? Also, do any of those lwm bgl files contain both area fills and polygons?scott s..

Share this post


Link to post
Share on other sites

This is definitelya software thing, not hardware (if it were hardware related, the removal of 6 bgl files would have no effect after all). Without the 'rogue' files, I can switch back and forward between views OK, though I agree that it can be a strain on the resources and I do limit view changes at 'heavy' airports, like EGLL Xtreme etc.I only have the one AFCAD for the airport. And I use scenery_align (a very useful programme) and the Area and Layer nos. in the scenery.cfg file correspond 100% (would it be a problem if they didn't - never quite understood the difference between the two).Not sure if the lwm files have area fills and polygons. How would I check? (Could you say how that would be relevant?).Thanks for the replies,Martin


Martin Stebbing, EGLF (UK)

Share this post


Link to post
Share on other sites
This is definitelya software thing,
If it is a software thing alone then it ought to be reproducible. Which scenery addons are you using? Which are the offending .bgl files? Does the CTD happen with all aircraft? Have you turned off AI traffic. Are you running ASA, Radar Contact etc? Which OS? Did you turn off spyware, antivirus? Have much free space on your HDD? Did you dust out the case, fans etc?

Supporter.png

 

John

Share this post


Link to post
Share on other sites

It would only definitely be reproducible I imagine if someone had exactly the same FS9 setup as I do (on XP Pro SP2), which won't be the case. If the files themselves were at fault, on all machines, I am sure others would have reported the problem to the producers of FinnTerrain (and I see no such complaints online).I can't really list all the scenery addons I use - my file library has over 1000 of them. I only activate ones I am using (e.g. I have scenery in China, Europe, Australasia etc. turned off whilst flying in the USA). But that won't stop clashes - if you look at Process Monitor whislt FS9 is loading, files that are not active in scenery.cfg are still being loaded up, or at least, read. I have removed the files lwm_437_77.bgl through to lwm_437_85.bgl (9 files) and this stops the CTDs (which occur with all a/c and with Ultimate Traffic off too). 15GBs free space on the drive, almost zero defragmentation. With those files in the FinnTerrain scenery folder, I get the CTD with no other addons like Ultimate Terrain, ActiveSky, Ground Environment Pro etc. loaded. Spyware and antivirus are on the machine, but I set them up not to load at startup, as this machine is only used for FS and never connects to the internet. Files downloaded for FS9 & FSX are scanned on another PC that I use for all other purposes, including downloading FS stuff.To be honest, I have managed to get rid of probably a dozen CTD problems over the past few years by painstakingly locating bgl files that my PC doesn't like. If the problems were due to dust or whatever (the machine is not dusty, I checked - it was cleaned about 2 months back anyway), the CTDs wouldn't stop as soon as you removed a few files.I think I have to assume that the problem is definitely something to do with the bgl files on my machine. I am in fact A+ certified as a PC hardware engineer, so am pretty sure I can tell when a problem is hardware related. I really just wanted to find out why this bgls might be causing this problem on my setup - but I doubt anyone will be able to come up with a definite answer over the internet like this! I was just fishing for some ideas.Martin :-)


Martin Stebbing, EGLF (UK)

Share this post


Link to post
Share on other sites
This is definitelya software thing, not hardware (if it were hardware related, the removal of 6 bgl files would have no effect after all). Without the 'rogue' files, I can switch back and forward between views OK, though I agree that it can be a strain on the resources and I do limit view changes at 'heavy' airports, like EGLL Xtreme etc.I only have the one AFCAD for the airport. And I use scenery_align (a very useful programme) and the Area and Layer nos. in the scenery.cfg file correspond 100% (would it be a problem if they didn't - never quite understood the difference between the two).Not sure if the lwm files have area fills and polygons. How would I check? (Could you say how that would be relevant?).Thanks for the replies,Martin
They are just a couple theories I have but can't prove one way or the other. So theory 1 doesn't apply. To test theory 2 you could look at the files in lwmviewer 1.3 to see what the files contain. I don't have any really confidence in this theory, but it would be a data point. scott s..

Share this post


Link to post
Share on other sites

As you mention, Martin, there is insufficient information for a precise analysis. Since they are FS 9 files, you could probably try loading them in SBuilder for FS 9 and see if there are any missing L/WM polygons or Area Fills. Or, even worse, duplicate polygons, one over the other.But, without a close look at those files, all we can do is guess.Best regards.Luis


do.png Hot, humid Caribbean paradise!

Share this post


Link to post
Share on other sites

If Flight Simulator closes down instantly, it is probably a clash with other software or drivers. An internal error within Flight Simulator will usually result in a civilised shut down and an error message explaining why. The fact that you have pinned down some bgl files that stop the fault occurring when removed is only half-way there - I'm going to pluck an idea out of the air and say that those bgls call for some textures that are of a format that may be fine in FS but give something on your computer (the video card?) indigestion when they load. I have this add-on installed and don't experience the same as you do but there are plenty of reasons for us to differ. As to the solution - if upgrading drivers and shutting down unwanted software doesn't resolve the problem, and you can't trace the textures concerned and change them to something user-friendly (i.e. DXT3) then I don't know what to suggest. A change of screen resolution may help. A line to the author wouldn't go amiss, he may have heard from others with the same issue or may be able to come up with some ideas.John

Share this post


Link to post
Share on other sites

Thanks, Luis, Scott & John, for the input. I will try having a closer look at the lwm_ files in question, and see if I can spot anything amiss, but to be honest this isn't really my 'field of expertise'! I do have the software on my FS PC to do this though LWM Viewer etc.), so I'll certainly have a look at some stage soon.I think you are quite right John in what you say. (All of it!). I too wondered if it is a texture file problem, but whilst I am quite happy now analysing scenery bgl files (much thanks to Luis' helpful advice over the past few years!) and tracking down missing bitmaps (almost second nature now!), I am a lot less confident with files like this (or files containing only elevation data, that I haven't yet learned to 'crack'), but I will gve it a go - it was to learn about the cause of the CTD that I posted here in the first place of course. In practical terms though, I can't see any obvious adverse effects on the scenery though after removing these 9 bgl files, so as long as the problem is 'patched' in this way, I am happy.I wonder why FS9 just disappears from the screen in a fraction of a second, rather than freezing up and my finally getting an 'MSFS has encountered a problem .. blah, blah, blah' message, as sometimes happens in other cases. You think it shows a clash with drivers or software? Do the two types of CTD actually denotre a different cause?I did look for the author of the FinnTerrain, but in vain. I didn't try that hard though, I admit, so I'll look again - an email reply might be enlightening..Martin


Martin Stebbing, EGLF (UK)

Share this post


Link to post
Share on other sites
I wonder why FS9 just disappears from the screen in a fraction of a second, rather than freezing up and my finally getting an 'MSFS has encountered a problem .. blah, blah, blah' message, as sometimes happens in other cases. You think it shows a clash with drivers or software? Do the two types of CTD actually denotre a different cause?
As far as I know, yes. My own observations are that an instant exit from Flight Simulator is always caused by something external to FS, whether software or hardware. The most spectacular I have seen has been when using certain CD writing software - OK, I know good pilots don't write CDs in mid-flight but sometimes things are urgent . . . did I say in mid-flight, what flight? FS vanishes in a fraction of a second as soon as the writing process starts! Hardware or software I don't really know, but its a good example where an external issue is proved.Best wishes,John

Share this post


Link to post
Share on other sites
I did look for the author of the FinnTerrain, but in vain. I didn't try that hard though, I admit, so I'll look again - an email reply might be enlightening..Martin
Did you try this website? http://fisd.fsnordic.net/You must have FinnClass installed before you install FinnTerrain. I suggest you download from that site and, if you have not already done so, to read the manual. The Scenery Library install order is important too. John HPS. Just by way of interest, you mentioned that you checked that the numbering of Areas and Layers in the scenery.cfg corresponded. In fact, unlike FS2002, it doesn't seem to matter if they are the same or not in FS9. Don't ask me why.

Supporter.png

 

John

Share this post


Link to post
Share on other sites

Hi, yes, I suppose I must have read the manual when I originally installed it: I have FinnClass too, and all files in the right order..Thanks for the heads up,M.


Martin Stebbing, EGLF (UK)

Share this post


Link to post
Share on other sites

Hi. Well I am looking at the files now in lwm viewer v.1.1) and I can't see anything untoward, but that may be because I am not 100% sure what I should be looking for! I exported each file to a bitmap and I have areas of I suppose typical Finnish landscape - land (green?) dotted with lots and lots of small lakes (blue). The text file just shows the co-ordinates.I also tried in LWM Viewer v.2.0, but this is a bit beyond me. The window is a blank yellow grid each time. I think I'd best forget this line of questioning as I have no idea what I am seeing!Martin


Martin Stebbing, EGLF (UK)

Share this post


Link to post
Share on other sites

Hi Martin,I'm afraid I do not have any solutions for you. I only pop in here to tell you I have exact the same problem as you describe.With my old computer I had XP Pro 32 Bit 3.6 GHz Pnetium IV, 2.0 GB RAM and 9800GT Nvidia and I had that problemNow I have a new computer ie7 920 3.4 GHz, 6.0 GB RAM and GTX 275 first with Vista Home Premium and now W7 Home Premium. I re -installed all the Finnish sceneries exactely (once more) as the readme's tell and still have the same problem.As I encountered some problems at Rovaniemi EFRO after installing the mesh payware Global 2008I wonder if this can also causes some problems at EFHK, surroundings included.Do you happen to have the FS Global 2008 mesh as well ?Regards,CarlJust after writing the above I visited FsNordic Forum and found that maybe two bgl's in the scenery folder for Helsinki City, they are; mmaki.bgl_ and mmakipussit.bgl ; probably cause this CTD.I have removed them and so far I had no CTD's. Perhaps a little early to say, I crosss my fingers and hope though.

Share this post


Link to post
Share on other sites

×
×
  • Create New...