Archived

This topic is now archived and is closed to further replies.

KL Oo

Solve this and I'll send you a beer!

Recommended Posts

Hey guys,Everything on the old FSX computer has been running wonderfully since I upgraded to a 2500k, Windows 7 64Bit and 8 gig of RAM. So well in fact that the other day I thought to myself, why not try and see if I can network my notebook computer to my FSX box and enjoy EFB and ASE over a network!Well...All started off no problems. Did all the simconnect stuff, shared all the right folders and no problems getting either program to work over the wireless network in my house. Cool I thought. So I load up my CS767, place it at FSDT's KORD, fire up all the addons and off I go for a flight. Thats when I started to get problems.Immediately after taking off I started to get pauses of about 3 seconds in duration, every 20 seconds or so. The PC never crashed, just paused and then resumed as if nothing had happened. All addons working fine, simconnect working fine. No problems. So I started troubleshooting as you do. Turned off ASE and EFB to see if they where the culprit. Nope, re running the same scenario still caused the problem. Ok, removed all the simconnect files. No help, problem still persists. Ok I think, so I pull the USB wireless adapter out.......problem stopped immediately.....put the adapter back in....problem returns......pull adapter out...problem stops....adapter back in....problem returns.So its something to do with the network that is cause the pauses. I tried leaving my wireless adapter in for internet access, but turned off network discovery to ensure no other computer was accessing the FSX PC but the problem remains. Its only when the adapter is out that the problem goes away..WHAT THE HELL HAVE I DONE TO MY PERFECTLY FUNCTIONING FSX PC!!!Anybody got any ideas?I've tried it at different airports, still the same issue. I'm thinking something to do with FSUIPC or simconnect....what else might it be???Any advice warmly received!Should also mention I'm using RC4 (which isn't the problem as I've tried it without this with the same results) and UT2 which also doesn't seem to be the problem as it still occurs without UT2 running. No antivirus or firewall running on either PC at the moment. ThanksKael

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Well, I'm not so much into beer, but maybe you could try to temporarily disable Vistamare and the Addon Manager and see how it goes.Both stuff is used to drive AES (+lite) (Vistamare) and to enable all the FSDT features (Addon Manager) and may, if not running correctly, affect your sim in the described way.To disable the modules, check your dll.xml file for <Launch.Addon> <Name>VistaMare Core</Name> <Disabled>False</Disabled> <ManualLoad>False</ManualLoad> <Path>VistaMare\ViMaCoreX.dll</Path> </Launch.Addon>and <Launch.Addon> <Name>Addon Manager</Name> <Disabled>False</Disabled> <ManualLoad>False</ManualLoad> <Path>bglmanx.dll</Path> </Launch.Addon>Also check the exe.xml for <Launch.Addon> <Name>Couatl</Name> <Disabled>False</Disabled> <ManualLoad>False</ManualLoad> <Path>fsdreamteam\couatl\couatl.exe</Path> </Launch.Addon>I suggest to make a backup of the files and then delete the above entries which leads to the modules not being loaded.Of course, all stuff like AES or FSDT addons won't work then, but if your mentioned stutters then go away, you have a least a clue to investigate further.To get into the USB adapter thing, you would have to enable a view on the processes and the response time they get. Windows offers some performance monitoring (depends on the Windows edition in use) and e. g. Process Monitor (which is a free download) gives you more of that.So if the "easy" uninstallation and installation of the network adapter (together with current drivers, installed as admin and with antivirus off) doesn't help, this may be a way to go.The target is to really aim at the process which causes these hangs then.

Share this post


Link to post
Share on other sites
Immediately after taking off I started to get pauses of about 3 seconds in duration, every 20 seconds or so.
Maybe do you have autosave enabled in your FSUIPC module?Try to check it, if you have set autosave feature every 20 secs, so you've probably found the reason.On some systems (mine too) and only using certain models (it happens to me using feelthere E-Jets), the system pauses for some seconds during autosaving, and than resume normally.Maybe it could be related to the 64 bit file system? But I don't know why only using some models. I'm currently using the fantastic IFly 737, without any issue on the same system.Mauro

Share this post


Link to post
Share on other sites

Thanks for the replies guys.CoolIP in my endless Googleing the problem I had come across a few mentions of this issue with Addon Manager. I gave it a go as a method of elimination but no dice I'm afraid. Just out of curiosity, are any people who have that issue of pauses due to Addon Manager having it at airports that do NOT use Addon Manager?I will however follow your advice of uninstalling and reinstalling the network adapter....who knows.....?Zetato, thanks for the tip, I did check however and I do NOT have any saves happening..Something to do with the network adapter me thinks..

Share this post


Link to post
Share on other sites

It's your wireless adapter. I had exactly this same problem when I decided to use a remote laptop in conjunction with my main FSX computer over a network. In my case, I had a two-second pause within FSX that repeated precisely every 60 seconds.A good tool to use in troubleshooting this would be the free process monitor available from Microsoft at:http://technet.microsoft.com/en-us/sysinternals/bb896653This program is a far more feature-rich process monitor than the task monitor that comes built-in to Windows. It will show every running process on your computer, as well as how much CPU time each process is consuming. In my case, the program showed that the process assoociated with the driver for my wireless card was spiking to 100% CPU useage every 60 seconds.Based on a lot of Google research I did at the time on various hardware and online gaming forums, it appears that the spike is related to a type of "network discovery" refresh routine the wireless performs - but unfortunately it is NOT the same as the user-configureable discovery function that you disabled. It is a hardware-level routine that cannot be turned off without preventing the adapter from being able to maintain its connection to the rest of your wireless network.I tried a couple of different brands of wireless cards, both built-in (PCI) and USB, but had the same problem - only with the new cards, the CPU spike occured at different intervals. In one case, every 20 seconds, instead of every 60, just as you are experiencing.The only way I was able to solve the problem was to do away with wireless altogether on my FSX computer. I wired it directly to my router using an ethernet cable, and the problem was solved.Jim Barrett

Share this post


Link to post
Share on other sites

Jim,Thanks for that - that is what I figured was happening. I'm going to download that process monitor and see what I can see. Clear your fridge for some beer!Kael

Share this post


Link to post
Share on other sites

Well, something interesting happened!I had a look at the tool Jim mentioned above and ran all apps, across the network to see if I could see a connection between network usage and CPU usage.What I've seen is that each time FSX pauses for a moment, CPU usage drops completely. Normally, FSX runs anywhere from 30% - 60% on my machine (this is using Affinity Mask=14), however each time there was a pause, FSX usage would drop down to about 15%. There where no other apps or programs using CPU at the same time, overall usage just dropped right down in line with FSX usage.Does anybody have any other ideas what might be at play here? Its dropping evenly across all four cores, at completely random intervals of anywhere between 20-60 seconds.Cheers,Kael

Share this post


Link to post
Share on other sites

"The only way I was able to solve the problem was to do away with wireless altogether on my FSX computer. I wired it directly to my router using an ethernet cable, and the problem was solved."+1 FSX and wireless dont play well together

Share this post


Link to post
Share on other sites

Hi guys.This weekend I decided to make a trial on running FSX on my home network. I have a old system with Pentinum D so maybe my system could get some refief when running ASE and SB4. Here in Brazil, it's a long holiday so I'd have plenty of time in case I had to troubleshoot anything. Sorry about my poor english.I have my network set through a DSL-wireless router. My FSX system is connected to the router with cable, while my laptop uses wireless connection for ASE and SB4. I must say I didn't notice any strange behavior like pauses or slowdowns. The system is stable as before. Maybe with less stutters or more stable FPS, but I didn't make any "scientific" measurement on that.Maybe the difference is that all wireless network-related stuff is OUT of the computer... is on the router.Kael, I know you run W7, but this quote from Pete Dowson's WideFS may give you some clue..."...I have received reports that the automatic wireless network settings for Windows XP can cause problems with timing. The service searches automatically for new wireless networks, and whilst doing this the current connection can be actually paused for as long as 1.5 seconds. These interruptions not only reduce performance but can also cause errors in WideFS, resulting in re-connections, affecting busy programs such as ActiveSky‘s weather updates quite severely..."Try disabling this service, or any W7-related one, and see if the problem goes away. You could also try to set up a network like I did using a wireless router from a friend.Good luck. Duran.

Share this post


Link to post
Share on other sites

Interestingly, when I had the problem, it only affected my newest computer, a 2600K Windows 7 system. I originally had that computer, plus an older 2004-vintage AMD desktop connected to my router via CAT5 cables. A couple of months ago I needed to move my router to a different location, so decided to go wireless to avoid the trouble of having to run new ethernet cables through the walls and attic.I purchased two identical Netgear wireless PCI cards. The one in the new FSX Win7 machine had the constant CPU useage spikes every 60 seconds, and nothing I tried with settings or driver updates helped.Same model card on the old single-core AMD computer running XP, had no issues at allI finally gave in and ran new cables, which has been trouble free.Jim Barrett

Share this post


Link to post
Share on other sites

In device manager try disabling any power saving options for the wireless adapter

Share this post


Link to post
Share on other sites

Thanks for the many replies guys,

Kael, I know you run W7, but this quote from Pete Dowson's WideFS may give you some clue..."...I have received reports that the automatic wireless network settings for Windows XP can cause problems with timing. The service searches automatically for new wireless networks, and whilst doing this the current connection can be actually paused for as long as 1.5 seconds. These interruptions not only reduce performance but can also cause errors in WideFS, resulting in re-connections, affecting busy programs such as ActiveSky‘s weather updates quite severely..."Try disabling this service, or any W7-related one, and see if the problem goes away. You could also try to set up a network like I did using a wireless router from a friend.Good luck. Duran.
Thanks mate. I did see this post of Petes when searching the WideFS usuer manual. Whilst I remember playing with this service on my old XP machine, I couldn't find any similar thing win W7. It makes sense that its there, just couldn't see it. Any ideas what service it may be or what its called?
Interestingly, when I had the problem, it only affected my newest computer, a 2600K Windows 7 system. I originally had that computer, plus an older 2004-vintage AMD desktop connected to my router via CAT5 cables. A couple of months ago I needed to move my router to a different location, so decided to go wireless to avoid the trouble of having to run new ethernet cables through the walls and attic.I purchased two identical Netgear wireless PCI cards. The one in the new FSX Win7 machine had the constant CPU useage spikes every 60 seconds, and nothing I tried with settings or driver updates helped.Same model card on the old single-core AMD computer running XP, had no issues at allI finally gave in and ran new cables, which has been trouble free.Jim Barrett
Thanks again Jim - this may be what I end up doing, unfortunatly it means a LONG peice of cable to connect to the router... :(
In device manager try disabling any power saving options for the wireless adapter
Yeah already did that one. Thanks anyway tho...Looks like the wired option may be it.....what a pain this is....Cheers for the help anyway guys,

Share this post


Link to post
Share on other sites