Archived

This topic is now archived and is closed to further replies.

flyguy172

1 day fine, the next OOM errors with every flight

Recommended Posts

my system can perfectly handle the 747 and 737NGX with an FPS of 30yesterday I experimented with 2 things: I changed the LOD_RADIUS from 4.5 (default) to 5.5 under the terrain section of FSX.cfg, and secondly I tried increasing the cloud draw distance in FSX from the minimum I had it at (60 mi I think) to the max of around 130 mi or so.i was getting tired of not having a cloud cover from horizon to horizon when flying and the max cloud draw distance gave me that without any hit to FPS.last night though i was coming into the KJFK area and my FSX crashed with the OOM error message.today I flew the NGX into the KDTW area with lots of cloud cover and snow, and right after my wheels touched down on landing FSX crashed and I got the OOM message.does anyone know if either the LOD_RADIUS change or the cloud draw distance change could effect OOM errors on a system that normally runs everything fine?psmy system:i7 950 3.07GHz quadwin 7 64 bit8 GB ramNvidia 465 GTX

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Both. Yors taking a hit with those settings with your system I'm afraid

Share this post


Link to post

Oh yeah. They can both be hard hitters too. I'd reset them & play with only one setting at a time.

Share this post


Link to post

thanks guys, will try LOD @ 4.5 and maybe 100 mi. cloud draw distance

Share this post


Link to post

Gosh, a 64-bit OS and 8Gb of memory. I am surprised you're getting OOM errors. Just maybe there is something else going on?

Share this post


Link to post

what else could it be?as i said, i have flown without OOM errors for months, but as soon as I changed the LOD_RADIUS and the cloud draw distance, I got 2 in the same day

Share this post


Link to post

Up the page file allocation to 10 000 from whatever it was. I also had this a while a go but I'm sure this fixed it. Its only a two min job as well so worth a try. Im at work at the moment but just whack it into google.

Share this post


Link to post
Up the page file allocation to 10 000 from whatever it was. I also had this a while a go but I'm sure this fixed it. Its only a two min job as well so worth a try. Im at work at the moment but just whack it into google.
He's on a 64-bit OS with 8GB of RAM, page file size is only really critical on 32-bit systems with the 4GB total VAS limit. His PC has plenty of overhead to give FSX it's full allocation of address space 24/7. The problem is FSX is requiring more than it can handle.

Share this post


Link to post

Sorry if I seemed a bit harsh Andy. If he were using a 32-bit OS or had only 4GB RAM installed that could be an issue because the OS & FSX would be forced to share some of the memory. Nowadays though, with 64-bit systems & 8+GB RAM, FSX can have all it wants (up to the 4GB VAS limit) & the system still has plenty of leftover memory, so the two never have to fight for resources & nothing FSX-related needs to be sent to the page file. Of course, if you're running a lot of other programs, you could potentially use up all the 8GB, but FSX & IE, VLC or FSC won't do it.

Share this post


Link to post

I've just setup a new system (see Below) with 32GB RAM, my system is not overclocked and a SSD partition setup just for gaming with only FSX installed. I have FSX with the latest SP installed and a few addons such as UT, AS2012, Global 2010, UT USA, UT Europe, RC 4.3, PMDG MD11, B747, B737. paging is set to system mamage its about 47GB, all sliders set to high. no tweaks, FPS 30. I've setup a short flight (MD11) KBOS KJFK i've to flown this route 7 times, 6 times i had gotten the OOM shutdown FXS.i'm also looking for answers to the same Question what could it be?

Share this post


Link to post

Did you guys apply the highmemfix in your fsx.cfg ?

Share this post


Link to post

Raising the LOD radius is one of the biggest memory killers you can do in FSX - that's increasing the distance that it draws autogen and basically all the highly detailed things in the sim's world out to. Huge memory load from that.

Share this post


Link to post

thanks Ryan, i set LOD back at default 4.5 and clouds are I think at 90 mi. i haven't gotten an OOM message since

Share this post


Link to post