Jump to content

Archived

This topic is now archived and is closed to further replies.

copilot767

OOM with High end system

Recommended Posts

Hello..Hope its the right forum, and someone can help me..A well known problem about OOM... On a approach the OOM appear - goes to desktop and tell me to reduce settings... I will not accept this problem..Have searched a lot of forums, but not found the correct solution yet :(I have a really high end system: 2600K (clocked to 4.8 Ghz) 8 GB Mushkin ram 1600 mhz, Nvidia GTX 580, Motherboard ASUS (newest and biggest). SSD for OS & Velcio R 10.0000 for FSX.Ultimate Windows 7 64 bit.Typical OOM at Fs dream airport in an approach: I use UTX (with night lightning) GEX, My Traffic 2011, Contrails pro, photorealistic areas, US cities (aerosoft), Radar contact 4.3, Live ATC , Aerosoft Airbus X and ASE (weather program) , REX Overdrive.My weather settings are at highest, my traffic is always 25% to 45%..LOD radius (yesterday with a crash - MEDIUM). Autogen from normal to Very dense..My system is very stable, and these OOM only appears at approaches at big EYE candy areas.1. Do I have to accept it, and put down sliders ?2. What about BC EDIT solution (3072..read something about it, but not sure it can can help at Win 7 64 bit ??3. Buy a SSD to my FSX system, will that eliminate my OOM, ( I mean it by myself - that it can be the solution, but don´t know ???Really hope someone have an idea :)Chris from Denmark

Share this post


Link to post
Share on other sites
Guest jahman

Try reducing your LOD radius (so less objects are loaded) until yo no longer get your OOM.Cheers,- jahman.

Share this post


Link to post
Share on other sites
Guest firehawk44
1. Do I have to accept it, and put down sliders ?2. What about BC EDIT solution (3072..read something about it, but not sure it can can help at Win 7 64 bit ??3. Buy a SSD to my FSX system, will that eliminate my OOM, ( I mean it by myself - that it can be the solution, but don´t know ???
1. Yes. FSX will crash with all sliders set to max. Turn down AI and turn off AI for ships/yachts, bring car traffic down to no more than 10%, aircraft to no more than 50%. Bring a couple of scenery sliders down as Jahman suggested.2. The /3GB switch is for Windows 32 bit systems only. It will not work with 64 bit systems. Getting an OOM with a 64 bit system is very, very rare.3. Buying another SSD just for FSX will not eliminate the OOM's.Make sure Microsoft dotnet is up-to-date by running Windows Update. Microsoft dotnet has, as one of its functions, the ability to manage memory for software programs. Check your virtual memory settings (page file). If you manually set up max and min figures, they are probably wrong and the cause of your OOM's. My system works well with 'system managed size'. I once set my page file manually as suggested by an "computer expert" and began getting all kinds of crashes until I changed it back to system managed size. Make sure your system memory is not overheating. Check the Event Viewer to see if there were other events associated with the crash(es). Check out the guide on setting up FSX and tuning it - http://www.simforums.com/forums/topic29041.html - for more suggestions.Best regards,Jim

Share this post


Link to post
Share on other sites

Sounds like I have to reduce heavy settings at KJFK & KLAX.. Never have problems almost all other airports.Thanks for answer :)

Share this post


Link to post
Share on other sites

Yep just like Jahman said, lower the LOD and cut back settings.

Share this post


Link to post
Share on other sites

Does anyone have any tips for OOMs with a windows 64 bit system? I'm going nuts trying to nail down a problem at KJFK (FSDT scenery). I have very good performance (FPS), and usually the OOM occurs when I'm on final into JFK (within 5 miles).

Share this post


Link to post
Share on other sites
Guest firehawk44
Does anyone have any tips for OOMs with a windows 64 bit system?
The tips above ARE for 64 bit systems.Best regards,Jim

Share this post


Link to post
Share on other sites

Okay, removed all my addons, except for the Ngx, and, although I didn't have time for a complete flight, I did some touch-and-goes, and the same problem occurred; the virtual memory kept on increasing and increasing, and never seemed to lower itself. So I have decided to uninstall FSX completely, and now I have to find time for a reinstall. I hope this gets fixed since not even lowering settings seems to aid, so my hypothesis is that if this doesn't get fixed, I won't be able to complete a long flight.

Share this post


Link to post
Share on other sites

I'm also still getting numerous OOMs at KJFK (FSDT) when paired with the megascenery new york, and aerosoft's Manhattan. I'm also on a Windows 7 64b system with 8GB of memory, a nice 2600k overclocked. Have no clue what to change. I have Ult Traffic 2 running at only 80%, all other ground traffic at 10%, etc.

Share this post


Link to post
Share on other sites
Guest firehawk44
I'm also still getting numerous OOMs at KJFK (FSDT) when paired with the megascenery new york, and aerosoft's Manhattan. I'm also on a Windows 7 64b system with 8GB of memory, a nice 2600k overclocked. Have no clue what to change. I have Ult Traffic 2 running at only 80%, all other ground traffic at 10%, etc.
All the programs you mention use a lot of memory resources. You'll have to lower your sliders as recommended by the developers in their respective manuals. Ultimate Traffic should be no higher than 45%. Remember it loads flight plans and aircraft worldwide, not just the area you are flying. This takes up a lot of resources. You'll still see a lot of traffic at 45%. Autogen, if set to max, should be lowered to 'normal' or turned off. If you have HD graphics turned on (Texture_Max_Load=4096), return it to 1024. You just have too much 'eye-candy' for one location. Regarding memory.... here's a quote from NickN's excellent guide on setting up FSX and tuning it:"FSX is a 32bit application and as such even when run in a 64bit operating system memory amounts greater than 4GB will be of little use to FSX directly, however, when applied with a 64bit OS and i7 FSX SP2 (or RTM/SP1 with edited fsx.exe files) will be allowed access to a full 4GB with other processes and applications running along side having access to more (over and above). Therefore 6GB (3x2GB) i7 systems as addons and aircraft become more complicated will benefit FSX on a 64bit OS. If you switch to i7 you are far better off on 3x2GB than 3x1GB in system memory."Hope this helps.Best regards,Jim

Share this post


Link to post
Share on other sites
All the programs you mention use a lot of memory resources. You'll have to lower your sliders as recommended by the developers in their respective manuals. Ultimate Traffic should be no higher than 45%. Remember it loads flight plans and aircraft worldwide, not just the area you are flying. This takes up a lot of resources. You'll still see a lot of traffic at 45%. Autogen, if set to max, should be lowered to 'normal' or turned off. If you have HD graphics turned on (Texture_Max_Load=4096), return it to 1024. You just have too much 'eye-candy' for one location. Regarding memory.... here's a quote from NickN's excellent guide on setting up FSX and tuning it:"FSX is a 32bit application and as such even when run in a 64bit operating system memory amounts greater than 4GB will be of little use to FSX directly, however, when applied with a 64bit OS and i7 FSX SP2 (or RTM/SP1 with edited fsx.exe files) will be allowed access to a full 4GB with other processes and applications running along side having access to more (over and above). Therefore 6GB (3x2GB) i7 systems as addons and aircraft become more complicated will benefit FSX on a 64bit OS. If you switch to i7 you are far better off on 3x2GB than 3x1GB in system memory."Hope this helps.Best regards,Jim
Thanks Jim...So with my 8Gb, FSX is using my full 4Gb in it's program virtual address space, and the remaining 4Gb serves for Windows to run, as well as add-on programs- but not for within the sim itself. This is why those of us that think we have power systems (and we do) load up the scenery so much to the point where it memory's-out the program.

Share this post


Link to post
Share on other sites
Guest firehawk44
Thanks Jim...So with my 8Gb, FSX is using my full 4Gb in it's program virtual address space, and the remaining 4Gb serves for Windows to run, as well as add-on programs- but not for within the sim itself. This is why those of us that think we have power systems (and we do) load up the scenery so much to the point where it memory's-out the program.
Well stated! Now if they could somehow update the FSX code to allow for better use of hardware and CPU's and DX11, things would be great!Best regards,Jim

Share this post


Link to post
Share on other sites

×
×
  • Create New...