Archived

This topic is now archived and is closed to further replies.

Piper9t3

Crazy FPS spikes

Recommended Posts

I have just completed a fresh re-install of FSX onto its own dedicated ssd. I have tweaked fsx.cfg with BP=0, HIGHMEMFIX=1 and TML=4096. I have set FPS to unlimited in FSX and set external limiter to 30 fps in NI. Start FSX and get erratic fps spikes 20-30-60-single digits - its all over the place. Tried locking fps to 30 fps in FSX but still getting crazy fps spikes. I don't understand what is causing this. How do you achieve a steady 30fps??

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Try TML at 2048 (still HD).  The highmemfix=1 is a fix, not a tweak for better fps.  High display driver settings will slow things down too as you are asking FSX to render the most extreme textures in the fastest time possible.  Lower a couple of fsx settings too.  Try those in the Orbx manual (if you have one).  They work for all scenery.  It is impossible to maintain a steady 30 fps near the ground, inside VC's, and not until you are well off the ground, maybe at cruise altitude.  You might be able to maintain a steady 30fps if you lower all of your scenery sliders down to a very minimum.

 

I personally am not in favor of the BP=0 "tweak" - http://forum.avsim.net/topic/281538-the-bp0-conclusions/.  I do like this one -

 

[bUFFERPOOLS]
UsePools=1
Poolsize=8388608
RejectThreshold=262144
 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Hi John, if like me you use the Bufferpools tweak and experience graphical spikes, this can be easily rectified by increasing your water settings to High 2.x. Now, in doing so you will sacrifice the frame increase you have gained by using [bUFFERPOOLS] Usepools=0, BUT, you have gained better water rendition IMO and most of all the added smoothness that is often associated with the Bufferpools tweak. Nick Needham bangs on about it being a waste waste of time to use the tweak if you then have to run the data through an additional shader, BUT in my experience, as I say, you do benefit by having nicer water and also a smoother sim. :wink:  BTW, FWIW, I have never had any success whatsoever by using any other frame setting other than FSX being locked at 30 in FSX.

Share this post


Link to post
Share on other sites

Set nVidia Inspector to 1/2 Vsync (I suppose setting it to 30 like you did is something else...?) and lock ingame to 30. That should prevent fps spikes...

Share this post


Link to post
Share on other sites

Hi John, if like me you use the Bufferpools tweak and experience graphical spikes, this can be easily rectified by increasing your water settings to High 2.x. Now, in doing so you will sacrifice the frame increase you have gained by using [bUFFERPOOLS] Usepools=0, BUT, you have gained better water rendition IMO and most of all the added smoothness that is often associated with the Bufferpools tweak. Nick Needham bangs on about it being a waste waste of time to use the tweak if you then have to run the data through an additional shader, BUT in my experience, as I say, you do benefit by having nicer water and also a smoother sim. :wink: BTW, FWIW, I have never had any success whatsoever by using any other frame setting other than FSX being locked at 30 in FSX.

I share your opinion. My experience was the same, i can't get better combination of graphic qulality and smoothnest then using BF tweak. I tried also Nick's set of recommendations and i get a 10fps less and nice slideshow at any bigger airport. I'm not saying that Nick is not good, but we must try all approaches and see what works best. Different systems - different experience :)

 

 

For John, to answer OP: Go to Nvidia Control Panel and check in Display section that your refresh rate is 60Hz. If so, use nvidia inspector https://www.dropbox.com/s/92g87a4ri15yeym/nvidiaInspector.zip

 

and set FSX profile like here: http://imageshack.us/a/img163/7515/capturelfo.png

 

For this profile to work, start fsx, go to settings and under graphics tab - set filtering to "Anisotropic" and limit FPS to 30.

Share this post


Link to post
Share on other sites

FSX being locked at 30 in FSX.

lock ingame to 30. That should prevent fps spikes...

Gonna keep it locked inside FSX...

Share this post


Link to post
Share on other sites

Gonna keep it locked inside FSX...

 

one more thing, you have great hardware to run FSX at high settings, google for "Word Not Allowed's Flight Simulation World" and folow his recommendations

Share this post


Link to post
Share on other sites

Zelijko

I have read thru Word Not Allowed's guide many times! I Must be making a fundamental mistake here. Gonna keep at it trying to correct this...thanks for the help

Set nVidia Inspector to 1/2 Vsync

Jeroen is there any special tweak needed in fsx.cfg for using 1/2Vsync?

Share this post


Link to post
Share on other sites

John, you must try this  increasing your water settings to High 2.x  

Share this post


Link to post
Share on other sites

Zelijko

I have read thru Word Not Allowed's guide many times! I Must be making a fundamental mistake here. Gonna keep at it trying to correct this...thanks for the help

Jeroen is there any special tweak needed in fsx.cfg for using 1/2Vsync?

 

No, none at all!

Share this post


Link to post
Share on other sites

Try setting your Bufferpools to 20000000 or 25000000 and remember  UsePools =0 should only be used if you have  2GB or more dedicated video memory on your graphics card. 

UsePools=1 utilizes the computers memory and UsePools=0 draws memory from the video card directly.

 

Also if you are running a quadcore processor try different Affinity Mask settings =14 is the standard but you can also try 255, 63, 252, and 254.  A lot of people get stutters with 255 but try them out and see if you get some improvment.

 

If you are so inclined you can drop a copy of your current FSX CFG. in a pm to me, I will have a go at it and you can drop it back in your FSX and see if it makes a difference.

 

I have done this for like 15 people all have seen improvements and they can all now run FSX with there scenery sliders set to max with very good performance.

Hope this helps.  ~  James

Share this post


Link to post
Share on other sites

Don't just use any number for AM. The numbers DO mean something! My testing has confirmed what Phil Taylor said. The rules are:

 

1, No AM, HT on or off, OS and FSX on core 0, threads on 1,2, and 3. With HT on virtual cores are not used.

 

2. HT off, AM=14, OS on core 0, FSX on core 1, and threads on 2 and 3.

 

3. HT on, AM=254, OS on core 0, FSX on core 1, and threads on 2, 3, and all 4 virtual cores.

 

HT on, AM=14, CPU temp 62C. With AM=254 my CPU temp jumps to 76C and at times goes over 80C. Stock air cooler.

 

Dave

Share this post


Link to post
Share on other sites

You should have HT turned off period with an Intel core, AMD is a different beast altogether, and I have a friend Paul Jenkins that was on the FSX Testing team and worked with the Microsoft "Aces" team and he calculated these numbers, I am not just throwing random numbers out there dude....lol   These do work! i was just saying that AM=14 is a great stand-by but try the others.  you can go to Intel.com and find your specific processor number and see exactly how many cores and threads you have and then match it up to the number that corresponds to the AM to use.

 

 

Here is Paul's List =

 

For 2-core 4-thread CPU
15=1111 = ALL 4 cores
14=1110 = last 3 cores (cores read from back to front)
7=0111 = first 3 cores
3=0011 = first 2 cores
1=0001 = first core
For 4-core 8-thread CPU
255=11111111 = ALL 8 cores
254=11111110 = last 7 cores
252=11111100 = last 6 cores
127=01111111 = first 7 cores
63=00111111 = first 6 cores
For 6-core 12-thread CPU
4095=111111111111 = ALL 12 cores
4094=111111111110 = last 11 cores
4092=111111111100 = last 10 cores

Share this post


Link to post
Share on other sites

I know but others may not. I just read a thread here that a guy had an I5 and was using AM=84 "cause he read it somewhere".

 

Dave

Share this post


Link to post
Share on other sites

Managed to get FSX working smoothly (steady 30fps) without mucking around with affinity mask in my fsx.cfg......

Share this post


Link to post
Share on other sites

Glad you got it working! Tweeks are there to help you out. If they don't help, don't use them.

 

Which ones did you use?

 

Dave

Share this post


Link to post
Share on other sites

I tried ALL possible settings with AM, BP, fps locked to 30 and Vsync 1/2 in Inspector, etc., but I ALWAYS do have spikes when on ground.

Here is what happens to me:

I load the flight, with the aircraft sitting on the runway threshold, VC mode but without launching the TrackIR software. No visible AI traffic, sky clear. Therefore this is a steady situation, nothing moves, nothing changes. At the beginning and for about 30-40 seconds I get about 26 to 29 fps, steady. Suddenly, after those 30-40 seconds, fps start dancing between about 15-25, very irregularly and never go back to those steady 26 to 29, with spikes up to 13 fps.

WHY does that happen? If the sim manages to run at 26-29 fps for 30-40 seconds, why do fps decrease after, without NOTHING changing?

Share this post


Link to post
Share on other sites

I tried ALL possible settings with AM, BP, fps locked to 30 and Vsync 1/2 in Inspector, etc., but I ALWAYS do have spikes when on ground.

Here is what happens to me:

I load the flight, with the aircraft sitting on the runway threshold, VC mode but without launching the TrackIR software. No visible AI traffic, sky clear. Therefore this is a steady situation, nothing moves, nothing changes. At the beginning and for about 30-40 seconds I get about 26 to 29 fps, steady. Suddenly, after those 30-40 seconds, fps start dancing between about 15-25, very irregularly and never go back to those steady 26 to 29, with spikes up to 13 fps.

WHY does that happen? If the sim manages to run at 26-29 fps for 30-40 seconds, why do fps decrease after, without NOTHING changing?

 

This happened to me when i tried acceleration pack earlier this year. I just uninstalled it and installed SP1+SP2 and SDK, and everything back to normal, steady 30fps, no spikes. Same settings in both cases, but fps about 21-22 and spikes with Acceleration

Share this post


Link to post
Share on other sites

Glad you got it working! Tweeks are there to help you out. If they don't help, don't use them.

 

Which ones did you use?

 

Dave

My changes to fsx.cfg....BP=0,HIGHMEMFIX=1,TML=2048 and NI settings exactly as in Post 5 above..thats it!!

Share this post


Link to post
Share on other sites

 

Try setting your Bufferpools to 20000000 or 25000000 and remember  UsePools =0 should only be used if you have  2GB or more dedicated video memory on your graphics card. 

UsePools=1 utilizes the computers memory and UsePools=0 draws memory from the video card directly.

 

Also if you are running a quadcore processor try different Affinity Mask settings =14 is the standard but you can also try 255, 63, 252, and 254.  A lot of people get stutters with 255 but try them out and see if you get some improvment.

 

If you are so inclined you can drop a copy of your current FSX CFG. in a pm to me, I will have a go at it and you can drop it back in your FSX and see if it makes a difference.

 

I have done this for like 15 people all have seen improvements and they can all now run FSX with there scenery sliders set to max with very good performance.

Hope this helps.  ~  James

 

 

You mentioned UsePools=0 causes the video card memory to be used rather than the computer memory. So, are you saying that if one is using the BufferPools and RejectThreshold settings, one can use UsePools=0 to direct the use of the video card memory as well? Reason I ask is that I thought UsePools=0 was a command to not use BufferPools.

 

Thanks

 

Danny

Share this post


Link to post
Share on other sites

 

 



WHY does that happen? If the sim manages to run at 26-29 fps for 30-40 seconds, why do fps decrease after, without NOTHING changing?

 

Probably a AI aircraft started to taxi. Try moving your AI slider to 0 to see if that stops it.

 

Dave


 

 


My changes to fsx.cfg....BP=0,HIGHMEMFIX=1,TML=2048 and NI settings exactly as in Post 5 above..thats it!!

 

Thanks for the feedback!

 

Dave

Share this post


Link to post
Share on other sites

Probably a AI aircraft started to taxi. Try moving your AI slider to 0 to see if that stops it

 

Dave, unfortunately I tried with the slider to 0, but nothing changes. I am really curious to understand what causes that decrease after some time...

Share this post


Link to post
Share on other sites