Sign in to follow this  
SirStiggie

Crash To Desktop (CTD) - MSVCR100.dll

Recommended Posts

I'm hoping this is the correct place to post this as I do not see a CTD sub-forum like in the FSX forum.

 

I have been having intermittent CTD's all pointing to the same file, MSVCR100.dll. I have posted the entry in the event log below:

 

Faulting application name: Prepar3D.exe, version: 2.0.9448.0, time stamp: 0x528edbf4
Faulting module name: MSVCR100.dll, version: 10.0.40219.325, time stamp: 0x4df2be1e
Exception code: 0x40000015
Fault offset: 0x0008d6fd
Faulting process id: 0x2284
Faulting application start time: 0x01cef2b5c5a7cd84
Faulting application path: C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\Prepar3D.exe
Faulting module path: C:\Windows\system32\MSVCR100.dll
Report Id: 4009bea9-5ebd-11e3-a2bf-3c970e67be26
 
I have this CTD with different planes (payware and P3D) and seems to be scenery independent. The only consistency I seem to have is if I minimize the P3D window for awhile (> 5 minutes) then the sim crashes and that entry is made in the event log.
 
Is anyone else having this problem? If yes, have you managed to solve it?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It's more than likely that its one of the addons you have installed that is causing this problem.

 

The only way to narrow this down is to remove each plane that you have added and see if the problem goes away.

 

Once you have removed all the planes you have installed and the problem is still there, then your only option would be to reinstall P3D and start again.

 

Bear in mind that although developers may have said that their addons are P3D ready, that does not mean they are compatible.

 

As a matter of interest what have you added?

Share this post


Link to post
Share on other sites

As a matter of interest what have you added?

For scenery, I have Orbx PNW and DD Miami City 2012

 

For airports, I have LatinVFR MKJS and MKJP, FSDT KFLL and KJFK v2

 

For weather, I have REX Essentials Plus

 

Aircraft are a bunch of Carenado planes, Quality Wings Avro/RJ and 757, Aerosoft Airbus Extended, and Feel There E-Jets

 

 

 

 

IMO its more of a scenery or utility issue than aircraft. been seeing theses errors and runtime errors a lot around the forums. The most common thing is addon scenery but that means little. Do you by chance have FSUIPC installed?

 

http://www.prepar3d.com/forum-5/?mingleforumaction=viewtopic&t=3919.1

 

 

I have (I think) the latest version of FSUIPC (4.923)

 

I also uninstalled all FSX add-on's, then uninstalled FSX from my system as well as cleaned the registry and defragged the HD before I installed P3D.

 

The post made by c912039 in that link you posted agrees with my findings on this problem. As long as P3D is the active window, I don't have the error but if I minimize P3D or open another app window over it, it crashes.

 

Maybe this is LM's way of ensuring nobody steps away from the cockpit?  :rolleyes:

  • Upvote 1

Share this post


Link to post
Share on other sites

intermittent CTD's all pointing to the same file, MSVCR100.dll

 

 

Same bug here and its not a net framework problem ....

  • Upvote 1

Share this post


Link to post
Share on other sites

Same bug here and its not a net framework problem ....

True. Somethings trying to talk to something but not. :) They say the default Raptor will do it because it has a lighting overlap. LM changed the coding just enough to screw some things up but not easily replicated.

Share this post


Link to post
Share on other sites

Hi I found out what was causing this crash in my setup .. RAASPRO DLL in the P3D DLL

 

 

That makes sense, as I had this crash once before I moved P3D2 to my SSD. On re-install of the AXE I did not install RAAS and haven't seen it since.

 

I'm sure it's only one of many though.

Share this post


Link to post
Share on other sites

go in C:\Users\yours \AppData\Roaming\Lockheed Martin\Prepar3D v2

and delete the raas pro section in the dll xml

 

<Launch.Addon>

<Name>RAASPRO</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>.\RAASPRO\RAASPRO.dll</Path>

<DllStartName>module_init</DllStartName>

<DllStopName>module_deinit</DllStopName>

</Launch.Addon>

Share this post


Link to post
Share on other sites

Sure that just one of many. There are others having the error with nothing but the default installation.

Share this post


Link to post
Share on other sites

There is no need to "remove" that entry. Simply change this single parameter from False to True!

 

<Disabled>True</Disabled>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this