Sign in to follow this  
HaraldG

Dreamfleet 727 and Windows 7

Recommended Posts

Hi,

 

this is a question to those who use the wonderful Dreamfleet 727 under Windows7.

 

I decided to install Windows 7 due to some OOMs occuring recently (had none for years but several within the last weeks). All works fine so far, unfortunately the 727 doesn't. Always if I call the kneeboard with F10 button, FS2004 freezes and has to be shut down via Task Manager.

 

In the DF727 support forum I read that Internet Explorer 8 is needed to run the DF727 and to show the kneeboard properly. But I can't imagine that all of you using Win 7 and the DF727 stick with this old and insecure browser??? (Beside the fact that if I try to install IE8, Windows says me that it was not compatible to my OS)

 

Has anybody of you found a solution?

 

Thanks,

Harald

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Harald

I never use kneeboard so can't help you with your problem other than to say that I've been running DF727 in Win 7 X64 without any problems for several years

Cheers mate

Ian

Share this post


Link to post
Share on other sites

Hi Ian,

 

thanks! In fact, all other functions of the plane seems to perform well, even the weather radar.

 

Using no kneeboard was a possibility (I mostly use it for reading ATC messages if I can't use headphones because my wife wants to speak with me or my son wants to play while I fly). But I assume that I could forget about the fact, toggle kneeboard while performing final approach and wasted all the flying time.

 

And you never tested what happens when you toggle the kneeboard?

 

Harald

Share this post


Link to post
Share on other sites

I have the DF 727 running on Win 7 64 bit, and the F10 key does not crash FS2004. I do get some odd graphic behaviour sometimes, but changing from full screen mode to window mode, and back again usually fixes that. I must admit that I hardly ever use the kneeboard command.

Share this post


Link to post
Share on other sites

Thanks Graeme.

Can you please post which version of Internet Explorer is installed on your system?

Btw I tested some more planes, and this phenomenon only occurs with the DF727 - but with the DF727 it occurs every time I hit F10. So It seems to be in fact plane-related.

(Good to know I can still use other planes :mellow: )

 

Just an additional info - I do use windowed mode exclusively.

Share this post


Link to post
Share on other sites

Hi

Same behavior. When hitting F10, FS2004 freezes and has to be shut down via Task Manager.

Didn't now until today, when I read this post.

It works ok with other a/c

IE11 installed.

Due to I never use F10 command, no big deal for me. Everything else works OK.

Regards

Share this post


Link to post
Share on other sites

 

 


Can you please post which version of Internet Explorer is installed on your system?

I am using IE9.

Share this post


Link to post
Share on other sites

 

 


I am using IE9.

 

O.K. that means this information on IE8 I found in the 727 support forum is incorrect.

Perhaps a graphics setting that causes this problem?

I meanwhile deleted the 727 checklist and reference htm files, but this didn't solve it.

 

Edin, it's at last a certain comfort to me that I'm not alone. Unfortunately, I do use the kneeboard from time to time.

Share this post


Link to post
Share on other sites

I will play with the graphics settings in the evening. With my new Win7 x64 system, I also had new problems with some other graphics related items (f. i. no 2D panels with PanelAsTexture entry in fs9.cfg)

 

Will report back, maybe this thread has outcome for some of us.

 

Edin, which graphics settings do you use?

Antialiasing activated? If yes - via Catalyst Control Center or inside FS2004?

Any entries under the [DISPLAY.Device.xxxxxxx] section in fs9.cfg?

Which version of ATI Video driver resp. CCC do you use?

 

 


Just out of interest. Does this bird work with FSX? If so are there any known issues?

 

Don't have FSX, so can't help you. All I know is that it is specified for FS2004 at the product sites. There are rumours about portovers but I don't want and I'm not able to confirm these. However, Captain Sims "727 Captain" may be appropriate for you.

 

Harald

Share this post


Link to post
Share on other sites

Hi Harald.

Same here, no 2D panels with PanelAsTexture.

I'm using profile created in CCC. AA, AF is activated via CCC

I have tgis in fs9.cfg:

[DISPLAY.Device.ATI Radeon HD 5700 Series.0]
Mode=1680x1050x32
TriLinear=1

I'm using latest Beta drivers 13.11 beta 9.5

 

Edin

Share this post


Link to post
Share on other sites

Made some tests more.

All kinds of graphics settings and playing with fs9.cfg didn't help.

What finally helped was removal of the gauges from the panels. Further tests resulted in DF727NJ1.gau obviously being the offending one.

So there is an incompatibility between one of the gauges and the kneeboard. Maybe the difference between ATI/AMD GPU and NVidia GPU makes the difference between the behaviour of the kneeboard. I don't believe that it's a driver issue, since I stick with 13.1 (on my previous system this was the one which seemed to run best).

 

Harald

Share this post


Link to post
Share on other sites

I use W7 64, I just don't fly the 727 much anymore, but it works just fine as do all my add-ons from W- XP FS9. :rolleyes:

Share this post


Link to post
Share on other sites

but it works just fine as do all my add-ons from W- XP FS9

 

Lucky you.

 

Good night!

Harald

Share this post


Link to post
Share on other sites

Just a heads up:

The Airspeed Indicator is the offending gauge.

If I deactivate the ASI gauge in the panel.cfg, I can toggle, read and click the kneeboard without problems. It seems that the gauges and the kneebord communicate in a way unique to this plane (and maybe depending on GPU manufacturer?!?).

 

But due to the complex modelling of this superb aircraft I get other problems. The VSI gauge will crash the sim without ASI already when loading the flight. (I deactivated the VSI, too). Furthermore, with ASI and VSI deactivated, toggling the Flight Engineers panel crashes the sim.

I didn't test what happens if I replace the ASI with another ASI gauge. I honestly expect the whole plane to work not longer.

 

I decided to move on to the DF 727 support forum, but I'm frankly suspect, that it is not really alive anymore.

 

As I bought the 727 as boxed version from Aerosoft, it may be useful to use their support forum, doesn't it?

I really appreciate the help I got here at Avsim but I think I should rather ask the vendor of the product.

 

Thanks to all

Harald

Share this post


Link to post
Share on other sites

Hi Harald.

Thanks for deep investigation and report.

I will leave as it is. I don't fly to much.

 

P.S. Little OT. Do You know maybe good Sochi scenery. You can pm

 

Thanks

 

Edin

Share this post


Link to post
Share on other sites

 

 


P.S. Little OT. Do You know maybe good Sochi scenery. You can pm

 

Hi Edin, you have a PM.

 

Harald

Share this post


Link to post
Share on other sites

After I had no success neither at the Dreamfleet 727 support forum nor at Aerosofts support forum I decided to come back here. Today I ran ProcMon and I realized that at the very moment I toggle the kneeboard, FS9.exe wants to get access to a file "d3d10warp.dll" in the c:\windows\syswow64 folder (it is indeed there), but there is a problem indicated "File locked with only readers".

There are other problems indicated, mostly connected to the registry, don't know what they want to say me.

 

I have managed to get around quite well without the kneeboard, but I try to understand the problem and I'd feel better without it.

 

Thanks for any input!

 

Regards,

Harald

Share this post


Link to post
Share on other sites

After I had no success neither at the Dreamfleet 727 support forum nor at Aerosofts support forum I decided to come back here. Today I ran ProcMon and I realized that at the very moment I toggle the kneeboard, FS9.exe wants to get access to a file "d3d10warp.dll" in the c:\windows\syswow64 folder (it is indeed there), but there is a problem indicated "File locked with only readers".

There are other problems indicated, mostly connected to the registry, don't know what they want to say me.

 

I have managed to get around quite well without the kneeboard, but I try to understand the problem and I'd feel better without it.

 

Thanks for any input!

 

Regards,

Harald

Hi Harald,

Sorry to say that the Dreamfleet has been out of business for a few years now.  You may be able to find some answers on the Dreamfleet forum here:

http://www.flightsim.com/vbfs/forumdisplay.php?19-DreamFleet-727-Support-Forum

 

Not sure if you found that one or not, as the link on Dreamfleet's site has been dead for a few months now. It's not that active anymore, but it is still a valuable repository that you can take advantage of.  As for the Dreamfleet 727 specifically, You might also contact Flight1.com, who still sell the 727.  They might be able to offer some limited support.

Hope that helps a little.

Cheers,

Jeff

Share this post


Link to post
Share on other sites

Hi Jeff,

 

many thanks!

 

On the Dreamfleet forum, my post wasn't answered for weeks now. At Aerosoft (I bought the boxed version via Aerosoft) there was an attempt to help but without success. To me, Avsim seems to be the most "living" forum.

Anyway, perhaps anybody has an idea, if not, it won't be the end of the world!

Regards,

Harald

Share this post


Link to post
Share on other sites

Harald - just a wild guess: since your error seems to reflect sth with d3d, have you disabled any enb bloom feature?

---

Well as a man of your insight and sherlock i tend to state you already tried that...

 

Beste Grüße,

Alex

 

PS I am gonna reinstall that bird into w7 to see if i can reproduce, any further observations via pn.

Harald - just a wild guess: since your error seems to reflect sth with d3d, have you disabled any enb bloom feature?

---

Well as a man of your insight and sherlock i tend to state you already tried that...

 

Beste Grüße,

Alex

 

PS I am gonna reinstall that bird into w7 to see if i can reproduce, any further observations via pn.

F*** ya, mobile device!

Share this post


Link to post
Share on other sites

Hi Harald,

This is probably no help but:

 

I tried my DF727 to test the Kneeboard (haven't usually used them) and indeed I get the same problem. PC freezes and can only be unlocked by using Task Manager.

I tried using a different key assignment (desperate hey) but problem remains.

I tried just accessing the Kneeboard via the windows menu, same problem.

I tried using Firefox and Google Chrome instead of IE11, same problem.

 

So, I couldn't solve it either.

 

Only person I can think to get help from is Paul Golding who often posts here at Avsims.

 

Cheers,

 

Warren

Share this post


Link to post
Share on other sites

Hi Alex and Warren,

 

thanks for your posts.

 

Warren, do you also own an ATI/AMD graphics card? Which driver version?

 

I tried all that, too, but without help. With one exception: I never used ENB bloom (or SweetFX) due to problems I experienced with these tools on my old WinXP system.

Nevertheless I enjoy this aircraft without kneeboard, which I actually used only to remember some ATC advices I didn't understand clearly enough because I use the accellerated ATC by EditVoicePack.

After all, I still believe in some strange incompatibility of the gauges with some other FS2004 functionality under Win7 according to my previous tests (post #13 and 16).

 

Am I right that this d3d10... stuff somehow belongs to DirectX 10?

The strange thing is that my Win7 came with DX11, while I installed DX9.0c additionally to have proper sound for the TinMouse 732, what worked well. If I test DirectX via DXDiag, I get v.11 as installed version without problems. There were no differences for my DF727 problem before and after re-install of v.9.0c. I thought of reinstalling v.10 the same way, but found no installer. But then I found the d3d10warp.dll file within my Windows\system32 folder as well as in my Windows\WinSXS64 folder. They have a different file size, but nevertheless they are there. The question is what ProcMon wants to say me with the indication "File locked with only readers"?

 

By the way, after my latest tests, I get the same phenomenon if I load a flightplan and click the "Show navigation log" button or if I choose this functionality via menue "Flight - Navigation log" (but again, only with the DF 727 as active plane). In the latter case, the "frame" of the navigation log will appear, but without the log itself, and then Fs2004 freezes. FYI, I use flight plans made with FSCommander v. 9.4. Obviously, the navigation log of FS2004 is somehow similar to its virtual kneeboard. Another fact: I can use FS2004's map without problems.

 

Regards and Grüße,

Harald

Share this post


Link to post
Share on other sites

Warren, do you also own an ATI/AMD graphics card? Which driver version?

No Harald, I'm using NV GTX480. I also don't use any special enhancer programs, it's a pretty basic FS9 setup.

I also have no similar problems with other aircraft, it's specific to the DF727. I'm pretty sure it used to work ok when I had Win XP as my OS, but now I'm using Win 7 64.

 

Warren

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this