Jump to content
Sign in to follow this  
Guest

P3DV2.1 stutter or no stutter

P3DV2.1 Stutters Yes or No  

247 members have voted

  1. 1. Are you getting stutters in P3DV2.1?

  2. 2. What OS are you running?

  3. 3. Do you use controllers (yokes, joysticks, rudders)?



Recommended Posts

Guest

Have you tried testing with any of the other aircraft besides the Carenado A36?

 

 

Yes.

 

 

v-sync/triple buffering enabled (which needs to be re-enabled every time you exit and re-enter the sim)

 

 

Odd, I don't need to do that?  Once checked it stays checked.

 

I installed the 334.89 drivers tonight, and I did indeed notice a little performance boost, but it didn't cure the stutters.

 

 

Share this post


Link to post

Odd, I don't need to do that? Once checked it stays checked.

 

 

 

 

It stays checked it just doesn't stay enabled. With v-sync enabled obviously the frame rate shouldn't go above the refresh rate of the display (in my case it's 60Hz/60 fps). When I close out of the sim and then start it again the frame rates are 80+ fps, v-sync is again disabled.

 

If v-sync isn't enabled and the frame rate limiter is set to unlimited just like with any other game you will see some stuttering no matter how high the frame rate is.

 

 

 

 

 

I installed the 334.89 drivers tonight, and I did indeed notice a little performance boost, but it didn't cure the stutters.

 

 

I installed them last night and didn't see any difference from the 334.67's. Next up I might just try a fresh install of Windows 7/SP1 64 to see if there's any difference compared to Windows 8.1 Pro.

Share this post


Link to post
Guest

 

 


It stays checked it just doesn't stay enabled.

 

You lost me here?

 

If you turn OFF Vsync, then there is no point to Triple Buffering and I believe LM disable and uncheck the option.

Share this post


Link to post

You lost me here?

 

 

 

If you turn OFF Vsync, then there is no point to Triple Buffering and I believe LM disable and uncheck the option.

 

 

 

If I have v-sync enabled and then completely close out of the sim and then start it again the frame rates are above 60 fps, which shows that v-sync is no longer enabled.

Share this post


Link to post

If I have v-sync enabled and then completely close out of the sim and then start it again the frame rates are above 60 fps, which shows that v-sync is no longer enabled.

 

Unfortunately, vsync isn't quite that precise, and even when enabled, you may regularly see the fps counter spiking above 60 fps. I'm not entirely sure where in the rendering pipeline it even measures, tbh.

 

Whether the image tears or not is a better test.


Regards,

Brian Doney

Share this post


Link to post
Guest

 

 


If I have v-sync enabled and then completely close out of the sim and then start it again the frame rates are above 60 fps, which shows that v-sync is no longer enabled.

 

Interesting, mine doesn't exhibit that behavior and we have the same video card ... per Brian, have you confirmed visually that Vsync is off?  Are you using NI?  If so, what settings?  If no NI, what are the nv control panel settings for Prepar3d.exe? (or Global if you don't have a specific profile set).

Share this post


Link to post

Unfortunately, vsync isn't quite that precise, and even when enabled, you may regularly see the fps counter spiking above 60 fps. I'm not entirely sure where in the rendering pipeline it even measures, tbh.

 

 

 

Yes I've seen the frame rate spikes with v-sync enabled but with the issue I'm describing the frame rates never even hover around 60 fps, they stay in the 70 – 80 fps range until I go back into the settings and check the v-sync option again.

Interesting, mine doesn't exhibit that behavior and we have the same video card

 

 

 

Are you running on Windows 7, now you've got me wondering if it's a Windows 8/v-sync issue?

I might just go ahead and see if I can reproduce the issue on my i7/AMD 290X setup.

Share this post


Link to post

Yes I've seen the frame rate spikes with v-sync enabled but with the issue I'm describing the frame rates never even hover around 60 fps, they stay in the 70 – 80 fps range until I go back into the settings and check the v-sync option again.

 

That is indeed a separate issue then, and something I have not seen.

 

Hopefully someone else can chime in that might have seen this.


Regards,

Brian Doney

Share this post


Link to post

For me and my 144hz screens.. i found with win 8.1 that turning off vsync in P3d 2.1 and turning it on in the NI profile seemed a little better, perhaps it was just placebo, but it really should be no different i would think.  Also, whether I ran at a multiple of 144 (fsx internal 36) or fsx unlimited, didnt seem to matter.. my experience is mostly smooth with the occasional stutter.


MSI z690-a Unify; 1000 watt evga SuperNova Platinum; 12900kf at 1.255 adaptive LLC6, auto avx, auto Pcore, E-4.0ghz, Ring-4.1ghz, PL 241watt (Cine96c, games 83c case side On); DDR5 Gskill F5-6400J3239G16GA2-TZ5RS  at 6400mhz autovolt, Kraken x73 360mm; Thermaltake v51 Case; Gigabyte 4090 OC;  VR-Varjo Aero;  AstronomicallySpeaking:

Share this post


Link to post

For me and my 144hz screens.. i found with win 8.1 that turning off vsync in P3d 2.1 and turning it on in the NI profile seemed a little better, perhaps it was just placebo, but it really should be no different i would think.

 

 

 

 

You are running on displays with a 144Hz refresh rate and are able to maintain 144 fps? If so with what settings?

Are they HDTV's or are they something else?

 

As far as I've seen so far since v2.1 was released, NI still doesn't have any control over Prepar3D's exe. The ½ refresh rate setting still doesn't seem to be doing anything with Prepar3d v2.1.

 

 

Share this post


Link to post

No stutters , no blurries, no problem. In other words i am fine, thanks for asking ;)

 

Would you sell me your PC? How much?

 

B)

Share this post


Link to post

You are running on displays with a 144Hz refresh rate and are able to maintain 144 fps? If so with what settings?

Are they HDTV's or are they something else?

 

As far as I've seen so far since v2.1 was released, NI still doesn't have any control over Prepar3D's exe. The ½ refresh rate setting still doesn't seem to be doing anything with Prepar3d v2.1.

 

Lol sorry i guess i typed that wrong.. no i dont get and maintain that fps, wow i wish.. in PNW areas i can indeed hit 50-70 fps depending on clouds being present.. but the fsmark07 in hybrid mode for a 40 second test i get 38.80 fps.. without hybrid checked im around 41 fps (when set to unlimited).


MSI z690-a Unify; 1000 watt evga SuperNova Platinum; 12900kf at 1.255 adaptive LLC6, auto avx, auto Pcore, E-4.0ghz, Ring-4.1ghz, PL 241watt (Cine96c, games 83c case side On); DDR5 Gskill F5-6400J3239G16GA2-TZ5RS  at 6400mhz autovolt, Kraken x73 360mm; Thermaltake v51 Case; Gigabyte 4090 OC;  VR-Varjo Aero;  AstronomicallySpeaking:

Share this post


Link to post

Lol sorry i guess i typed that wrong.. no i dont get and maintain that fps, wow i wish.. in PNW areas i can indeed hit 50-70 fps depending on clouds being present.

 

 

 

That's why I asked, if the display is running at 144Hz with v-sync enabled and the frame rate is only 50-70 fps how would you see anything but stuttering? Are you using a HDTV capable of a 144Hz refresh rate?

 

The reason why I'm asking is because I have seen some HDTV's that will only do 60Hz when the signal is coming from a PC.

Share this post


Link to post

That's why I asked, if the display is running at 144Hz with v-sync enabled and the frame rate is only 50-70 fps how would you see anything but stuttering? Are you using a HDTV capable of a 144Hz refresh rate?

 

The reason why I'm asking is because I have seen some HDTV's that will only do 60Hz when the signal is coming from a PC.

 

I'm using display port and hdmi via 3 x 24" Asus VG248QE screens, so its a "pc" signal.  I double checked my NI settings.. i have the vertical sync set to 1/4 (and yeah still at unlimited in the cfg).. i was set to 36, but unlimited seemed smoother.. no real stuttering or tearing.  Sync control is set to adaptive.  Ill try a few fresh flights later tonight and confirm things, but fairly certain.


MSI z690-a Unify; 1000 watt evga SuperNova Platinum; 12900kf at 1.255 adaptive LLC6, auto avx, auto Pcore, E-4.0ghz, Ring-4.1ghz, PL 241watt (Cine96c, games 83c case side On); DDR5 Gskill F5-6400J3239G16GA2-TZ5RS  at 6400mhz autovolt, Kraken x73 360mm; Thermaltake v51 Case; Gigabyte 4090 OC;  VR-Varjo Aero;  AstronomicallySpeaking:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...