Jump to content

Sign in to follow this  
Petraeus

Version 2.1 OOM and possible memory leak.

Recommended Posts

This will probably be LM's fall back position in the end, because the expanded sliders we have been given will never fit our 32bit Sim once we add our complex addons.

 

I'm not sure whether it is fair to say "will probably be LM's fall back position". I think it is fair to say that it is indeed LM's position because us hobbyists are NOT their core market and the majority of us seem to forget that. It may change one day, who knows? For the record and acknowledging I only have a mid range rig overclocked to a lowly 3.4 (or 3.3 can't recall right now) coupled with only a 560Ti card, I do get better performance from P3Dv2 (even with my "mystery 737") with more autogen, better scenery, better clouds, no stuttering, no blurries, immersive cockpit shadows, than I have ever been able to get out of FSX !??!

 

So from my perspective I have two choices. I can either enjoy the gains I have made for a very small investment whilst waiting for some of the 3rd party developers to catch up, or I can simply blow up my sim by pushing it over the edge and sit on the various forums moaning and crying all day about a simulator that has a far greater capacity than my pc has the ability to use.

 

Oh and no offence meant, but your pictures reminded me of just how lifeless FSX is. Do you actually own P3Dv2? 

Share this post


Link to post

Brian, in case no one else mentions it, I'd like to thank you for doing these tests. 

 

Hook

 

You are very welcome Larry, and you are right, only you and ANZ121 have ever bothered.

 

I just wish we didn't always have to do everything the hard way  :lol:

My final contribution will be to say that there is no leak, and I'm going to say so definitively. 

 

There is, however; a lethal combination of settings that will kill the sim in no time, but that is on us, if we are not willing to compromise. 

 

Maybe LM can work to reduce the amount of VAS that autogen requires, sure, but I doubt they will, as they never intended for these settings to be used the way many of you are trying to use them.

 

In any case, this has been fun.

 

:t0152:


Regards,

Brian Doney

Share this post


Link to post

My final contribution will be to say that there is no leak, and I'm going to say so definitively.

 

There is, but you've proved it's not in the vegetation.  :)  Looks like it's the new XML parser at this point.

 

Be sure to report this on the LM forums.

 

Hook


Larry Hookins

 

Oh! I have slipped the surly bonds of Earth
And danced the skies on laughter-silvered wings;

Share this post


Link to post

There is, but it's not in the vegetation.  :)  Looks like it's the new XML parser at this point.

 

Hook

 

Maybe, I don't know as I do all my testing in the Beech, which though XML has very little going on.

 

If they've tightened things up the way Fr Bill has said though, then it isn't the parser causing the leak, it would be gauges coded in the more relaxed format of previous versions that are to blame. (note by blame I do not mean that the gauge devs themselves are at "fault", just that you can't blame a more strict system, that was designed to be more strict, for being more strict)

 

I won't say any more though as I really haven't done any testing for it.

Be sure to report this on the LM forums.

 

 

I don't know if I have the will  :lol:


Regards,

Brian Doney

Share this post


Link to post

 

 


I won't say any more though as I really haven't done any testing for it.

 

Go on ............ I dare you !!  :Waiting:  :Waiting:  :dance:

Share this post


Link to post

Go on ............ I dare you !! 

 

:Worried:

 

:Cry:

 

:Silly:


Regards,

Brian Doney

Share this post


Link to post

I don't see that it's necessary, considering anthony31 has pretty much proven it.

 

http://forum.avsim.net/topic/435146-v21-oom-test-three-conclusions/page-2#entry2931865

 

Hook

 

Agreed.

 

My only point was, that if he was able to fix it by cleaning his code, then the issue still isn't the engine.

 

It is unfortunate though. The hope for devs and end users, well, all of us, was that any updating would be relatively simple and hopefully not too time consuming. This may have an impact on the number of "free" addon updates for P3Dv2.

 

(I do think LM handled that pretty poorly. Any sort of heads up would have been nice)

 

Anyway, the dinner bell is ringing, and I do think I've had my fill of AVSIM for today   :lol:

 

Take care, all.


Regards,

Brian Doney

Share this post


Link to post

OK, Just finished test flight #1, Fresh 2.1 complete install, stock CFG, Mooney w/G1000, 8K ft@235kts and here are the settings and stats.

Let me add that it was SMOOTH the entire flight with no stutters!!! Love it!

At start of flight FREE VAS=2.4G End of 2.5hr flight FREE VAS=1.0G

klfi to kind 2.5hrs

FPS set to Unlimited

FXAA=off MSAA=8x Anio=16x 4096x4096res Tess=on LOD=Max Tess=Max Scenery Obj=Dense No Shadows HDR=on Clouds=60+detailed Traffic=0

NI Settings, AA=Super_Cava_64X_4v12 VS=Adaptive and Force On

PC Specs
WIN7 out of box 2010 No updates
I5-2500k OC to 4.5G
P67 ExtremeB4 ASRock mobo
8G med speed ram
Nvidia 6600TI 2G
SSD Hdd

Any other info needed?? Going to do the test flight others want at 320kts in the F22

Rob


Rob Archer

 

KIND Flying in a Full size 737 simpit

Share this post


Link to post

 

 


My only point was, that if he was able to fix it by cleaning his code, then the issue still isn't the engine.

 

I'm gonna say it is the engine.  There are a lot of aircraft out there that will never be updated, and some will have the memory leak.  They broke it with a code change, they could fix it with another code change.  If the XML is compiled into the model, it can't be extracted by a third party to be fixed.  Lots of stuff that's no longer supported.

 

Besides, don't some of the LM aircraft have the same problem? :)

 

Hook


 

 


Going to do the test flight others want at 320kts in the F22

 

If the F22 doesn't have the problem sitting on the runway, the only solution would be to turn down the sliders.  If it's ok on the runway, give it a shot and see what it does.

 

Hook


Larry Hookins

 

Oh! I have slipped the surly bonds of Earth
And danced the skies on laughter-silvered wings;

Share this post


Link to post

I'm gonna say it is the engine.  There are a lot of aircraft out there that will never be updated, and some will have the memory leak.  They broke it with a code change, they could fix it with another code change.  If the XML is compiled into the model, it can't be extracted by a third party to be fixed.  Lots of stuff that's no longer supported.

 

Besides, don't some of the LM aircraft have the same problem? :)

 

 

 

Seems like the Raptor sure does, at least, but that's likely because LM haven't updated the default aircraft for the new parser, which is indeed kinda  :rolleyes:

 

The default aircraft will likely need the same cleanup done, or LM may simply relax the parser a bit, I don't know.

 

Hopefully they will work with the dev community to decide on the best way forward, and hopefully sooner rather than later.

 

As much as it sucks for us to have to wait, having the dev community themselves in limbo, or faced with a bunch of "busy work" that doesn't actually need to be done, is far worse.


Regards,

Brian Doney

Share this post


Link to post

I am getting mine with the Razbam Metroliner III. About 1 hr into the flight or less, with depending on load. This is really frustrating. Hope it is solve soon.


Best Regards,

Robert J McGill

Share this post


Link to post

Update to my earlier post,

Ok just completed test #2 and #3 F22 AT KLFI all scenery sliders maxed. Let it sit on runway for 3hrs, FREE VAS was 1.8G, I then took off and set AP for Hdg 355, 3000ft and 340kts.  Test #3 OOM after 45mins   

Rob Archer

 

KIND Flying in a Full size 737 simpit

Share this post


Link to post

Hi guys

 

I had massive OOM problems before. I was using the FTX NCA scenery on a clean P3D installation.

 

No matter which sliders I tried changing the OOM's persisted.

 

Then I deleted the P3D config file and reinstalled the Orbx libraries and the OOM's disappeared.

 

Yesterday I flew in the Raptor for more than an hour at 1000 knots over California and didn't see a single a OOM.

Share this post


Link to post

Some really good info:

 

 Some initial testing here is showing that there is a state we can get into where autogen tiles don't page out properly. If your settings and affinity masks are set up well and your flying slow enough to give tiles time to page in and out, they will get released properly. If you're flying so fast that jobs get cancelled before they draw, they should page out properly too. If your flying slow enough to have tiles load in but to too fast for paging to keep up, then some tiles don't get unloaded properly. This is why some users can fly for hours without OOMs and see VAS go up and down while others see it go up and up before an OOM.

 

Beau Hollis

Rendering System Lead - Prepar3D® Team

 

 

and also the XML parser:

 

There may have been one or two new checks added as well, but we haven't gone through it with a fine tooth comb just yet. If the xml validates, but some scripts have errors, the system can get in a state where the same error string is created and logged over and over again eventually leading to OOMs. I would suggest turning on gauge debugging in the Prepar3D.cfg and either fix the errors or avoid using any content that pop up alerts until the next patch. We're sorry about the legacy content effected by this. A silver lining may be that add-on developers might be motivated to go back and clean up script errors

 

Beau Hollis

Rendering System Lead - Prepar3D® Team

 

 

At this point, honestly...I think I'm gonna have to just put P3D away for now. Especially considering nearly everything has been made incompatible, in one way or another.

 

It would also seem that all of us had it wrong regarding the autogen memory leak, in that yes there is one, but then no there isn't  :wacko: Then again, since nearly every included aircraft and 90% of addons also cause OOM issues, who knows.


Regards,

Brian Doney

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    30%
    $7,720.00 of $25,000.00 Donate Now
×
×
  • Create New...