Sign in to follow this  
James Bennett

How do I get rid of VSync issues?

Recommended Posts

Flying FSX with acceleration and all the services packs etc, Nvidia graphics card, frames locked at 30fps and no stuttering but I still seem to get Vsync "tearing". I am using Nvidia inspector to handle graphics with the FSX profile in use. I know nothing about where to even begin with Vsync.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

AFAIK Your motherboard supports the use of lucidlogix Virtu MVP software (free for MSI mobo's maybe also for yours.) http://lucidlogix.com/products/virtu-mvp-2-0-for-windows/ - which amongst other things (not for FSX) is one of the best controls for vsync for many games. I use it for FSX and find it useful. Others may not, but it may be worth a try.

It has to be set up in the BIOS so read the instructions carefully.

Regards

pH

Share this post


Link to post
Share on other sites

I downloaded RivaTuner, which comes with a tool called D3DOverrider. This will allow you to make a profile, and force VSync and/or triple buffering for FSX. Works in both DX10 and DX9 modes.

  • Upvote 1

Share this post


Link to post
Share on other sites

I downloaded RivaTuner, which comes with a tool called D3DOverrider. This will allow you to make a profile, and force VSync and/or triple buffering for FSX. Works in both DX10 and DX9 modes.

 

Hi there.

 

Im a complete novice with Vsync, couple of questions.

 

1.can someone explain briefly to me what it is.

2.can I use rivatuner with a radeon gfx card (i have a radeon hd 5880)

3.can I use my motherboard settings in the bios (I have a Asus P8Z77-V PRO Z77 Socket 1155 8 Channel HD Audio ATX Motherboard)

 

many thanks for the advice

Share this post


Link to post
Share on other sites

Hi there.

 

Im a complete novice with Vsync, couple of questions.

 

1.can someone explain briefly to me what it is.

2.can I use rivatuner with a radeon gfx card (i have a radeon hd 5880)

3.can I use my motherboard settings in the bios (I have a Asus P8Z77-V PRO Z77 Socket 1155 8 Channel HD Audio ATX Motherboard)

 

many thanks for the advice

 

 

Threadjack!

 

So it seems it's a greater issue than some setting i can apply to Nvidia inspector or FSX?

Share this post


Link to post
Share on other sites

So it seems it's a greater issue than some setting i can apply to Nvidia inspector or FSX?

 

I tried that, and it didn't seem to work (either the "force on" or "1/2 refresh rate" option). So using a program like D3DOverrider or the other one that was mentioned should work. There is a fsx.cfg tweak for VSync, but if you tweak alot, then you have to keep adding it in. As deleting the cfg file will result in losing the tweak. It works in DX9, but I haven't gotten it to work with DX10. Maybe that's the issue.

 

These tweaks work fine with DX9, but DX10 seems to reject the cfg tweak or the Nvidia inspector tweak. Works fine with D3DOverrider though. It's sort of a "set it and forget it". Just set up the profile by clicking the plus sign and finding your FSX.exe file, and select "Force VSync". You'll either need to start D3DOverrider before you start FSX, or just have it run on startup so you don't need to. I personally have mine pinned to the taskbar, so I just click on it whenever I need it. Since the option is already set, there's no fiddling with it. 

Edited by magnetite

Share this post


Link to post
Share on other sites

I tried that, and it didn't seem to work (either the "force on" or "1/2 refresh rate" option). So using a program like D3DOverrider or the other one that was mentioned should work. There is a fsx.cfg tweak for VSync, but if you tweak alot, then you have to keep adding it in. As deleting the cfg file will result in losing the tweak. It works in DX9, but I haven't gotten it to work with DX10. Maybe that's the issue.

 

These tweaks work fine with DX9, but DX10 seems to reject the cfg tweak or the Nvidia inspector tweak. Works fine with D3DOverrider though. It's sort of a "set it and forget it". Just set up the profile by clicking the plus sign and finding your FSX.exe file, and select "Force VSync". You'll either need to start D3DOverrider before you start FSX, or just have it run on startup so you don't need to. I personally have mine pinned to the taskbar, so I just click on it whenever I need it. Since the option is already set, there's no fiddling with it. 

 

 

This program running in the background doesn't cause any instability issues or anything then? 

Share this post


Link to post
Share on other sites

This program running in the background doesn't cause any instability issues or anything then? 

 

None that I can tell. Never had any issues with it.

Share this post


Link to post
Share on other sites

A think i have the same problem.

 

The problem is along with limiting fps in inspector.

All newer drivers suffer from this.

 

I have found that 327.23 works fine, also fix the problem in games and the like.

Nvidia are aware of this problem.

Its all the gameready drivers i think.

 

Sometimes loading a saved game, will also have vsync broken.

 

First, try that driver.

Share this post


Link to post
Share on other sites

If you are running in full screen mode, then setting the Vsync to Standard and 1/2 Refresh in nVidia inspector will fix tearing and lock your frames to about 30, assuming a 60hz refresh rate (common on most monitors).  

 

If you are running in windowed mode, that doesn't work to limit FPS or stop vertical tearing.  In the [Graphics] section of your fsx.cfg, you can add:

 

ForceWindowedVsync=1

 

and that will stop the tearing in windowed mode, but will do nothing about limiting FPS.  

 

You will only have to put that line back in if you delete your .cfg file (but that's true for any tweak you add to your config).  

Share this post


Link to post
Share on other sites

If you are running in full screen mode, then setting the Vsync to Standard and 1/2 Refresh in nVidia inspector will fix tearing and lock your frames to about 30, assuming a 60hz refresh rate (common on most monitors). 

 

Fixed it instantly. Cheers!

Share this post


Link to post
Share on other sites

I downloaded RivaTuner, which comes with a tool called D3DOverrider. This will allow you to make a profile, and force VSync and/or triple buffering for FSX. Works in both DX10 and DX9 modes.

Jeff,

 

Thank you for this tip. It works!

Share this post


Link to post
Share on other sites

Or restart windows aero theme via FSUIPC. No tearing at all even without nVidia Inspector settings and ForceWindowedVsync=1.

Share this post


Link to post
Share on other sites

I've been looking at doing that fsuipc re start windows aero but the instructions make no sense to me at all. Like everyone knows how to create a batch file, I followed a google search on how to do it but I couldn't get it to work.

Share this post


Link to post
Share on other sites

I've been looking at doing that fsuipc re start windows aero but the instructions make no sense to me at all. Like everyone knows how to create a batch file, I followed a google search on how to do it but I couldn't get it to work.

 

You create a text file and save it as .bat .

 

Read this thread: forum.avsim.net/topic/375526-addendum-to-vsync-fix-windowed-mode/page-1

Share this post


Link to post
Share on other sites

But just restarting aero will not enable vsync by itself. Windows aero doesn't force vsync on every program. You have to set vsync somewhere for FSX specifically from among the many ways to do so.

Share this post


Link to post
Share on other sites

But just restarting aero will not enable vsync by itself. Windows aero doesn't force vsync on every program. You have to set vsync somewhere for FSX specifically from among the many ways to do so.

 

In my case it does, in windowed mode. After restarting aero via FSUIPC no tearing at all, not even a drop of it, locked @ 30 or unlocked frames. No vsync settings enabled in inspector or forcewindowedvsync=1 in cfg, nothing. Dx9 or DX10, doesn't matter. It's quite strange, I can't explain why, but aero cured the tearing completely.

Share this post


Link to post
Share on other sites

I can explain it. Somewhere you do have something set that enables vsync. We are talking Win7, right? Not Win8? Aero doesn't work one way on your computer and a different way on others.

Share this post


Link to post
Share on other sites

Yep. win7 64bit. No vsync enabled by default in nvidia control panel or inspector, so I don't have a clue. But I'm not thinking at all about it, it works fine. :)

Share this post


Link to post
Share on other sites

Thanks for the link mike2060, I will have a look at that.


Yes I had already looked at that post and I didn't understand it, for one the .bat file creation but also where to modify the fsuipc.ini and how to get fsuipc to run the .bat file.

I'm not computer savy enough.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this