Jump to content

Sign in to follow this  
Guest 727Fan

AFCAD2 Causes CTD. Desperate

Recommended Posts

Guest 727Fan

Desperation is creeping in, folks. Ongoing saga of my misadventures with AFCAD 2 causing Crash To Desktop, or more.Doesn't matter if it's my own AFCAD design of just adding a few extra gatesspots, or a full 3rd party file of an airport.Just the other day I was adding gates to KONT and KCNO. All's well. But then I placed a few spots at KPSP nearby, and WHAM, CTD!So I tried to start a flight at KPSP. Program goes to load flight, but crashes before the flight begins. So clearly AFCAD 2 is somehow giving FS9 a bad taste.If I delete the add on scenery file AFCAD 2 created, it's a 50-50 chance the airport will load, or not load the default.I'm really trying to figure this out, but it's been a baffling phenomenon so far.I use "fault finder," check for duplicate gate or parking designators, make sure all nodes are connected, and use the proper link button when connecting nodes to the new spots I create.I haven't use any 3rd party scenery files yet, so embedded AFCAD files aren't an issue.I have updated FS9 with the patch.I use XP Home with SP1 installed.Other than that, it seems my problem with CTDs and AFCAD 2 seem to be rather isolated, because I don't see many posts from other AFCAD 2 users.I must be doing something wrong here, and it's messing with my head. I don't want to back to FS2K2, which ran flawlessly on my system.AAAAHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH...........ThanksRick

Share this post


Link to post
Share on other sites
Guest Philip Olson

Rick, Have you installed any AI packages that might have contained AFCAD files? It really sounds like you could have conflicting AFCAD files. Double check your Addon Scenery/Scenery folder to see if there are any other AFCAD's. Another thing that you might try, and this is more of a long shot, is to change your video driver, I had a friend that had occasional CTD's that he attributed to AFCAD's, but one day he upgraded his video driver and the CTD's went away. Hey, I said it was a long shot! :-lol I hope this helps.Philip OlsonI'm the luckiest man in the world, my girl friend has a yoke and rudder pedals! Eat your hearts out!http://www.precisionmanuals.com/images/forum/supporter.jpg

Share this post


Link to post
Share on other sites
Guest 727Fan

Thanks Phil. No, I have no AI packages installed. Video drivers are Nvidia 2XP 61.77, and they are about a month old since I installed new video card.CTDs occurred before, and after the video card change-out.Latest clue now seems to be something in my aircraft folder. I did an uninstall, defrag, new install. I then installed a copy of the old, much larger Aircraft folder, as well as TTool generated flight plans and aircraft lists. No AFCAD was installed. This was a fresh install of FS9.So thinking I had started from reasonable scratch this time, I started a flight with the Howard 500 from previously troublesome KPSP. I lasted about 5 seconds on the tarmac, and the CTD occurred.I'm lost now. Either a bad aircraft, or perhaps there is a problem with the WinXP install, done by a professional, back in May 2004 after my original hard drive exploded. WinXP ServicePak 1 was also installed. I remember some folks had problems with FS 2K2 crashing after they updated with Service Pak 1.I don't know. I'm completely lost now. And I'm getting withdrawal symptoms now.Rick

Share this post


Link to post
Share on other sites
Guest 727Fan

No Shez. No addon scenery installed other than an AFCAD2 file.Like I said, these CTDs, which for the longest time seemed linked to a newly redone AFCAD file (in the Addon Scenery folder)now seem to be more than that.I can delete the modified AFCAD 2 file from the Addon Scenery folder after I get a CTD, and still get a CTD the next time I fly, even though it seems the CTD intially was caused by the new AFCAD 2 file.I'm afraid I'm going to have to go back to a fresh install, then ever so slowly re-introduce other components like AI and flyable aircraft, TTool created flight plans, and then, hopefully, AFCAD2. With a strict experimental environment, maybe I can pinpoint the problem. Is this really worth it? It is, after all, a game, right?If I can't make this work, and my computer skills are limited, I'll have to reluctantly junk FS9 and return to FS2K2.Thanks allRick KMKE

Share this post


Link to post
Share on other sites
Guest boswell254

Rick,You say that you have no AI packages loaded. Do you mean to this specific region? I had a problem some months ago which related to an ai traffic bgl that was a long way from where I was attempting to fly. Once I'd checked for no duplicate AF2 files, the next step was to remove all AI traffic and progressively re-add.RegardsAdrian

Share this post


Link to post
Share on other sites

Hi Rick.. same problem occured to me after installing a Paris-De Gaulle scenery. Something messed up in the AFCAD and CTD. Tried to uninstall the scenery but still CTD. I couldn

Share this post


Link to post
Share on other sites

In the library, there is a great freeware utility called ScanAFD. This scans all your scenery folders and identifies any duplicate afcad files.Duplicate afcads might not be the problem, but it is an easy place to start looking.

Share this post


Link to post
Share on other sites
Guest 727Fan

Thanks Folks for all the input.Johan. You mentioned that you are "very careful when messing around with AFCAD."So could you tell what you are careful of when you mess with an AFCAD? If you would share this info with me, maybe I can avoid a mistake you made.I'm just amazed at how sensitive FS9, and AFCAD2 are.I did alot of modifying Airport files in FS2K2 with AFCAD, and I probably had duplicate gate numbers, and all kinds of nuances that would bring AFCAD2 to its knees. I never had a problem with AFCAD 1.Really, the only addon scenery I have been using is AFCAD generated and AI Aircraft. My aircraft folder holds about 800 aircraft including texture variations. Or it did. I've just done a "clean boot" and reinstalled FS9 under that condition. We'll see. I've been using AVG 7.0 Antivirus software (recommneded by a majority of AVSIM readers) too, so by temporarily disabling it, I might have prevented it from corrupting a FS9 file.I also had a recurring sound problem with the SB Audigy, so I've installed the latest drivers for it. I was thinking maybe a conflict had caused the CTD.The "Settings Too High" idea is intriguing. Most of my settings are between 50% and 90%, depending on what it is. AI traffic is at 100%That's what I like most.I'll play around with all these ideas, and keep you all posted.A Quick look at my system;Intel mobo, P4 Northwood @2.0Ghz, 512 DDR Ram, SB AudigyThanks so much, everbody, for trying to help me. Rick (KMKE) The only place to see more B717s than anywhere else on the planetOOOHHHHH, 38F on Feb 1. That's a blessing

Share this post


Link to post
Share on other sites

Just Adding my two cents. I had the same experience with CTDs after a mega-third party freeware Aadd-session not too long ago. The error I would get would say something about a problem in the FACILITIES.dll(module), which I took to mean an airport (AFCAD) or scenery related item. Unfortunately, I could only solve the problem with a re-install. Now I log all of my scenery add-ons and only perform one at a time, so if there is a problem, I know what caused it and can then promptly remove the file. http://www.2decker.com/media/solent1-2.JPAlex ChristoffN562ZBaltimore, MD

Share this post


Link to post
Share on other sites
Guest smilinpete

The only CTDs that I have experienced came from texture files I downloaded from PAI to create an AI flight. Whether fs9 crashed or not depended upon where I was flying from, the time of day and the subsequent loading of the textures by the traffic module. And the crashes didn't begin when I installed the textures, but only later when I flew at a certain time and place. Possibly your crashes occur because the new afcads now enable a flight that wasn't generated before and the problem is with an aircraft and not the afcad. I noticed that if FS was going to crash before it loaded the flight it was always at 96% which is while it's loading the AI traffic.

Share this post


Link to post
Share on other sites
Guest 727Fan

I'd actually like to know if anybody has achieved CTD-less performance with FS9.1?I'd like to have 1200 aircraft (30 flyable and 1170 AI) in my aircraft folder, AFCAD2 designed parking at roughly 33% of all the airports in FS9.1, and a few choice add-on scenery files, like Misty Fijords.Anybody?Rick

Share this post


Link to post
Share on other sites
Guest Philip Olson

I don't have any CTD's currently! I have FS9.1, every single PAI package available plus some cargo packages and military packages that either I created or downloaded to cover some of the things that PAI has not covered yet. I also have about 600 AFCAD2 files, and quite a few add-on sceneries as well as many, many planes, panels, sounds, etc. I think that the only way that you are going to be able to find out what is causing your issues is to uninstall FS9, delete all of the left behind folders and files and then do a search of your hard drive to verify that everything is gone. Reload FS9 and apply the patch, at this point fly for awhile without adding anything else to verify that you do not have any system or driver issues causing the problem, if everything works fine then start to SLOWLY load your add-ons back in, maybe two or three items at a time and then test them to make sure that you don't have a problem. I think that you may have a problem that resides in the files that you are trying to copy back into your new install of FS9. The only truly good way of restoring a re-install of FS9 back to the way you had it is to re-install your add-ons too, not just copying the files from your previous installation because you are just copying the problems too. Yes, it takes time to do it this way but it will be time well spent because you will have a "clean" install without any corrupted files. I learned this a few years ago when I did exactly what you are doing, I kept re-installing FS and then just dumping all of my add-ons back in only to find that the problem came back time after time, so I went through my add-ons, wrote them down and downloaded them again, applied them to a frsh install of FS and all of my problems went away. Now after I download and install an add-on I move the zip file to another drive on my computer and then once a month I burn those zip files and exe. files to a CD and delete them from my computer. Now when I have to re-install FS I put in those CD's and install my add-ons fresh. There are really only two possible explanations for your problem, one is a computer or driver issue that I think you have ruled out so the next thing is an issue with the files that you are adding back into FS so that is where you have to look. I hate to bring you bad news like this but I am just trying to help.Good luck!Philip OlsonI'm the luckiest man in the world, my girl friend has a yoke and rudder pedals! Eat your hearts out!http://www.precisionmanuals.com/images/forum/supporter.jpg

Share this post


Link to post
Share on other sites

Try something else first. Remove ALL after market AFCADS. If you already did that then try this. I put my AFCADS into thier own seperate folder in Add-on scenery folder then add them through the scenry config editor in settings. I believe I have never had a crash with it like this due to an AFCAD file. Defualt install into the scenery folder in Addon scenery may or may not be causing this. Hornit

Share this post


Link to post
Share on other sites
Guest Kingair315

You might check to make sure that all AFCAD2 files are going into the addon sceneryscenery folder. Ive sometimes found that AFCAD put them elsewhere. WHY? I believe that it is loading AFCAD2 after using some other program, which leaves stuff in memory which may conflict with AFCAD2. Have never had this happen, after rebooting, then using AFCAD2..... Bob

Share this post


Link to post
Share on other sites
Guest 727Fan

Thanks Folks!!Some GREAT advice from people who have also battled problems like I've got.I will re-start slowly, keeping track of all additional files added.Right now FS9.1 sits in a virgin state on my hard drive. After the "clean boot" reinstall, I took the Mooney out for a quick circuit at Palm Springs. This was where the latest CTD seemed to be caused by an AFCAD, and the problems cascaded from there.The flight went off OK.So far so good. The real trick here will be to lay-off the AI Traffic. I'm afraid I'm an AI junkie, and want to put "realistic" AI at every airport I visit.Thanks for all the help. It's very much appreciated. Everyone come on over for a beer!!Rick

Share this post


Link to post
Share on other sites
Guest pjanastacio

>Desperation is creeping in, folks. Ongoing saga of my>misadventures with AFCAD 2 causing Crash To Desktop, or more.>Doesn't matter if it's my own AFCAD design of just adding a>few extra gatesspots, or a full 3rd party file of an>airport.>Just the other day I was adding gates to KONT and KCNO. All's>well. But then I placed a few spots at KPSP nearby, and WHAM,>CTD!>So I tried to start a flight at KPSP. Program goes to load>flight, but crashes before the flight begins. So clearly AFCAD>2 is somehow giving FS9 a bad taste.>If I delete the add on scenery file AFCAD 2 created, it's a>50-50 chance the airport will load, or not load the default.>I'm really trying to figure this out, but it's been a baffling>phenomenon so far.>I use "fault finder," check for duplicate gate or parking>designators, make sure all nodes are connected, and use the>proper link button when connecting nodes to the new spots I>create.>I haven't use any 3rd party scenery files yet, so embedded>AFCAD files aren't an issue.>I have updated FS9 with the patch.>I use XP Home with SP1 installed.>Other than that, it seems my problem with CTDs and AFCAD 2>seem to be rather isolated, because I don't see many posts>from other AFCAD 2 users.>I must be doing something wrong here, and it's messing with my>head. I don't want to back to FS2K2, which ran flawlessly on>my system.>AAAAHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH...........>Thanks>Rick>>Do you by chance use FSAutoStart? Since I stopped using it, my CTDs and in some cases a complete system reboot while using FS2004 have stopped. I too was a wit's end with CTDs...I am sure that the program works well for some, but for me it didn't.Peter

Share this post


Link to post
Share on other sites
Guest bobsk8

>In the library, there is a great freeware utility called>ScanAFD. This scans all your scenery folders and identifies>any duplicate afcad files.>>Duplicate afcads might not be the problem, but it is an easy>place to start looking. I just dowloaded Scan AFD and it says I am some duplicate files, from Ultimate Traffic and a new Norway Scenery I downloaded this week. Are you supposed to remove the duplicates , or is it OK to leave them if the scenery priority is different? For instance the UT files are level 3 and the Norway Afcads are level 1.

Share this post


Link to post
Share on other sites
Guest Kingair315

Scenery for older versions will work in FS9, BUT, if it includes an AFCAD or you copied that AFCAD into your ADDON SCENERYscenery folder, it can cause a CTD. All AFCAD's in FS9 should begin with the letters AF2_ Bob

Share this post


Link to post
Share on other sites
Guest JoeW

My 2 cents........ Never delete anything in FS9. BGL's can be renamed to *.bak's. You should never have 2 AF2 files in active folders. You will get a CTD everytime. If you have 2 AF2's..... Rename one to a bak and go look.... then try the other...... keep the one you like best. If you want both...... then you'll have to combine the two with the AFCAD program.Joe W

Share this post


Link to post
Share on other sites
Guest Kingair315

Many problems with W98 or XP and XP with SP1,2 happen because the registry is corrupted or has a lot of invalid links.Reccomendations for better operation or to stop CTD of your system:If using W98, ME, et.al. Upgrade to XP it will virtually eliminate "Errors". Your entire system will operate much better, and faster.IF you are using XP, without SP2, installing it will give you a _framerate_ boost, and other improvements.The FS was created with XP, and the FS patch was undoubtedly created, with SP2 installed. If not using SP2, by all means upgrade, there are too many reasons to do so, to repeat here.You might search for: RegCleaner 4.2 by Jouni Vuorio or RegScrub, are free, I use both. the latter is simpler... After installing...RegCleaner Set the "Options, Registry Cleanup, Method" to Automatic. Then, click on "Tools, Registry Cleanup, Do them all." It will safely clean your registry, even if you know nothing about it.This will delete all _invalid_ registry keys, etc. First time it ran on my system, it deleted 287! One person I told about cleaning the registry, said it deleted 1643 invalid registry keys, and his system ran like it did brand new.Even if you have Norton One button cleanup, it does not get them all. Ive run it after running Norton, and found as many as 17 invalid links. Each time you add or delete something from your HD, it can leave an invalid link. Even something as simple as deleting a picture you no longer want. Over time, invalid registry entries can slow your system to a crawl. I run it each day after deleting anything. And Find if even if deleted from Control, Remove Software, the majority of the time it leaves links to what was deleted. Many software demo's or paywares which gives you a free trial, leave links in the registry, to prevent you from using it over, and over. They also may leave folders with junk in them. You can get RegCleaner free, I've used it with W98, ME, XP, and I'd not do without it after using it.If now using Adaware, and Spybot, its a good idea to begin. They can get rid of a LOT of programs which tell companies where you are surfing, and more. Each time they do, is slows down your system as they use bandwidth. If there are hundreds of them on your system, the time they use is significant. Removing spyware, can also leave invalid links in the Registry, so run RegCleaner after doing so, I'd run it at least once a week. Sometimes I run it daily.... Some Spywre attempts to control your system, and can cause conflicts.Cleaning your Registry and getting rid of Spyware, makes your operating system work the way it should. There are so many causes of problems, in FS which are caused from invalid links in the Registry, its not possible to list all of them. Every time I have a problem with the FS, _first_ thing I do is run the RegCleaner. Bob

Share this post


Link to post
Share on other sites
Guest 727Fan

Joe. I'm not sure I understand. I should never delete an AFCAD2 file in the addon scenery folder, but just rename it "bak" and it will then be ignored by FS9?You said; "You should never have 2 AF2 files in active folders. You will get a CTD evertime."Do you mean 2 AFCAD2 files of the same airport in the Addon Scenery folder?I never had that. I also never had any scenery packages installed in the folder, so embedded, and therefore duplicated AFCAD files, were never a question.But please do clarify. I need all the advice and tips I can get!!Rick

Share this post


Link to post
Share on other sites

3.552 AFCAD2 airports, 58 are duplicated at different levels where Microsoft had given them the wrong name (only done the UK, a few airports have the wrong city and all RAF stations should be prefixed RAF instead of the default AB suffix, also the Navy suffix should be pefixed either RNAS or HMS), and some others have duplicates to fix/add aditional airport feature all with no apparent problems, on the rare ocasion i do get a CTD the problem is elseware.

Share this post


Link to post
Share on other sites
Guest JoeW

Delete only if your sure.I meant 2 AF2's of the same airport in any active folder. Example: one AF2 of KSEA in the addon sceneryscenery folder and another in the scenery folder for KSEA. I would rename the one in the addon sceneryscenery folder then move the other AF2 to the Addon sceneryscenery folder, then rename the AF2 in the KSEA scenery folder. That way you only have one af2 active.Beware of the program ScanAFD, it doesnt look in the sceneryworldscenery folder. There can be one here working and it will not find it. It's a good program but doesn't find them all.Renaming to a *.bak will make FS9 ignore it but it can be re-named back to a *.bgl and it will work again.Joe W.

Share this post


Link to post
Share on other sites
Guest Kingair315

Many problems with W98 or XP and XP with SP1,2 because the Registry is filled with Invalid links.Recommendations for better operation or to stop CTD of your system:If using W98, ME, et.al.Upgrade to XP it will eliminate many "Errors". Your entire system will operate much better, and faster.IF you are using XP, without SP1 and SP2, installing it will boost _framerate_ and make other improvements.The FS was created with XP, and the FS patch was undoubtedly created, with SP2 installed. If not using SP2, by all means upgrade, there are too many reasons to do so, to repeat here.Each time you _delete_ something from your HD, it can leave an invalid links. Even something as simple as deleting a picture you no longer want. Over time, invalid registry entries can slow your system to a crawl, if FS pauses too long, it errors. Software demo's or payware which give you a free trial, leave links in the registry, to prevent you from using it over, and over. They also may leave folders with junk in them, which you need to remove manually. You can get RegCleaner free, I've used it with W98, ME, XP.You might search for: RegCleaner 4.2 by Jouni Vuorio.After installing...RegCleaner Set the "Options, Registry Cleanup, Method" to Automatic. Then, click on "Tools, Registry Cleanup, Do them all." It will safely clean your registry, even if you know nothing about it.This will delete all _invalid_ registry keys, etc. First time it ran on my system, it deleted 287! One person I told about cleaning the registry, said it deleted 1643 invalid registry keys, and his system ran like it did brand new.HOWEVER... both my wife's and my computer have been slowing down drastically over the past year, and even have had a few "blue screen errors." Pages which used to load in 4-5 seconds, have been taking 16-20 on DSL!A friend told me to check this link for a better program http://www.registryfix.com/ Decided to try it. It found 275 errors which the above programs have _never_ found. It Fixed 37 which helped, to fix the rest you need a registered copy, which costs $29.95 . . . .. Decided to buy it, ran it to delete the others, and rebooted. Now all webpages which Ive tried, load in _one_second_ or less! Unlike the other programs, it searches the entire drive for orphaned files or links and missing shortcuts, et. al.I'd removed norton and some other programs _months_ ago, it found six links still existing to norton. If not using Ad-aware, and Spybot, (freeware) its a good idea to begin. They can get rid of a LOT of programs which tell companies where you are surfing, and more. Each time they do, it uses bandwidth. If there are hundreds of them on your system, the time they use is significant. Cleaning your Registry and getting rid of Spyware, makes your operating system work the way it should.There are so many causes of problems, in FS which are caused from invalid links in the Registry, its not possible to list all of them. Every time I have a problem with the FS, _first_ thing I do is clean the system.I highly recommend you at least check out the demo at: http://www.registryfix.com/ Bob

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...