Sign in to follow this  
virginblue737

High FPS but getting Stutters

Recommended Posts

Evening All, 

 

So i have had this problem for a while now, but have never really addressed it. 

 

It seems ( Most noticible ) when Taxing in or out at slower speeds ( E.G 0-30 Knots ) Its noticble that i am getting some stuttering. Im acheiving really smooth FPS, like anywhere from 25 - 30 Fps, but getting stutters. I was reading somewhere that texturebandwithmult may do something with stutters, i have had it from 40 to 80 to 120 and to 400, but following kostas guide i have it atm set at 40. 

 

I have my Affinity mask set to 15 instead of 14, i have Texturemaxload set to 21, im ususing steves dx10 fixer, i have frames set to 30 in Nvidea inspector and unlimited in the sim, i have Pre rendered fps set to 3 ( What is this setting ? could it cause the stuters ) ? 

 

Again the stuttering is only really noticible when taxing at say slower speeds.

 

System specs are : I5 4670k OC 4.4GHz, 8 gb ram and GTX770

 

Any suggestions

 

Jack


Another Tweak, i have Vsync set to 1/2 In nvidea inspector, but i dont use the force fullscreenvsync eg, i would prefer a little bit of image tearing then the stutters 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I am really interested in seeing the answers from your post . I also get stutters, but it doesn't matter what I'm doing or where. I also get good frame rates.

Share this post


Link to post
Share on other sites

Try locking your frames to a lower number that your system can maintain with your settings ie: 30 or even 20.  What have you set road traffic at? Airport ground vehicles? AI Traffic? What AA settings are you using.  I have 780 card and can still get stutters when I turn the AA settings too high.  You say the problem is worse when taxiing.  Are you using addon airports.  There is a lot happening at airports, especially if you have lots of AI.  Generally the only way to get rid of stutters is to turn down some of the settings until your system can easily maintain the locked framerate you are trying to maintain. 

Share this post


Link to post
Share on other sites

Two things that helped cure my stutters:

 

1.  You need to set affinity mask to 14 to ensure that one core is free for processes.

 

2. Try the usepools=0 tweak, that helps too.

 

FSX usually works best on a separate hard drive, failing which separate partition, failing which, outside of the program folder (e.g. root drive).

 

Do you still get stutters if you move some of the sliders to the left< AI traffic and road traffic can have an adverse effect, so try turning them down - no more than 20% for road traffic and 50% for AI.

 

I assume that you have tried turning off your anti virus, anti malware, etc. as they can be a cause of stutters as can any other process that may be running in the background.  How many processes do you have running and which version of Windoze?

 

IAN

Share this post


Link to post
Share on other sites

Hi All, 

 

Thank you for all your posts. 

 

I have road settings set to only 5% i had it at 20 inintially but kept bringing it down to see if i got results, other then the freeway traffic all of my other traffic settings are set to 0, as i fly on Vatsim i just rely on other people flying for my traffic. 

 

Ian, i already use the bufferpools=0 tweak. Process i normally try and disable as much as i can, but i make sure that i have no uneccesiarly process runing whilst i am flying, for example i do the flight planning before i get into the sim, so when i start FSX the only things running are FSINN, Active sky next, FS Real time, and of course FSX itself and then depending if im flying for a Virtual airline the odd VA tracker may be open. 

 

I use the NGX, and it dosent really matter if im at a FPS expensive airport like ORBX brisbane, or a defualt scenery, im still getting the stuutters. 

 

I just have one question and it really does puzzle me, if im getting a smooth 25 - 30 fps whilst i am taxing, why are the stutters occuring, i mean you press SHIFT Z twice to see your FPS and its going from 28 to 34 ect but at the same time you are stuttering. It puzzles me


Thinks like this just make the switch to P3D seem even better to do, I guess when the time comes and if it comes, where PMDG take there Planes over to P3D and of course other major producers, i think alot of people will make the switch. What do you guys think ?

Share this post


Link to post
Share on other sites

I know this goes against most of what is out there, but instead of externally limiting your FPS, lock it to 25 inside FSX and get rid of the Nvidia inspector limitation.  It's becoming more and more noticeable that the internal FSX limiter is better than an external on some systems.  Also have you done what Ian suggested regarding your affinity mask setting?  Set it to 14.

Share this post


Link to post
Share on other sites

HI Dylan, 

 

I will set it back to 14, what about texture bandwith mult ? Can you give me  a recomended setting for that i have had it from 40up to 400 and have no idea what it does 

Share this post


Link to post
Share on other sites

One other thing I've noticed is the graphics card driver.  I've installed some where the fps shoots up and down like a yoyo and others where the fps are a bit more stable, so it could be worth trying a different driver.

 

As far as smoothness goes, I've also found that limiting fps within fsx to 30 helps, but not if you are only getting 25 fps of course.  Some swear by using an external framerate limiter, but I've found the fsx limiter to be fine (when compared).

 

IAN

Share this post


Link to post
Share on other sites

Definitely agree with Ian regarding GPU drivers.  Also make sure you select clean install when testing new ones.

Share this post


Link to post
Share on other sites

Lock frames internally to 30 for TBM and TML to work.

        

[GRAPHICS]
HIGHMEMFIX=1 //Added
TEXTURE_MAX_LOAD=2048 //1024,2048,4096

 

[Display]
TEXTURE_BANDWIDTH_MULT=120 //40,80
TextureMaxLoad=6 //6, 9
 

Dave

Share this post


Link to post
Share on other sites

I'm running a I5 2500k @ 4.6, 8gb ram with a 2gb gtx770 just down loaded the latest nvidia drivers and am now able to set monitor refresh at 50hz so with 1/2 vsync in Inspector and frames limited to 25 in fsx I get the same smoothness as with 30fps and monitor at 60hz but which I could not always maintain 30fps,

this is great as my system has the headroom to run at 25fps all day long

I run with all the usual addons ie, NGX, orbx england, rex, uk2000 airports etx and AA 2x sgss with most sliders to the right

 

cheers

Adam

Share this post


Link to post
Share on other sites

Is it just around airports ? If so check to see if you have AEMODULE.DLL in your dll config.

 

If you have take it out and see what happens.

Share this post


Link to post
Share on other sites

I have TBM set to 60 and have done for some time.  I've experimented with higher and lower and this seems to suit my current system best - your mileage may vary.

 

I can't remember for sure but I think default is 30 or 40.

 

IAN

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this