Jump to content

Archived

This topic is now archived and is closed to further replies.

Andreas Stangenes

Runtime error R6025 faulting msvcr100.dll

Recommended Posts

Ah, I don't use RAAS, removed it from my system. Worth checking though.


Will Reynolds

 

Flight Sim Addict

 

Posted Image

Share this post


Link to post
Share on other sites

Ok a little report from me. I dont have anything conclusive yet, but Ive done three things somewhat simultaneously, and I havent tested enough to say if it has fixed anything:

1. I ran p3d without using ASN for several hours yesterday and today.

2. I reverted my nvidia inspector settings to default, and only tweaked my graphics settings using the default nvidia panels.

3. I sat infinity mask=15 in my cfg (this is probably not a fix for anything but fluidity and effective use of my cores. Just mentioned it anyway).

 

So far I havent had a single crash, and my sim is pretty smooth. I will try using ASN tomorrow again to see if my crashes return.

 

Additional information: I have flown for like 4 hours in one gaming session today. My route has been ENML to ENBR to ENGM to ENVA on vatsim using vPilot. I have not restarted p3d or vpilot once yet. When I started my available virtual memory was 2.2gb. After about 4 hours it's down to 1.6gb. Fluidity is pretty good :)

 

I hope it was the invidia inspector settings that fooked me up, and that I can start using asn again tomorrow.

Share this post


Link to post
Share on other sites

Ok my crashes persisted, but now I think I've solved my problem. I noticed that I had several simconnects installed (like 3-4). I uninstalled them, and proceeded to uninstall all my addons and then finally p3d. I reinstalled everything and now my sim is working perfectly. No more crashes :)

I have only 2 versions of simconnect installed at the moment.

Share this post


Link to post
Share on other sites

I'm having this crash too. I'm also using Airbus X Extended and Active Sky Next. As a point of interest, I had to install the Simconnect package that comes with Prepar3d 2.2 manually. It didn't get installed when I installed the sim. It's happened to a lot of people apparently. I'll be interested to see if anyone has found a fix other that uninstalling everything...

Share this post


Link to post
Share on other sites

Ive been having the same issue today having had no problems at all.  The only change to my PC today was updating the Nvidia GeForce Experience.  Just done a complete clean install of Windows 8.1 & P3D so will see

Share this post


Link to post
Share on other sites

Well I suspected anything and everything to be the cause of this crash (ezdok, ASN, js41, ftx global, rex, you name it). However, as I mentioned, It seems that at some point I accidentally installed multiple versions of simconnect (there IS such a thing as too much of a good thing after all). If you are having the crash problem mentioned in this thread, try uninstalling and reinstalling simconnect and see if that helps .

Share this post


Link to post
Share on other sites

I'm having this crash too. I'm also using Airbus X Extended and Active Sky Next. As a point of interest, I had to install the Simconnect package that comes with Prepar3d 2.2 manually. It didn't get installed when I installed the sim. It's happened to a lot of people apparently. I'll be interested to see if anyone has found a fix other that uninstalling everything...

Chris512, see my post a few lines higher.

 

 

As a test: please rename your dll.xml to dll_xml and see if you still get this particular error!

I've also had this Runtime error R6025 faulting msvcr100.dll from P3Dv2/v2.1 and even in v2.2

 

The error came each time I had to reload a plane/heli/... ANY simobject, even the defaults, caused it.

The only thing I had to do is crash the plane and the error came on the screen.

 

Untill I started disabling all modules in my dll.xml; re-enabled one by one untill I got again the error when crashing.

In my case, and someone else on the LM P3Dv2 forum, it was RAASPRO.dll causing this.

Note that I am up to date with all Aerosoft products. This includes the Twin Otter and Airbus!


Regards,

 

Vital Vanbeginne

OneDrive Picture Library: http://1drv.ms/1XJppeh

sig.jpg

Share this post


Link to post
Share on other sites

Thanks for that. I think I'll go and get rid of the RAASPRO.dll for a start off then. I don't like it anyway... I just looked at the Prepar3d forum. A lot of people have this issue, even with a Vanilla install. Not a lot of response from Lockheed Martin either...

 

Chris512, see my post a few lines higher.


As a test: please rename your dll.xml to dll_xml and see if you still get this particular error!
I've also had this Runtime error R6025 faulting msvcr100.dll from P3Dv2/v2.1 and even in v2.2

The error came each time I had to reload a plane/heli/... ANY simobject, even the defaults, caused it.
The only thing I had to do is crash the plane and the error came on the screen.

Untill I started disabling all modules in my dll.xml; re-enabled one by one untill I got again the error when crashing.
In my case, and someone else on the LM P3Dv2 forum, it was RAASPRO.dll causing this.
Note that I am up to date with all Aerosoft products. This includes the Twin Otter and Airbus!

Share this post


Link to post
Share on other sites

Indeed like you're saying; not everyone has thie R6025 crash... some of us are flying the AXE without getting this error. Some of us don't even have the AXE and are getting this crash.

 

But well... personally I'm looking at it like this: there are worse things in life. This is simply an inconvenience in a product you've spent some money on.

 

Good luck, hope this trick helps you get rid of the error! ;-)


Regards,

 

Vital Vanbeginne

OneDrive Picture Library: http://1drv.ms/1XJppeh

sig.jpg

Share this post


Link to post
Share on other sites

I also have this problem. I have rex installed, ASN, Majestic dash 8, QW 757. I dont have the AXE though. I myself am also trying to figure out whats up with this. i will keep you posted.

Share this post


Link to post
Share on other sites

I also posted another thread re this problem. I get it when the airplane crashes into an object, or just like 10min into the climb to cruise. Very annoying!

I have the MJC DH8D installed and I use Active Sky Next for weather.

I also have UT2 installed, but disabled until I fly online.


Michael Shamash

FlightSim Solutions GP

Share this post


Link to post
Share on other sites

UPDATE: Disabling the RAAS pro that comes with the AXE seemed to have fixed the problem when any aircraft crashes into an object and I now get the error message only during flight at random times. Thankfully now I can hide it and continue flying!

Hopefully this bug is fixed very soon!


Michael Shamash

FlightSim Solutions GP

Share this post


Link to post
Share on other sites

Guys I also started a thread about this error here:

 

http://forum.avsim.net/topic/444699-anyone-else-getting-the-dreaded-r6025-windows-error-message/

 

F++ replied on the thread and suggested I take a look at another thread where the ASN X-GAUGE was responsible for causing the R6025 error in FSX. See last post here:

 

http://forum.avsim.net/topic/444989-windows-7-pro-64-default-beep-on-shutdown/

 

The last post from flying engineer could be the solution. I'm going to reinstall ASN tonight but without  the X GAUGE option and shall report back.

 

Please update this thread with your findings as well?

 

Adam

Share this post


Link to post
Share on other sites

Guys I also started a thread about this error here:

 

http://forum.avsim.net/topic/444699-anyone-else-getting-the-dreaded-r6025-windows-error-message/

 

F++ replied on the thread and suggested I take a look at another thread where the ASN X-GAUGE was responsible for causing the R6025 error in FSX. See last post here:

 

http://forum.avsim.net/topic/444989-windows-7-pro-64-default-beep-on-shutdown/

 

The last post from flying engineer could be the solution. I'm going to reinstall ASN tonight but without  the X GAUGE option and shall report back.

 

Please update this thread with your findings as well?

 

Adam

Hi Adam,

 

Thanks for the suggestions. How can I uninstall X GUAGE from ASN/P3d? Do I need to reinstall ASN completely?

 

Mike


Michael Shamash

FlightSim Solutions GP

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    10%
    $2,505.00 of $25,000.00 Donate Now
×
×
  • Create New...