Sign in to follow this  
Guest baksteen33

FS2004 Stuttering Even With High Frame Rates

Recommended Posts

Is "stuttering" (frame randomly freezes for second or two) in FS2004 related to frame rates? I consistantly get frames rates of 40fps and above, sometimes 70fps to 80 fps, but I still get stuttering. I don't think I can get any higher frame rates. Anyone have any suggestions how else the stuttering can be eliminated?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Try to limit your framerates to 40 or 30. I saw this happen with some airarft and real fast graphics cards. Also you can try to set your video cards latency to a lower value. It is possible that the cad hogs the PCI bus. Do a search at the hardware forum for latencycfg.Alex

Share this post


Link to post
Share on other sites

Depends on what you mean by stuttering. If you are getting random freezes for 1-2 seconds this DOES NOT have to do with frame lock or frame rates (unless your FPS is 1/sec or worse). Most likely you have another process demanding your CPU's attention, such as loading of weather with one of the Addon weather programs such as ActiveSky. You can get brief pauses when weather updates. You may also get this when .wav files load if they are large and your file system is slow and/or badly fragmented. Or, you could have some other program running such as AV software or something which grabs the CPU for a brief period. If you are having steady "pause and release" behavior, as in when you look at the scenery outside it seems to stick very briefly then "catch up" rhythmically--this can be related to NOT having your frames locked to a lower rate specifically. This is my educated guess about your freezes.How many processes running in the background? Noel

Share this post


Link to post
Share on other sites

I agree. If you're running with unlimited frame rate then you're just asking for stutters as the CPU will inevitably get choked if it's trying to run the sim and keep the GPU filled. Try setting target frame rate to something like 35 or 40 and see what happens.

Share this post


Link to post
Share on other sites

Higher framerates do not seem improve performance much in fs9 once you get to higher numbers (30+) At least on my system. . I tried experimenting with unlimited frames, and even though I was getting on average of 40+fps, things were no smoother. There were still small stutters. Not sure why exactly. One thing that helps reduce my stuttering is turning off AI traffic completely. Even in cruise this helps it somewhat.

Share this post


Link to post
Share on other sites

First, thank you, and all the others who replied to my message and offered suggestions. I REALLY appreciate your suggestions.I reduced my frame rates from Unlimited to 30, but that didn't seem to help. The problem still occurs. I test for the problem by setting up an aircraft on autopilot, straight and level flight. Then I use spot view to rotate the image continuously around the aircraft. Aproximately every 2 360 degree rotations, the frame will freeze for about one half to three seconds, and then continue. I also go to virtual cockpit and rotate the view from inside the aircraft. Same thing happens. One thing I have noticed is that the freezing seems to happen more often and for longer times when the view I am scanning includes both sky and ground. If the view inculdes only ground, or only sky, it seems to perform better. No idea why.Some other information:Computer: Dell Dimension 8400, 3.4 GHz, 1 GB RAM, Windows XP Professional Sp 2, DirectX 9.0c, Dell 1901FP flat panel display (70 Hz refresh rate, 1280 X 768 resolution, 32 Bit color), Creative Audigy 2 sound card, ATI Radeon X700 PRO PCIe video card with 256 MB memory, latest driver (I use ATI Catalyst software to automatically configure the card for performance/quaility. I currently have it set to maximize quality because setting it to maximize performance doesn't solve the frame freezing problem.)I use FSAutoStart to start FS2004, defragment the memory, and close all processes and programs except for the following:Processes: ATI Hotkey Poller DCOM Server Process Launcher DHCP Client DNS Client Event Log IAA Event Monitor MSSQL$MICROSOFTBCM Network Connections Plug and Play Print Spooler Protected Storage Remote Access Connection Manager Remote Procedure Call (RPC) SAVSCAN Security Accounts Manager System Restore Service Telephony Terminal Services Windows Audio Windows Firewall/Internet Connection Sharing Wireless Zero Configuration Work Station Programs: ASMon.exe CLI.exe explorer.exe firefox.exe IAAnotif.exeFS2004 settings: Everything maxed out (I do this because adjusting the settings at lesser values doesn't eliminate the frame freezing problem)except for the following: Scenery Land Only (No water effect) AutoGen Very Dense Weather Sight Distance 60 mi. Cloud Distance 30 mi. 3-D clound percentage 10 Cloud Density Medium Hardware Anti-Aliasing Unchecked (controlled by video card) Bilinear Filtering MIP Mapping 4 Hardware Rendered Lights 8 Global Max Texture Size Massive Again, if anyone has any ideas how to solve the frame freezing problem, I greatly appreciate your help. I would think that with my particular computer configuration, I shouldn't have any problems running FS2004, but, obvioulsy, I do.

Share this post


Link to post
Share on other sites

I had exactly the same problem, a 1-2 second stutter every few seconds when I continually rotated the camera around the plane in the outside view.The solution for me was to set the Global Max Texture Size on the hardware tab to High, instead of Massive. This reduces the stutters greatly for me doing the same above test, and I see no visual difference.Also, did you download Airport Environment Upgrade 7.0? This has some pretty large textures, and some users were reporting stutters, which I assume were due to the loading of the textures.Scott

Share this post


Link to post
Share on other sites

>First, thank you, and all the others who replied to my>message and offered suggestions. I REALLY appreciate your>suggestions.>>I reduced my frame rates from Unlimited to 30, but that didn't>seem to help. The problem still occurs. I test for the>problem by setting up an aircraft on autopilot, straight and>level flight. Then I use spot view to rotate the image>continuously around the aircraft. Aproximately every 2 360>degree rotations, the frame will freeze for about one half to>three seconds, and then continue. I also go to virtual>cockpit and rotate the view from inside the aircraft. Same>thing happens. One thing I have noticed is that the freezing>seems to happen more often and for longer times when the view>I am scanning includes both sky and ground. If the view>inculdes only ground, or only sky, it seems to perform better.> No idea why.>>Some other information:>>Computer: Dell Dimension 8400, 3.4 GHz, 1 GB RAM, Windows XP>Professional Sp 2, DirectX 9.0c, Dell 1901FP flat panel>display (70 Hz refresh rate, 1280 X 768 resolution, 32 Bit>color), Creative Audigy 2 sound card, ATI Radeon X700 PRO PCIe>video card with 256 MB memory, latest driver (I use ATI>Catalyst software to automatically configure the card for>performance/quaility. I currently have it set to maximize>quality because setting it to maximize performance doesn't>solve the frame freezing problem.)>>I use FSAutoStart to start FS2004, defragment the memory, and>close all processes and programs except for the following:>>Processes:> ATI Hotkey Poller> DCOM Server Process Launcher> DHCP Client> DNS Client> Event Log> IAA Event Monitor> MSSQL$MICROSOFTBCM> Network Connections> Plug and Play> Print Spooler> Protected Storage> Remote Access Connection Manager> Remote Procedure Call (RPC)> SAVSCAN> Security Accounts Manager> System Restore Service> Telephony> Terminal Services> Windows Audio> Windows Firewall/Internet Connection Sharing> Wireless Zero Configuration> Work Station> >>Programs:> ASMon.exe> CLI.exe> explorer.exe> firefox.exe> IAAnotif.exe>>FS2004 settings: Everything maxed out (I do this because>adjusting the settings at lesser values doesn't eliminate the>frame freezing problem)except for the following:> Scenery > Land Only (No water effect)> AutoGen Very Dense> Weather> Sight Distance 60 mi.> Cloud Distance 30 mi.> 3-D clound percentage 10> Cloud Density Medium> Hardware> Anti-Aliasing Unchecked (controlled by video card)> Bilinear Filtering> MIP Mapping 4> Hardware Rendered Lights 8> Global Max Texture Size Massive> >Again, if anyone has any ideas how to solve the frame freezing>problem, I greatly appreciate your help. I would think that>with my particular computer configuration, I shouldn't have>any problems running FS2004, but, obvioulsy, I do.>>Geez your settings are very modest. You should be able to get much more image quality than what you ahve here with 10% 3D clouds, bilinear, etc. I would go through and eliminate every one of the programs that aren't essential for FS. And also try getting rid of unnec services, such as ATI hotkey poller. What the heck is SAVSCAN? Sounds ominous! How about getting rid of Foxfire, and whatever the other ones are. You should should try eliminating ALL programs and services that aren't critical. Make sure you have any chipset drivers installed, reinstall DirectX, etc.Noel

Share this post


Link to post
Share on other sites

>Anyone have any suggestions how else the>stuttering can be eliminated?Uhm, I'd suggest a step-by-step process: try to start with minimal settings (video, sound and AI aircraft) and to set your video card drivers to Performance Mode. Then go ahead turning up only some parameters a time (you can start turning up video card drivers settings, then go on to FS9 settings), and every time check out if the stutters are gone. This way you should be able to isolate the "stuttering factor" :)If stutters are still present with minimal settings, then maybe there's something to change in BIOS, or in FS9.cfg, or something else...

Share this post


Link to post
Share on other sites

My experience is that stutters are caused by CPU intensive operations of all kind.This can be hard drive transfers (e.g. loading of textures), rendering of visuals (e.g. you pan with the spot camera and FS needs to calculate the image for the new view angle), calculation of the behaviour of objects (e.g. aircraft, clouds, AI traffic, all in respect to weather conditions, gauges) etc. etc.I suppose you'll for sure get more or less stutters if your FS is beefed up with various add-ons.Teh formual is simple: the more things there are to display and the more complex it is to calculate an image to display them, the more stutters you get.I for my part have a _very_ clean WinXP and FS installation, a better-than-average system, but lots of add-ons and aircraft, and I almost always get stutters, and I don't expect them to ever go away.Remember, FS is so ressource hungry that it would currently cost you several ten-thousands of Euros to build a system capable of running it fluently with everything maxed out.Andreas

Share this post


Link to post
Share on other sites

It helped me to turn down my sound acceleration in dxdiag. I found that most of my stutters were occurring when ATC was talking to someone. This could be the case even if it's not on your frequency. You migh give it a look and see what happens.best

Share this post


Link to post
Share on other sites

FS has ALWAYS stutterd for me in spot view if I pan more than about 90 degrees around the aircraft. I have come to the conclusion its the way the sim loads the textures, in particular the terrain. Does not seem to matter what type or how complex the aircraft either. I dont believe Microsoft wanted this to be a "spot view" sim but with all the wonderful models we have as add-ons we want to watch from outside. I have noticed that as long as I stay inside the cockpit, my sim experience is a LOT smoother. If i go to spot view I will get occasional mocro stutters and panning will give me the type of stutters you are seeing but they are much shorter in duration. Its just the way it is, I dont think there is much you can do about it.I have a P4 at 3.0ghz, 1G of PC2100ram, a Radeon 9800pro and an Audigy sound card. Clean system running nothing in the background while FS is running. I can get easily frames in the 30's and pretty smooth if locked. Dips into low 20's and high teens with complex scenery, wx, and traffic.Hornit

Share this post


Link to post
Share on other sites

Yep, I pretty much echo Hornit's thoughts. Theres something about the way FS loads and caches the textures. It almost seems to me that it loads high res textures that are in front of you and quickly forgets whats off to the sides and if you start panning around more than about 30 - 40 degrees in either direction it has to reload the textures. My system is modest by current standards, but I've got it pretty well optimized and FS9 runs really nicely on it (I get pretty consistent 20 - 25fps performance even in the VC of most planes) and as long as I'm not panning around the sim is absolutely stutter-free. It's really only when I start rubber-necking in the VC or panning around in spot view that things start to get funky. The issue does get worse if the plane happens to be really texture heavy I find (which I why I always convert everything I can to dxt textures).

Share this post


Link to post
Share on other sites

>Theres something about the way FS loads and caches the textures. It>almost seems to me that it loads high res textures that are in>front of you and quickly forgets whats off to the sides and if you>start panning around more than about 30 - 40 degrees in either>direction it has to reload the textures.Yeah, I came to formulate the "10 seconds rule" for texture loading in FS: after 10 seconds, texture are dumped and need to be loaded again. Try to take off in dusk, get airport to 3 o'clock, switch to right view, then switch back, wait like 12-15 secs, then again right view: you'll notice all airport textures need to be loaded again...this really sucks IMHO, most 3d engine don't behave this way...

Share this post


Link to post
Share on other sites

I had the stutters start occurring only recently. In turns or when panning in vc, there are pauses every few degrees. I never had this before, and my system isn't cutting edge. I've tried it all: reinstall of FS, new card drivers, increase texture bandwidth, reduce card latency, etc, etc, etc. Nothing works. It's so bad I refuse to fly anymore. All other programs seem to be fine. The only thing I can think of is some update from #### that I got from MS that only effects FS.Todd

Share this post


Link to post
Share on other sites

I've spent far too much time experimenting with framerates and settings. In the end you're just better off locking the frames at 25 or so. The framerate is lower, but the sim runs smoother, you shouldn't see those stutters anymore.

Share this post


Link to post
Share on other sites

I see some stutters (under the circumstances I referred to above) no matter what I lock the framerate at. Stutters are essentially a complete split-second stop while the cpu is doing something. In most cases in my experience that something is usually texture loading but it can also be cuased by background apps (or spyware), A/V software that momentarily grabs 100% of cpu resources, or any number of other little reasons. I've basically eliminated all the other cuases I can find and am left with the texture loading. I could probably turn down some gfx settings (I run with the texture options maxed) to get rid of it but ftmp it doesn't bother me enough to want to loose the nice visuals...

Share this post


Link to post
Share on other sites

Also.... If you have a Kensington mouse or trackball, that can be the problem. If you do have one, stop the kmu_run.exe or the kmw_run.exe in the process area of Task Manager and it will be back to normal. I have sent Kensington an email about this and thier reply was " You have 2 choices, Don't run that program or don't use the mouse or trackball."I have another Mouse ordered.Joe W.

Share this post


Link to post
Share on other sites

Hmmm Joe, now you mention it, I had a very similar experience with a Logitech mouse driver once... Upon installing a Logitech Momo racing wheel, the Logitech mouse driver got installed alongside without me noticing. Although a great piece of equipment, the Momo wasn't as easy to use as the MS or Thrustmaster wheels so I decided to uninstall the Momo again. Curioulsy, after that I had an annoying, persistant FS stutter and it took quite a while to discover the culprit. Once found and the Logitech mouse driver removed, FS9 returned to the usual (rare) stutter and behaved 'normally' again... Good luck and kind regards Jaap

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this