Sign in to follow this  
J van E

Ground shadows show up as dark blobs

Recommended Posts

Just installed 2.3 (did a complete reinstall, not the update) and I notice that all ground shadows show up as very obvious almost black blobs. This only happens in front of me. At my side and behind me everything is fine. Anyone else having the same problem? I am using the 337.88 nVidia drivers. I sometimes had this problem with 2.2 also but then those blobs only showed up every now and then in a few places but not as obvious and all over the place as now!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I've got the same with the 337.88 driver. P3D2 is confirmed to have problems with the 340.52 driver, so to what do we update?

Share this post


Link to post

I've got the same with the 337.88 driver. P3D2 is confirmed to have problems with the 340.52 driver, so to what do we update?

 

Indeed. The 337.88 driver is the latest driver that works with P3D so updating has no use: it will only makes things worse.

Share this post


Link to post

Sorry for the confusing,only Nvidia can clarify this state or a cooperation /LM and Nvidia).

Share this post


Link to post

I'm using 337.94 (last build to work with v2.2) and see the same thing. I have seen this occur in 2.2 but its much worse in 2.3.

 

I may try an older driver, to see it that makes any difference.

Share this post


Link to post

 

 


I have seen this occur in 2.2 but its much worse in 2.3.

 

Ah, I am rather glad I am not the only one who is experiencing this...!

 

If you try that older driver, let us know if it helped!

Share this post


Link to post

If you try that older driver, let us know if it helped!

 

 

Will do :smile:

Share this post


Link to post

I am using the 337.88 driver without issues.

Share this post


Link to post

No problems here either.

 

Vic

Share this post


Link to post

I'm still seeing these patches with the old 331.82whql set so it would seem its not the drivers... And to those saying 'I'm not seeing them'... are you 100% positive? many claimed their clouds did not spin, despite the facts being different so I'm always cautious with responses... its amazing what pass some by, though I'm sure that's not the case with you guys, Ed and Vic  :smile:

 

It seems odd two very different systems/configs show the same thing... however, it could be one shared setting or add-on causing it, rather than a general problem with v2.3.

 

Jerone, was this happening with default scenery?... as I patched, rather than started over, I maintained my FTXG + LC set-up and have no scenery that is not Orbx to try.

Share this post


Link to post

Well since no one who says they are experiencing "blobs" has posted a screenshot of this "terrible" issue, I can only assume they don't exist because I don't see them. ;-)

Share this post


Link to post

Well since no one who says they are experiencing "blobs" has posted a screenshot of this "terrible" issue, I can only assume they don't exist because I don't see them. ;-)

 

Fair enough. ^_^

 

Ground shadows off:

 

14721636570_26dc591672_o.jpg

 

Ground shadows on:

 

14905246381_056dc07da8_o.jpg

Share this post


Link to post

Ugh! That looks funny!  :lol:  I'll try by ground shadows again when I get home. Thanks for the screenie.

Share this post


Link to post

I'm seeing the same effect here in v2.3 using default ground textures. I've turned the them off, as they are just annoying.

I can't recall seeing these in v2.1 though.

 

  Jazz 

Share this post


Link to post

These are my custom graphics settings... I wonder how they compare to those who also see these blotches.

 

 

 

[GRAPHICS]
TEXTURE_MAX_LOAD=1024
NUM_LIGHTS=4
MIPMAP_VC_PANELS=0
TESSELLATION=1
COCKPIT_HIGH_LOD=1
AIRCRAFT_REFLECTIONS=1
LANDING_LIGHTS=0
DAWN_DUSK_SMOOTHING=1
LENSFLARE=1
HDR=1
BLOOM_LEVEL=2
SHADOW_QUALITY=2
TERRAIN_SHADOW_CAST_DISTANCE=3
CLOUD_SHADOW_CAST_DISTANCE=3
OBJECT_SHADOW_CAST_DISTANCE=2
CONTENT_NO_SHADOW=0
INTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_CAST=1
TERRAIN_SHADOWS_CAST=1
VEGETATION_SHADOWS_CAST=0
BUILDING_SHADOWS_CAST=0
CLOUD_SHADOWS_CAST=1
INTERIOR_SHADOWS_RECEIVE=1
EXTERIOR_SHADOWS_RECEIVE=1
SIMOBJECT_SHADOWS_RECEIVE=0
TERRAIN_SHADOWS_RECEIVE=1
VEGETATION_SHADOWS_RECEIVE=1
BUILDING_SHADOWS_RECEIVE=1
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_ULTRA=12
GROUND_SHADOW_TEXTURE_SIZE=2048
CLOUD_SHADOW_TEXTURE_SIZE=512
SHADOW_LOG_PARTITION_LOW=0.850000
SHADOW_LOG_PARTITION_MID=0.850000
SHADOW_LOG_PARTITION_HIGH=0.850000
SHADOW_LOG_PARTITION_ULTRA=0.850000
EFFECTS_QUALITY=1
EFFECTS_DISTANCE=1
[DISPLAY]
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=30
UPPER_FRAMERATE_LIMIT=30
TEXTURE_FILTERING=16
MSAA=8
SSAA=0
FXAA=0
VSYNC=1
TRIPLE_BUFFER=1
WideViewAspect=0
FullScreenExclusive=1
FullScreenAutoFill=1
[PANELS]
PANEL_OPACITY=0
[sCENERY]
IMAGE_COMPLEXITY=5
[TERRAIN]
LOD_RADIUS=6.500000
TESSELLATION_FACTOR=90
MESH_RESOLUTION=23
TEXTURE_RESOLUTION=26
AUTOGEN_VEGETATION_DENSITY=4
AUTOGEN_BUILDING_DENSITY=3
DETAIL_TEXTURE=1
WATER_REFLECT_CLOUDS=1
WATER_REFLECT_USERAIRCRAFT=1
WATER_REFLECT_SIMOBJECTS=1
WATER_REFLECT_TERRAIN=1
WATER_REFLECT_AUTOGEN_VEGETATION=1
WATER_REFLECT_AUTOGEN_BUILDINGS=1
WATER_REFRACT_CLOUDS=0
WATER_REFRACT_USERAIRCRAFT=0
WATER_REFRACT_SIMOBJECTS=0
WATER_REFRACT_TERRAIN=0
WATER_REFRACT_AUTOGEN_VEGETATION=0
WATER_REFRACT_AUTOGEN_BUILDINGS=0
ENABLE_BATHYMETRY=0
WATER_CLARITY=30
WATER_DETAIL=4
[WEATHER]
CLOUD_DRAW_DISTANCE=5
DETAILED_CLOUDS=1
OPTIMIZE_DENSE_CLOUDS=0
CLOUD_COVERAGE_DENSITY=6
THERMAL_VISUALS=0
DownloadWindsAloft=0
DisableTurbulence=0
DynamicWeather=2
VolumetricFog=1
[TrafficManager]
AirlineDensity=15
GADensity=35
FreewayDensity=10
ShipsAndFerriesDensity=20
LeisureBoatsDensity=25
IFROnly=0
AIRPORT_SCENERY_DENSITY=1
[AContain]
ShowLabels=0
ShowUserLabel=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabelTailNumber=0
ShowLabelDistance=1
ShowLabelAltitude=1
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelFlightPlan=0
ShowLabelContainerId=0
ShowLabelAirspeed=0
ShowLabelHeading=0
LabelDelay=1000
LabelColor=FFFF0000

 

 

Share this post


Link to post

Try disabling the terrain shadow cast option and see if the blobs disappear...

Share this post


Link to post

Try disabling the terrain shadow cast option and see if the blobs disappear...

 

Er...? See my screenshots: how else did you think I made the one without the blobs...? ^_^ At first I wondered what was causing those odd blobs but after changing the terrain shadow cast distance to various disctances it immediately became clear the problem was terrain shadow.

Share this post


Link to post

Some good news... nVidia driver 340.66(Quadro/Grid WHQL) fixes the problem with Tessellation with P3Dv2.X.

 

You need to mod the inf to work with non workstation cards, but a Geforce version should be out very soon.

 

 

EDIT: blobby terrain shadows remain though.

Share this post


Link to post

Er...? See my screenshots: how else did you think I made the one without the blobs...? ^_^ At first I wondered what was causing those odd blobs but after changing the terrain shadow cast distance to various disctances it immediately became clear the problem was terrain shadow.

 

Whoops - sorry. Thought your question related to cloud shadows interacting with ground shadows. Back to our blobby blobs... :lol:

 

(I'd actually disabled ground shadows because of the unrealistic way they appear and disappear based on camera angle).

Share this post


Link to post

 

 


(I'd actually disabled ground shadows because of the unrealistic way they appear and disappear based on camera angle)

 

Indeed!... which may be part of the problem... I think even Rob Ainscough runs without terrain shadows, so unless he tests other settings during beta, this could be missed during testing... not that he's the only tester, but lots seem to follow his settings.

 

Despite P3Dv2 being far better than FSX, terrain shadowing in P3Dv2 has always been less affective than the older platform, as is water and cloud to view positioning.

Share this post


Link to post

This may have to do with time of day and the terrain shadows. I have been flying mostly in the morning or evening... but using the time preview I was able to get the blobs to show at around noon time.

Share this post


Link to post

I was able to get the blobs to show at around noon time.

 

Thanks for confirming Ed... maybe time to post a bug report on the LM forum Jeroen.

Share this post


Link to post

I'm curious if anyone has sent in a bug report to LM on this issue yet. I did a 100% fresh installation of my entire system and P3D v2.3 last night and I immediately noticed these strange ground shadows as well. I really don't recall these shadows being this harsh in past versions at all. (SIdenote - I'm also running the good 337.88 driver.)

 

I'd prefer not to turn the ground shadows off, as they used to lend some great effects to mountain flying, but if that seems to be the only solution as of this point, so be it. 

 

If there's any further input from the group, I'd be happy to read it....

-Greg

Share this post


Link to post

I'll be honest... I don't find the ground shadows to be of much value in most parts of the flying area. Because of that, I leave it off.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this