Sign in to follow this  
Sbacchini

Need some help with DSR

Recommended Posts

Hello everyone, I tried to post on the main DSR topic but my question was buried beneath everything else, so I'll try to make a new thread.

 

Anyway, I must be doing something wrong, but I can't get DSR to work with P3D. On FSX it works perfectly, and the result is great, but I'm not having the same results in P3D. Here's the deal: when I change the resolution on the P3D options and go full screen (with alt+enter), my desktop resolution changes, so all I get is a huge mouse cursor, but P3D keeps the same resolution from before, I don't get the tiny menubar. I just get this huge mouse cursor, and my desktop goes to the new resolution, but there's no effect in P3D. 

 

 

Now, if I had to guess, the fact that it works on FSX points to a problem with the fact that P3D it's not really full screen, but as people got DSR working there must be a way. I hope someone can help me.

 

Cheers and thanks in advance!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Sorry, I can't help but have exact the same problem. So you are not alone with that one.

 

Harry

Share this post


Link to post

That sounds wierd. I can only say that I have no such problem and 2.25x DSR works great on P3D, Win7 64bit.

Share this post


Link to post

See if this works:

 

From the desktop (P3D not running yet)...

 

1. Set your monitor's resolution from Windows to what you plan to set it to in P3D

2. Start P3D

3. Set P3D to the resolution that you want to use.

 

When done using P3D, set Windows resolution back to what you want it to be.

 

There may be a utility to do this for you more easily, but I haven't bothered hitting up the Google-machine to find out.

Share this post


Link to post

See if this works:

 

From the desktop (P3D not running yet)...

 

1. Set your monitor's resolution from Windows to what you plan to set it to in P3D

2. Start P3D

3. Set P3D to the resolution that you want to use.

 

When done using P3D, set Windows resolution back to what you want it to be.

 

There may be a utility to do this for you more easily, but I haven't bothered hitting up the Google-machine to find out.

 

Nope, same result. I get the new resolution on windows, but the resolution on P3D, after setting it on the options and going full screen, still stays the same....

Share this post


Link to post

Hi,

 

Set P3D the new resolution you want to use, return in your plane, and alt+enter twice.

Share this post


Link to post

Hi,

 

Set P3D the new resolution you want to use, return in your plane, and alt+enter twice.

 

Thanks for the suggestion, but that's exactly what I'm doing, as you can read on my posts....

Share this post


Link to post

Does it behave the same when the "Black-out Desktop" is cheked or not ?

 

On my rig, if "Black-out desktop" is not set, whatever DSR resolution I choose within P3D, P3D stays at the my native monitor resolution when CTRL+ENTER is pressed. As soon as "Black-out Desktop" IS set CTRL+ENTER works differently and use the DSR resolution I choose within P3D (Options-Display).

Share this post


Link to post

The tip from vbazillio is what I had to do to, while testing DSR in P3D. Anything other than that, did not work. I suspect it has something to do with P3D running in a sort of pseudo fullscreen mode on systems with several displays (it just "removes" the window borders). Checking the "Black out desktop" forces it to run in a true fullscreen mode, and thus switching the resolution to whatever you selected in the graphics options. 

 

Talking about DSR - I went back to native resolution, after a good portion of testing. 2SGSS in Inspector gives an equivalent picture quality IMHO, and far better performance on my GTX780. Tried 1.5, 2, 3 and 4x native res with different smoothness-settings, but the only one that really looked vastly superior was the 4x. Too bad it nearly melted the GPU..

A tip: use the performance monitors in Nvidia Inspector (or GPUZ), to see what impact DSR, AA etc has on your GPU. The frame-counter in P3D does not tell the whole story - It seems to only unveil the performance of the graphics engine, not both. It may very well be able to chunk out 30FPS all the time, but the GPU might struggle to render it all quickly enough..;) Maybe future drivers from Nvidia will improve the perfomance of DSR. 

Best regards, 

Kristoffer 

Share this post


Link to post

Good to hear you figured it out Kristoffer, I hadn't thought about making sure Black-Out Desktop was enabled, as I just keep that enabled to black out my second monitor to not distract from using a GTN 750 on it.

 

Try fiddling with the DSR options a bit more before giving up on it.

 

I'm using the following settings in the nVidia Control Panel:

 

DSR 1.78 for a resolution of 2560x1440 in P3D (up from 1920x1080)

 

Smoothness 28% (smoothing but not smudging, and doesn't fuzz up the image as much as SGSS does for me. 33% was too fuzzy for my liking and like you mentioned required an even higher ratio to make it sharper).

 

P3D AA set to 4x MSAA

 

P3D FXAA set to OFF

 

P3D AF set to 16x

 

The above settings give me a crystal clear image and high FPS, without the need for fiddling in nVidia Inspector and forcing any type of framerate slaughtering AA method.

Share this post


Link to post

Good to hear you made it work Philip! 

Does Vsync still work in DSR? Mine broke, but that might be down to the 2x and 4x DSR-settings. Sometimes the Windows Desktop Engine (or whatever its called - the one running Aero on the GPU, not software render) would revert back to compability mode in fullscreen, sometimes it wouldn't. Either way - when it did, the P3D window would go all black, but the sound was playing, som clearly it was running ok. I had to restart the service (like in FSX), to get the image back. Never have/had that problem running fullscreen in non-DSR.. 


I have a 28" monitor that is 2560x1440 natively - maybe that¨s why I didn¨t see the difference..:P 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this