Sign in to follow this  

Recommended Posts

I am slightly struggling with the water wave texture flashing as I'm crossing 1600 feet.
On the climb and descend all my water will flash bright white for fraction of a second, I wonder if there is a way of fixing it .
I have tried all kinds of different textures from quite small to very large from 2meg up to 10meg size and they all flash about the same so I don't think it is the size of the file.
My computer is quite decent with 4770K OC 4.4 and GTX 780 TI.
I realize that water is made completely different in DX10 .
I understand that different level of textures is loading at that time but it gets me every time.
mike

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I feel that I am always the bearer of bad news.

 

The white flashes (there are two) at 1500ft and 11,000ft are the transitions points at which the scaling of the bump maps changes - the way the shaders were shipped requires a switch between different compiled shader versions at this point and somehow that is causing a stall even if the new shader version is already compiled.

 

I experimented by changing the water shader and removing all the texture sampling and it still occurs.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you for your reply Steve

I was suspecting something like that and was blaming my system

Hopefully at some point you can crack it

best

mike

Share this post


Link to post
Share on other sites

Sorry to necropost but this is the only thread anywhere that sets out the issue and has a clear explanation of the cause.

 

In building a new dedicated flight sim PC over the last month, replacing a 7 year old system (which could never run DX10 as well as DX9), DX10 shines on the 2016 build computer with FSX Acceleration but for this issue.

 

However, there is a solution, which is to not use a Water 2x setting. Water 1x High eliminates the issue, so it has just been a matter of finding the best REX texture set that looks the best in 1x high.

 

For those who may be "living" with the limitation.

 

Regards,

 

Mark

  • Upvote 1

Share this post


Link to post
Share on other sites

Since yesterday i have installed dx10 fixer same problem! Good to know i am not the only one.

 

Max

Share this post


Link to post
Share on other sites

Not using water 2x unfortunately means that Cloud Shadows (if you have it installed) will not show up I believe.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this