Sign in to follow this  
twharrell

Love it

Recommended Posts

Nice job on the MU-2, guys! I just picked it up over lunch and did some quick pattern work. First impressions:

 

1) I'm flying in P3D and the model looks much better "in person" than on the training videos (which are well done). No offense intended, Joe. The VC is very well modelled. Switch sounds and engine sounds are very good. If you don't follow the correct start procedure, the engines will not light. Trust me.

 

2) Taxiing is very smooth, but I found I needed a good amount of power to get it moving. Maybe that's true in the real aircraft too. Either way, once moving, it was easy to taxi.

 

3)Flying the MU-2 is a beautiful experience. It feels much different than the C441. More jet-like, which is what an MU-2 is often compared to. I really like the flight dynamics of this bird.

 

4) The engine sounds are sweet. I especially love the transition from the start/taxi condition lever setting to the takeoff/cruise setting. My only niggle is when increasing or decreasing torque there is no change in engine sound. This wasn't an issue in the C441. Any way to fix this?

One other small thing I'll note is when my power levers are at idle, the aircraft throttles are at ground idle. Is there a detent between flight idle and ground idle in the real aircraft? It may be my TQ's (Elite) but if not, is there any way to make hardware idle match flight idle instead of ground idle?

 

So, overall I really like this aircraft! I think $42 price tag is fair. I foresee many enjoyable flights in SoCal with the MU-2. When can I schedule my first training session, Joe?

 

Todd

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

4) The engine sounds are sweet. I especially love the transition from the start/taxi condition lever setting to the takeoff/cruise setting. My only niggle is when increasing or decreasing torque there is no change in engine sound. This wasn't an issue in the C441. Any way to fix this?

 

From my experience fueling and servicing MU2's, the sound the engines produce doesn't really change in pitch, at least while taxiing. I'm probably wrong though. 

Share this post


Link to post
Share on other sites

From my experience fueling and servicing MU2's, the sound the engines produce doesn't really change in pitch, at least while taxiing. I'm probably wrong though.

 

I can report the same. With the Garretts, the way I always understood it, was that the engine basically has 3 speeds. Power, idle, and off. Having never operated or flown one, but like my fellow ramp rat above, I've been around hundreds. From my experience the sound of the engine only changes on takeoff and beta. It's when MU-2's (and Merlin/Metros) are idling and taxiing where you get the howl that any true aviation nut loves. That's when you can tell who on the ramp loves what they do, and who just works there. :)

 

There actually used to be an annual MU-2 convention here in Tampa. Seeing 30-40 of these things lined up was amazing. Then remembering they all want fuel....... Those were the days. Now I can do what I always wanted and climb in, and play with one. For much less then the cost of actually buying the real thing.

Share this post


Link to post
Share on other sites

You can all schedule your training sessions whenever you'd like!

Share this post


Link to post
Share on other sites

I just would like to say thanks to the team for creating again a masterpice,just did a 2hour test flight on IVAO and all works and handle like a charm. I just have a Problem when i try to load a saveflight with the mu-2 P3D crashes all the time, maybe you have an idea because it just happens with your mu-2.
 

ylz374ko.jpg

Share this post


Link to post
Share on other sites

Having a Blast!  I was waiting for this release like crazy. I love this plane!

 

I have some MU-2 time, Mark and Joe have really captured the beauty of this plane.

 

Been experimenting a little with the sound file, to get that slight increase sound on takeoff. Somewhat successful. Just a little more tweaking should have it.

 

I concur with others re autopilot issues. Caveat. Make sure to turn the A/p,Y/D ON. Easy to miss. Below throttle quadrant. Just pushing the buttons on glare shield only selects that mode.

Also, make sure either on the GTN-750, or the Garmin selection panel on pilot's side, you select the proper NAV mode. Either GPS or NAV. If in GPS mode, APP will not work.

 

1. When in level flight, with alt hold off, if select IAS mode the plane will climb before descending.  It may be it is capturing a set IAS speed.  I haven't found were the speed selection is located.

I thought when IAS was selected, it would hold the speed at selection. Same thing on climb out. If IAS is selected around 180kts, the plane will reduce V/S to accelerate to approx. 200kts.

Seems to be a hard coded speed?

 

2. Alt capture worked fine for me. Seems to function best if you set the requested ALT first, then use ALT Capture. On descent, I use ALT HOLD first, then select requested ALT, then disengage ALT HOLD to start descent.

 

3.V/S Mode. Using the pitch knob on A/P, I couldn't seem to adjust V/S on the plane anymore than about 700-1000fpm. Hard coded as well? Operator error, not sure. :-)

 

4. APP Mode:Had a glitch with APP mode. Flew a trip from KTKI(real homebase) to KGLS.  Set up the GTN 750 for the approach to 13 ILS GLS. Plane was tracking beautifully approaching FAF.

After intercept and capture ,I configured on speeds, captured G/S was following normally, then approx. 1000 ft  the airplane just dove towards the ground.

I disengaged the autopilot, to handfly rest of the approach. At that point, FSX froze up solid, I had a weird humming/buzzing sound from monitor. Computer was locked up tight. Had to do a complete restart of my system.

 

After reboot, did another flight. Set the plane on final again for KGLS, this time A/P APP worked flawlessly.  Scratching head. VAS Issue perhaps?  Using FSX Accel w/DX-10 fixer.

 

5. When using the CTRL E Autostart, had issues with startup. I then remembered, I had reloaded the last saved FSUIPC flight. Well, that was saved during the approach, hence airplane in flying mode. Hence props off the locks.

 

Trying to start, it would not light off. I then looked at the props, not on the locks.  Did manual procedures for unfeather...start normal then. Also noted on the reset the condition levers were not in correct positions. Left was Emergency stop, right was ground idle.  I DO NOT believe this was an airplane issue. I believe it was the re-save of the FSUIPC.

 

6.The amount of power to taxi was bugging me quite a bit. I discovered the dynamicfriction lua file form FSUIPC. She taxies beautifully now.  Just a little power to get rolling, then pretty much leave power levers at ground idle position, with occasional beta to slow.  Try it, works great.  The dynamic aspect is once above 30 kts, it allows the devs flight model to work for takeoffs landings etc.  Don't know how it will handle on different surfaces and or conditions. 

 

I know some of you are on the fence on this beautiful plane because you need the eye candy etc.  IMHO you are missing out on a FUN FAST airplane.

As mentioned, I have some MU-2 time, Mark and Joe have captured this plane and operations very nicely.

 

Is it photorealistic? No.   However, when you sit in the pilot's seat, does it give a feeling of immersion sitting in an actual MU-2? Graphics of panel not withstanding.....IMHO....Hell Yes!

 

Lastly, apologies for the long post. Wanted to give some thoughts on this plane.

 

Finally, STILL HAVING A BLAST! Flying this beautiful plane.

Thank You, Mark and Joe.

 

Have Fun!

David

Share this post


Link to post
Share on other sites

Having a Blast!  I was waiting for this release like crazy. I love this plane!

 

I have some MU-2 time, Mark and Joe have really captured the beauty of this plane.

 

Been experimenting a little with the sound file, to get that slight increase sound on takeoff. Somewhat successful. Just a little more tweaking should have it.

 

I concur with others re autopilot issues. Caveat. Make sure to turn the A/p,Y/D ON. Easy to miss. Below throttle quadrant. Just pushing the buttons on glare shield only selects that mode.

Also, make sure either on the GTN-750, or the Garmin selection panel on pilot's side, you select the proper NAV mode. Either GPS or NAV. If in GPS mode, APP will not work.

 

1. When in level flight, with alt hold off, if select IAS mode the plane will climb before descending.  It may be it is capturing a set IAS speed.  I haven't found were the speed selection is located.

I thought when IAS was selected, it would hold the speed at selection. Same thing on climb out. If IAS is selected around 180kts, the plane will reduce V/S to accelerate to approx. 200kts.

Seems to be a hard coded speed?

 

2. Alt capture worked fine for me. Seems to function best if you set the requested ALT first, then use ALT Capture. On descent, I use ALT HOLD first, then select requested ALT, then disengage ALT HOLD to start descent.

 

3.V/S Mode. Using the pitch knob on A/P, I couldn't seem to adjust V/S on the plane anymore than about 700-1000fpm. Hard coded as well? Operator error, not sure. :-)

 

4. APP Mode:Had a glitch with APP mode. Flew a trip from KTKI(real homebase) to KGLS.  Set up the GTN 750 for the approach to 13 ILS GLS. Plane was tracking beautifully approaching FAF.

After intercept and capture ,I configured on speeds, captured G/S was following normally, then approx. 1000 ft  the airplane just dove towards the ground.

I disengaged the autopilot, to handfly rest of the approach. At that point, FSX froze up solid, I had a weird humming/buzzing sound from monitor. Computer was locked up tight. Had to do a complete restart of my system.

 

After reboot, did another flight. Set the plane on final again for KGLS, this time A/P APP worked flawlessly.  Scratching head. VAS Issue perhaps?  Using FSX Accel w/DX-10 fixer.

 

5. When using the CTRL E Autostart, had issues with startup. I then remembered, I had reloaded the last saved FSUIPC flight. Well, that was saved during the approach, hence airplane in flying mode. Hence props off the locks.

 

Trying to start, it would not light off. I then looked at the props, not on the locks.  Did manual procedures for unfeather...start normal then. Also noted on the reset the condition levers were not in correct positions. Left was Emergency stop, right was ground idle.  I DO NOT believe this was an airplane issue. I believe it was the re-save of the FSUIPC.

 

6.The amount of power to taxi was bugging me quite a bit. I discovered the dynamicfriction lua file form FSUIPC. She taxies beautifully now.  Just a little power to get rolling, then pretty much leave power levers at ground idle position, with occasional beta to slow.  Try it, works great.  The dynamic aspect is once above 30 kts, it allows the devs flight model to work for takeoffs landings etc.  Don't know how it will handle on different surfaces and or conditions. 

 

I know some of you are on the fence on this beautiful plane because you need the eye candy etc.  IMHO you are missing out on a FUN FAST airplane.

As mentioned, I have some MU-2 time, Mark and Joe have captured this plane and operations very nicely.

 

Is it photorealistic? No.   However, when you sit in the pilot's seat, does it give a feeling of immersion sitting in an actual MU-2? Graphics of panel not withstanding.....IMHO....Hell Yes!

 

Lastly, apologies for the long post. Wanted to give some thoughts on this plane.

 

Finally, STILL HAVING A BLAST! Flying this beautiful plane.

Thank You, Mark and Joe.

 

Have Fun!

David

Thank you David. About the sounds, i find it a bit too noisy (strident). I've just watched a video (real airplane) and the sound (inside) is really less strident.

Here is the link: https://www.youtube.com/watch?v=OO_6utIWQdE. Anyways, I love this aircraft. I can live with this sound. :smile:

Share this post


Link to post
Share on other sites

5. When using the CTRL E Autostart, had issues with startup.

Well, it is a simulator

Share this post


Link to post
Share on other sites

 

WIP? I don't understand but I am intrigued. 

 

Interior design pixel reallocation?  Actually just trying to figure out how to repaint, I will get there one day.  Wonderful little play toy though B)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this