Sign in to follow this  
TristanHarmsen

EZDOK not functioning in FSX-SE

Recommended Posts

Since trying and ultimately failing to run side-by-side installs of MS FSX and FSX-SE, I have tried to uninstall both as completely as I know how.  After doing so,  I downloaded FSX-SE, installed it, and attempted to install the add-ons I had previously installed.  The first I tried was EZdok camera addon.  The first time I attempted this, I was able to install it, update it, and run the configure tool with no issues, and it would start alongside fsx, but it would not appear in the add-ons menu, making it impossible to set up cameras.  I tried several tips on the forums, and failing in this uninstalled the addon and tried again.  

The second time, I got as far as the configure tool.  When I pressed the configure button, a window popped up saying:

 

"So far as your version of Flight simulator X is other tha English + Acceleration Pack.  We recommend to go through the simple procedure of searching for address of the world camera coordinates in the RAM of your PC.  This task will be performed automatically and will not need any special skills from you.  If you skip this procedure the functionality of world cameras will be very limited.  Do you wish to start the wizard?"

 

If I say No, nothing happens and I am back where I started, and if I say Yes, it tells me to close flight simulator if it's running, so that it can delete the world cameras.  I click delete and I get an error saying: 

 

"Unable to write to

C:\Users\Tristan\AppData\Roaming\Microsoft\FSX\cameras.cfg."  

 

But upon investigating, I can find no FSX folder in C:\Users\Tristan\AppData\Roaming\Microsoft\.  Does this mean that my computer thinks that MS FSX is still installed?  If so, how do I correct that?  

 

Sorry for the long-windedness, but I figured it's best to make these things detailed.  

 

Thank you very much in advance.  

 

~Tristan

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have updated to 1.18.6 but I have exact same problem.. however it still works  :nea: it appears in my addons .  I have yet to put in new cameras however. but still have the issue where it cannot write to the folder as the folder does not exist... apparently the only time the FSX-SE folder would appear is where you are running both FSX and SE versions on the same system. So where you only have steam edition it only creates FSX folders in the same way as the old boxed version.. would suggest the EZdok is looking for a file that will not be there for the camera.cfg .. no idea if EZdok can be changed to point to the correct USERs folder...

 

Ok it actually does not work now I have tested.. just keeps crashing FSX.

Share this post


Link to post
Share on other sites

But upon investigating, I can find no FSX folder in C:\Users\Tristan\AppData\Roaming\Microsoft\. 

 

Sorry, this is pretty unclear to me.

May I ask you what do you mean exactly with "I can find no FSX folder in C:\Users\Tristan\AppData\Roaming\Microsoft\"?

 

That you have no "FSX" folder?

That you have no "FSX-SE" folder?

 

You must have either only "FSX" or both "FSX" and "FSX-SE". If you are running either version in single mode, then you must have only:

"C:\Users\Tristan\AppData\Roaming\Microsoft\FSX"

 

If you are running both versions in parallel or you made an incorrect/incomplete uninstall of MS-FSX, then you probably have both:

"C:\Users\Tristan\AppData\Roaming\Microsoft\FSX"

"C:\Users\Tristan\AppData\Roaming\Microsoft\FSX-SE"

 

It should be noted that MS-FSX and FSX-SE are basically identical by all means, only exception being the root folder. Addons like FSUIPC and Ezdok look at your registrly when you install them. If they find any remnant of any previous FSX install, no matter whether boxed or Steam, they assume that you are running both versions, even if you uninstalled one of them and even if the remnants in the registry are pointing to the correct path.  

I had this problem months ago after uninstalling FSX boxed without reformatting the disk. Read this thread entirely for more information. 

 

 

 

Does this mean that my computer thinks that MS FSX is still installed?  If so, how do I correct that?

That's correct! If you only have the Steam version installed and zero remnants from a previous install, then your addons treat your Steam install like a MS install and that is how it should be. So this is a normal condition.

 

Hope this helps

Share this post


Link to post
Share on other sites

I had a similar issue and started another thread where EZdok would not find the steam path correctly in the users folders.. the solution unfortunately was to do a complete clean and re-install of my OS. Which was also mentioned by another user.  When I installed Steam on its own then EZdok 1.18 (after 1.15 ) it worked .. I only got one option (steam) vs the usual two

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this