Sign in to follow this  
Ray Proudfoot

Changing Router causes WideFS and EFB connect problems

Recommended Posts

I have the following home network. Two running Win7 Home Prem (laptop runs Win7 Prof) :-

  • A desktop computer on which FSX resides (network name:FLYING).
  • Another desktop computer for FS Addons (network name:FSSUPPORT)
  • A laptop also with FS Addons (network name: ACER).
  • A Router (let's call it HH5. IP Address auto-assigned of 192.168.1.245 when connected to FLYING)
  • An old router (HH3) used when I take my FSX PC to flight sim meetings to connect to the laptop. This IP address (also auto) is 192.168.1.88 when connected to FLYING).

I run WideFS and Electronic Flight Bag at home via HH5 without problem. I use the computer name of FLYING (rather than IP addresses) for a successful handshake.

 

When I disconnect HH5 and connect HH3 (all Ethernet) to emulate being on the road a different IP address of 192.168.1.88 is assigned to the FLYING PC.

 

If I then fire up FSX I cannot get WideFS, Super Traffic Board or EFB to make a successful handshake. They just sit there showing "trying to connect".

 

Why? The FSX computer still has the name FLYING. So shouldn't WideFS, STB and EFB be able to succesfully connect? I can see all shared folders so it doesn't seem to be a general network problem.

 

If I disconnect HH3 and reconnect HH5 everything is fine again.

 

Are there some network rules that I'm overlooking that prevent two computers talking to my FSX one if the router is changed?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Computers don't understand names like FLYING. Computers understand IP addresses like 192.168.1.88. Either you need to provide a way for FSSUPPORT and ACER to find the changed IP address of FLYING or, much simpler, change the configuration of FLYING so that it has a fixed IP address of 192.168.1.245.

Share this post


Link to post
Share on other sites

Sam,

 

This problem has been resolved without me needing to change anything. It must have been a one-off glitch.

 

Sorry, but computers can be recognised by a name. Right-click Computer and choose Properties. In the info displayed you'll see 'Computer Name'.

 

With a fixed name EFB can complete a handshake. Fixed IP address is an option but I prefer using names.

Share this post


Link to post
Share on other sites

I always use the computer name, very rarely I may use a fixed IP but never use auto addressing.

Share this post


Link to post
Share on other sites

Sam,

 

This problem has been resolved without me needing to change anything. It must have been a one-off glitch.

 

Sorry, but computers can be recognised by a name. Right-click Computer and choose Properties. In the info displayed you'll see 'Computer Name'.

 

With a fixed name EFB can complete a handshake. Fixed IP address is an option but I prefer using names.

Your right Ray. I just installed Aivlasoft Electron Bag and run the Display unit on a different computer/monitor than the Data Provider. I found it makes no difference if I use the computers name or it's internal IP address i.e. 192.168.X.XXX. The name is case sensitive. Nothing is more literal than a computer. A missing dot would crash my database scripting applications. Paradox 3.5 made me a ton of money writing POS apps and the like in the early day's.

 

Baldy

  • Upvote 1

Share this post


Link to post
Share on other sites

Ray, sometimes if the system is pulled around enough, routers changed around, or for whatever reasons, the DNS database can be lost and takes a little time to rebuild. Which probably explains why it cured itself eventually. The DNS system relates names to ip addresses. Type "ipconfig /all" should show your router as the DNS server.

Share this post


Link to post
Share on other sites

Thanks for that Steve,

 

As I alluded to, this problem did sort itself out pretty quickly and has remained problem-free ever since. Each month I take my FSX PC and laptop to a monthly meeting and use the old router and EFB and WideFS recognise the parent PC immediately. Even at Cosford on Saturday everything was fine.

 

I do use ipconfig /all on occasions but problems are rare these days.

Share this post


Link to post
Share on other sites

Currently looking for a Wi-Fi Router

Edited by Ale1146

Share this post


Link to post
Share on other sites

In the future feel free to start your own thread.

What is your budget?  What is your connection speed?  How many clients do you normally have?  How many of those clients are wired and how many are wireless?  How many of those clients are AC, N, and G standard?  What is your ISP and do you already have a modem?

Thanks,

Greg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this