Sign in to follow this  
dental12

throttle problem

Recommended Posts

Hello

all of a sudden the throttle in every aircraft is stuck at idle.

I have deleted all button and key presses as well as all throttle axis from the control panels. I have also unplugged my hardware and just tried to use the mouse and the throttle tries to move but moves right back to idle.

Does anyone have any insight on this very frustrating issue

thx lee

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Do you have a cat sitting on the F1 key?

 

If no cat, then is there anything else that could be doing that?

 

If you are using FSUIPC, try removing the FSUIPC.ini file from its folder and putting it someplace else like your desktop. FSUIPC will build a new one.  This has been know to fix many problems that you wish you could blame on the cat.

Share this post


Link to post

Hi

Thank you for your quick response. I dragged and dropped the fsuipc.ini to the deckstop and restarted p3d . the throttl will stay at full for just a few seconds then reverts back to idle. I know something must inputing for this but i have deleted all throttle assignments. Seems crazy i know but it is obviously a crippling problem. The other axis like the mixture and prop work fine. HELP!!

thx Lee   P.S No cat on f1 key

Share this post


Link to post

You can use FSUIPC to calibrate the throttle axis - look at the raw input - if it's jumping around you may have a physical issue with the hardware. Other than that - SOMETHING is sending signals. Any new software added that may be trapping the keystroke?

 

Vic

Share this post


Link to post

Hi Vic

This has never happened before.I have unplugged all devices. Fsuipc has nothing going on. I even tried to used the generic p3d.cfg. Can you think of anything that would be just affecting the throttle no matter what aircraft I try. 

thx Lee

Share this post


Link to post

Lee see how the throttle behaves in the game controller settings (control panel>devices and printers > properties of the throttle device) see if it goes up and down , that proves the device, then make a backup of your C:\Users\your ID\Application Data\Lockheed Martin\Prepar3D v2\controls\standard.xml and delete it , try...

 

Jorge

Share this post


Link to post

Hi Jorge

the throttle is stuck in idle even when hardware has been disconnected and just the mouse is used. Can you tell me what part of the .xml control file controls the throttle? I am very upset that this problem is beyond my working knowledge so far. Your help would be extremely appreciated

thx Lee

Share this post


Link to post

In the control\standard.xml the thr is controlled by the keyboard mappings and any device you have attached to the PC via P3D, in P3D go to controls and tick disable controllers , that will remove any controller (connected or not) from P3D , if it still happens , maybe a repair of P3D may solve the problem, go to control panel programs and do a right click uninstall and select repair of P3D, ...

 

Have a try.

 

Jorge

Share this post


Link to post

Uninstall and repair...will all addons keep working with such? My FSX throttle goes to full on its own.

Share this post


Link to post

In control panel programs right click on prepar3d ... shows uninstall repair , select repair and a new install takes place. all addons remain..

 

Jorge

Share this post


Link to post

Hi Jorge

I unchecked the enable controllers and still have the throttle stuck at idle in every aircraft. If I do a reinstall, am I to assume that I can save my .cfg and nvidia profiles and just reload them once new inatall is done?

In all my years with flightsim, I have never come across such a difficult mystery.

thx lee

Share this post


Link to post

Hi 

Do you know where the signals to the throttle is sent from other than the sim ,fsuipc etc. I have tried all the suggested things. I unplugged my hardware also. The signal is being sent from somewhere other than the sim and the hardware. Help!

thxLee

Share this post


Link to post

Hi mate

I always go into the keyboard and axis assignments in the control section and delete anything that might conflict with my yoke,throttles or rudders.in the rudder axis section for instance you will find elevator and aileron assignments ,why i don't know..you might have an assignment in there that is conflicting with your throttle controls.

I use saitek yoke,2 throttles and ch rudders.so a good scan on all the control assignments is a must for me.if you use a seperate throttle like me delete the F1 2 3 4 keys and any other engine keys you can find that might interfere with the throttle.

 

   steve

Share this post


Link to post

thanks

will take another look

Lee

also lee it's worth mentioning what hardware if any you have.

 

   steve

Share this post


Link to post

I have elite simulations hardware. i tried unplugging hardware and removing drivers to no avail.

Share this post


Link to post

Hello

all of a sudden the throttle in every aircraft is stuck at idle.

I have deleted all button and key presses as well as all throttle axis from the control panels. I have also unplugged my hardware and just tried to use the mouse and the throttle tries to move but moves right back to idle.

Does anyone have any insight on this very frustrating issue

thx lee

 

Have you got the autothrottle turned on while on the ground ?

Share this post


Link to post

this problem is with every aircraft. not just the jets. I know it seem crazy but I think I have deleted every axis and button that is related to throttle. 

thx Lee

Share this post


Link to post

Can you control them at all using just the keyboard?

 

Vic

Share this post


Link to post

Have you got the autothrottle turned on while on the ground ?

Now it's very interesting that this topic has come up.

Last night the same thing happened to me.

And guess what....it was just as you describe I had my ATh turned on whilst on ground.

And me a long time simmer

 

OH the shame!

 

Andy

 

PS as soon as I disconnected the autothrottle ,'ordinary' throttle control resumed.

My excuse...I was using the Alain Capt panel(md11) which is fairly complex and I've not used in ages.

 

Uh hum!

Share this post


Link to post

If this problem is still  here, delete (after backup if you want) the standard.xml file and see, P3D will create a default one.

 

Jorge

Share this post


Link to post

The issue with the autothrottle is that it is saved in the .fxml flight file so it can be carried over to an airplane that doesn't even have A/T.

 

Rather than deleting control assignments at random, delete the startup flight and begin with a fresh one as Jorge suggests.

 

You can also very easily test this by opening P3D directly from a saved flight as long as the `open with` command is assigned to Prepar3D.exe. Then you may not even need to delete anything, although it sounds like the damage is done as far as default and modified control assignments are concerned.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this