Sign in to follow this  
WebMaximus

Saitek Throttle Quadrant

Recommended Posts

Just upgraded to Win10 to try it out and overall I think it works just great but I have one issue with my Saitek Throttle Quadrant.

 

First it wasn't recognized at all in the sim (P3Dv2.5) nor in FSUIPC. I then found a driver called Saitek_Pro_Flight_Quad_SD6_00000040_64_Drivers_pfw which unfortunately was for Win 8.1 IIRC...couldn't find a Win10 driver.

 

Installing this driver package solved the issue and the throttle was recognized just fine again looking in FSUIPC. However as soon as I restart my computer it won't work again and I have to reinstall the driver package to get it working...most annoying!

 

Anyone else seen this and has a cure for it?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm not using P3d. My saitek throttle Quads work but the buttons on them are not. I have the paid version of FSUIPC.

Share this post


Link to post
Share on other sites

I'm using Saitek tq, yoke and rudder in fsx and p3d and everything works. I'm using fsuipc with a clean install

Share this post


Link to post
Share on other sites

Post #6 - uninstall all saitek drivers - spad works perfect in windows 10

 

http://forum.avsim.net/topic/472506-win-10-saitek-trim-wheel-crashes-system/?hl=%2Bspad#entry3276660

Cool, I'll give that a try.

Saitek has announced on Twitter that they're aware of the issues and will have a fix soon:

 

https://twitter.com/SaitekSim/status/626892875029192705

Sounds good but seems a bit late to make sure their products work with Windows 10 now that it's already released :wink:

I'm using Saitek tq, yoke and rudder in fsx and p3d and everything works. I'm using fsuipc with a clean install

And what drivers are you using?

Share this post


Link to post
Share on other sites

Cool, I'll give that a try.

 

Sounds good but seems a bit late to make sure their products work with Windows 10 now that it's already released :wink:

 

And what drivers are you using?

not using any special drivers. All my controllers were automatically installed with Windows

Share this post


Link to post
Share on other sites

not using any special drivers. All my controllers were automatically installed with Windows

That's how I had it in Win7.

 

I think I'll do a clean install of Win10 and see what happens and if the TQ doesn't work without installing any drivers I'll try the drivers Richard suggested.

Share this post


Link to post
Share on other sites

Post #6 - uninstall all saitek drivers - spad works perfect in windows 10

 

http://forum.avsim.net/topic/472506-win-10-saitek-trim-wheel-crashes-system/?hl=%2Bspad#entry3276660

You give this advice but do you know that the software there is not an actual driver?

 

spad only starts if it finds a saitek panel. It did not work for me.

 

I try to run the program and it says "panel not found"

 

spad is not for yoke, throttles and pedals. It is specifically for the panels.

Share this post


Link to post
Share on other sites

What's also strange with the driver package I installed is I can't find a trace of it after the installation (and despite the TQ working as long as I don't restart the computer). Not under Device Manager, not under the Start menu and not under Control Panel programs and features.

Share this post


Link to post
Share on other sites

 

spad is not for yoke, throttles and pedals. It is specifically for the panels.

 

P3D and windows handles those no need for any saitek drivers - I have none installed and the thousands of other people who dont

You may have to try this - in windows 10 I could not get my lights working on multi-panels - this may be part of your problem still windows should see controllers - no drivers needed - check connections also - after you run the utility reboot immediately as your system will be acting funny  

 

http://uraster.com/en-us/products/usbenhancedpowermanagerdisabler.aspx

Share this post


Link to post
Share on other sites

 

 


Post #6 - uninstall all saitek drivers - spad works perfect in windows 10

 

Richard. I am using only Spad and do not have any Saitek drivers on my Windows 10 system. All works fine after I ran the .exe fix to advanced power management.  However, I have a severe problem after I fly FSX.  I have the Saitek Pro Cessna yoke and the Multipanel. My system is not dedicated solely to FSX or flight simming. When I am done flying in FSX, quit FSX, and return to my desktop, when I unplug either of the above mentioned Saitek devices to move them out of my way, my mouse goes bye bye.  The pointer moves around freely, but the scroll wheel and buttons do not perform at all.  After a number of attempts with clicking the  mouse buttons each additional click causes an audible ding, likely meaning a buffer has been filled to capacity. The keyboard works and via the Windows key I am able to navigate the Start menu using the keyboard. When I choose to shut down or restart, the system begins that action but never finishes. I have to eventually power down by holding the CPU power button. 

 

I do not have that issue with my other USB devices, such as if I connect my automotive Garmin, iPad, or my Wacoom graphics editing tablet.  Spad is not an issue as the problem occurs even if I have rebooted and not run Spad during a session.

Share this post


Link to post
Share on other sites

Richard. I am using only Spad and do not have any Saitek drivers on my Windows 10 system. All works fine after I ran the .exe fix to advanced power management.  However, I have a severe problem after I fly FSX.  I have the Saitek Pro Cessna yoke and the Multipanel. My system is not

 

Not sure you will have to dig around but what I do is just move an item out of the way but dont unplug it - I know thats not ideal but maybe thats why I dont see the issue could be anything - thinking your motherboard drivers may need some updating especially if they have windows 10 drivers start there thats what I would do

Share this post


Link to post
Share on other sites

Not sure you will have to dig around but what I do is just move an item out of the way but dont unplug it

 

Not a good option for my office environment. In my preflight I routinely reboot before flying FSX, so now part of my post flight routine will be to reboot, and while dark disconnect the devices. I did find a good tip tonight to considerably speed up the Windows 10 reboot. 

 

I have to say.  I used to start every flight cold and dark. But over the past two or three years with a fresh reboot, initializing flight controls, starting and loading weather engines, starting and connecting an iPad app, selecting and deselecting hi res scenery in context with my flight, and then waiting for the scenery and related textures to load.....  I may need to stop the cold and dark habit! Especially with the loss of tool tips due to the need to use DX10 preview under Windows 10. LOL!

Share this post


Link to post
Share on other sites

Check for motherboard drivers for win 10 also dont unplug them when the system is running - shut it down then do it you should be fine if you do that and same thing for plugging them back in do it before you start your system

Share this post


Link to post
Share on other sites

I'm getting this issue as well. What's happening is that win 10 doesn't power the TQ at startup for some reason. Until Saitek fix it, the easiest way to get it working again is to go to your Device manager in settings, right click on the TQ (usb) and disable it, then enable it. The power led should be now lit.

 

It's a bit of a nuisance, but it works.

 

Jess B

Share this post


Link to post
Share on other sites

That's great info Jess but where under Device Manager do you find the TQ?

 

I would like to think it would be under game controllers but in my case I don't find it anywhere looking in Device Manager, not under game controllers nor anywhere else.

 

Just did a clean install of Win10 so will look more into this issue shortly, maybe it will be discovered and show up when I unplug/plug it in. Had it plugged in while installing Win10.

Share this post


Link to post
Share on other sites

I'm getting this issue as well. What's happening is that win 10 doesn't power the TQ at startup for some reason. Until Saitek fix it, the easiest way to get it working again is to go to your Device manager in settings, right click on the TQ (usb) and disable it, then enable it. The power led should be now lit.

 

It's a bit of a nuisance, but it works.

 

Jess B

Have all of you tried disabling "Allow Windows to turn off this device to save power"?

Share this post


Link to post
Share on other sites

Have all of you tried disabling "Allow Windows to turn off this device to save power"?

Yep, that's one of the first things I always do after a fresh OS installation but thanks anyway.

Share this post


Link to post
Share on other sites

Ok, sorry but I don't know what else. It kinda sucks how Saitek waited until the last second to update drivers when the OPEN BETA of W10 has been available for months.

Share this post


Link to post
Share on other sites

For those of you still having this problem did you take note of and try the small .exe file you can find at either of these links? Not sure if the .exe files are the same at the two sites, but these worked for me to change the AdvancedPowerManagement for my Saitek devices in the Windows 10 registry.  

 

At the second link you may need to register with the site to gain access.

 

http://uraster.com/en-us/products/usbenhancedpowermanagerdisabler.aspx

 

http://fsgs.com/viewtopic.php?f=5&t=375#p1310

Share this post


Link to post
Share on other sites

Solved the issue where Win10 for whatever reason disables the Saitek TQ at logoff or restart and doesn't re-enable it at logon. I did this by using a very nice freeware tool called USBDeview which can be found and downloaded here.

 

Using this utility you can disable/enable a USB device from the command line so I simply created a task in Windows Task Scheduler which will run this command whenever I logon to Windows.

 

The command looks like this but obviously you need to change the path to the utility to the correct one depending on where you saved the utility and you'll also need to make sure you get the correct PID value. You can find the PID value for the Saitek TQ by executing USBDeview, find the Saitek TQ in the list of USB devices and then check the properties by right-clicking the device and choose 'Properties'.

 

C:\Util\usbdeview-x64\USBDeview.exe /disable_enable "USB\VID_06A3&PID_0C2D\6&ed9a0d5&0&4"

 

The effect of this is the same as if you physically disconnect/connect the TQ but in this case it will be done on a software level and also happen automatically without your intervention.

Share this post


Link to post
Share on other sites

Not sure you will have to dig around but what I do is just move an item out of the way but dont unplug it - I know thats not ideal but maybe thats why I dont see the issue could be anything - thinking your motherboard drivers may need some updating especially if they have windows 10 drivers start there thats what I would do

 

Richard,

Found a work around for my mouse freezing when the Saitek yoke and multi-panel are unplugged. Once I have finished flying and have exited FSX I went directly into Control Panel/Device Manager/HID devices and found and disabled the Saitek yoke. I also knew in the the HID section how to identify the Multi-Panel entry from having previously tracked it down to match it up in the regedit instructions referenced earlier in this topic. So I disabled it as well.  Got those nice polite Windows tones as I then unplugged each one. No lingering issue. My mouse did not hang at all. Windows was happy.

 

I found that I need to go back into Device Manager once I have successfully unplugged and enable the yoke again. No need to do so with the Multi Panel because I found that running SPAD enables it when it initializes it. 

 

Just a couple more checklist items to attend to on shutdown!

 

-FP

Share this post


Link to post
Share on other sites

After a cumulative update from Microsoft (I forced a check for updates), my Saitek devices and my dual monitor setup seem better behaved.  I wonder if the throttle quadrant issue (I did not have this problem) will also be alleviated?

 

Rick

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this