Sign in to follow this  
Midnight Music

Fatal error message only after exit

Recommended Posts

V3 is great. One thing, have any of you run into getting a fatal error on exit? I get it every time and I can't trace where it comes from. The sim performs great when in it, it is only right after exiting that I get the fatal error message, Any help will be appreciated. I'm still on W7.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Have you given admin rights to the entire v3 folder - might help - is it vanilla ?

 

Did you install something into it that may have messed it up or did it do it after a fresh install - might not like where you installed it

Share this post


Link to post

Clean install. I'm thinking it might be FSUIPC since that is not yet truly updated for this version. I have User Accounts off. Haven't installed PMDG yet, have only tried one FSDT scenery and it installed fine.

Share this post


Link to post

It is FSUIPC ,, some people is getting it also... the latest version 4.945a fails to install with a msg, if you click OK it continues but...who knows..

 

 

 

Jorge

Share this post


Link to post

How about the 'content error' message? I got this after saving a custom scenery as the default flight -- and quitting p3d 3.0.

Share this post


Link to post

My money would be on FSIUPC but i am not having an issue with it - loaded but only for my saitek panels to work other than that I dont touch it

Share this post


Link to post

Look in Event Monitor.  It's probably the nvapi.dll thing again.  Search this forum and see my previous.  Its a nvidia thing that gets put in (apparently) though not actually used by P3D. I believe and happens with some few games as well.  it doesn't get closed properly when P3D exits. Check in event monitor and you'll see.

 

Anyway had it with 2.5 and back now with 3.  It doesn't hurt, just a pain, but the solution for Win7 is to go in to SysWow64 in Windows and (backup) delete the nvapi.dll.  There may other places, but from there will stop the error message. Sadly it has a habit of being reloaded so you may need to re-delete if you make changes or do a restore.

 

see  http://www.avsim.com/topic/462059-the-dreaded-fatal-error-on-exit-from-p3d-with-25/?hl=%2Bnvapi#entry3178710

Share this post


Link to post

Look in Event Monitor.  It's probably the nvapi.dll thing again.  Search this forum and see my previous.  Its a nvidia thing that gets put in (apparently) though not actually used by P3D. I believe and happens with some few games as well.  it doesn't get closed properly when P3D exits. Check in event monitor and you'll see.

 

Anyway had it with 2.5 and back now with 3.  It doesn't hurt, just a pain, but the solution for Win7 is to go in to SysWow64 in Windows and (backup) delete the nvapi.dll.  There may other places, but from there will stop the error message. Sadly it has a habit of being reloaded so you may need to re-delete if you make changes or do a restore.

 

see  http://www.avsim.com/topic/462059-the-dreaded-fatal-error-on-exit-from-p3d-with-25/?hl=%2Bnvapi#entry3178710

I have a similar issue in so much that exiting p3d v2 & v3 I get a ' not responding' message.

is this linked to this same dll problem.

 

Some recent post here on Avsim, suggested closing most of the NVidia services down in the 'Manage my Services' section , could these nvidia services be adding to this problem.

 

bob

Share this post


Link to post

not sure about that - worth looking at.

 

FYI all, according to thread on the LM P3D forum, people are also geting the error on exit due to ntdll.dll as well, suspect similar solution

Share this post


Link to post

I'm wrong, rats!   I'm now getting fatal error on exit with the copy of ntdll.dll in SysWOW64 according to Event Monitor.  BUT, I've deleted that ntdll.dll and checked in flight - it's not there but still the error on exit.  I don't see how its FSUIPC can only pray . . .


But I removed the dll.xml,  which only had the FSUIPC entry, from Appdata , enabled controllers and it exited without the fatal error.  So it looks like you guys were right, it's FSUIPC in some way, but still, how error in a module that's not there?.  Aaargh!

Share this post


Link to post

I'm JUST starting to get this tonight.  I suspect EZDok.  I'm too layman to know how to check though.  

Share this post


Link to post

Also fatal error on every exit according to "sim1.dll" but without any problems - who cares? And by the way without FSUIPC installed and in the Services Section only NVIDIA Display Service activated and furthermore no 3D-Vision or Shadowplay-recording or GeForce-Experience installed. Also adin-rights to the V3 Folder and P3D started as admin. No luck to solve the issue - but besides the angry about the "fatal-error-message" no really problems - who cares? No pressure to waste my time longer.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this