Sign in to follow this  
Wizball

Step climb.

Recommended Posts

Hello.

 

As you see on the picture I have entered at step climb at waypoint N61E007 to FL350S (From FL330) , but why are the next waypoints still on FL330 ? Im pretty sure this have worked ok before.

 

 

fpkrAak.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello

 

Thanks for your reply.

 

But look at this.

 

If I enter the step climb at IPTON, then it works as expected, but not when i entering at the N61E007 or PEMOV

 

 

VtgGkU5.jpg

 

 

 

 

 

Hyd7ODF.jpg

Share this post


Link to post
Share on other sites

Interesting,

 

And if you CLR the speed/alt entry for N61E007 and re-enter what happens?

 

I don't have an easy exp0lanation for this, especially if you say it also does not work for PEMOV.

 

I would log a support ticket with PMDG and have them investigate.

 

Before doing this though, I would set the STEP to something other than 0 as mentioned in the above post.

 

Regards,

Share this post


Link to post
Share on other sites

I have tried to clear the speed/alt entry on N61E007 and entered the FL350S again. But same result.

 

Also tried to delete N61E007 and entered the step climb on PEMOV, but again, same result.

 

Also tried 2000 at the STEP on CRZ on VNAV page. dident make any difference.

 

So I belive it has to be a bug. Will make a ticket.

 

Thanks for your help :)

Share this post


Link to post
Share on other sites

 

 


So I belive it has to be a bug. Will make a ticket.

 

Just because it's stumping you doesn't mean that it's a bug. It might be, but give it a moment to actually look it over fully to ensure it's not user error. In many cases, that's where the issues lies, and in this case, it's partially so: STEP SIZE of 0. Zero tells the plane "I will not be stepping - planned, or ECON - at all. Ever. Never ever ever."

 

Not sure why it took the 350S and continued the altitudes for the one fix, but with a STEP of 0, it's not going to work with steps. Just because you're overriding the econ step points doesn't mean you should set STEP 0. So, that one bit might be something we need to look into, but for now: fly the plane like it's expecting to be flown.

Share this post


Link to post
Share on other sites

Just because it's stumping you doesn't mean that it's a bug. It might be, but give it a moment to actually look it over fully to ensure it's not user error. In many cases, that's where the issues lies, and in this case, it's partially so: STEP SIZE of 0. Zero tells the plane "I will not be stepping - planned, or ECON - at all. Ever. Never ever ever."

 

Not sure why it took the 350S and continued the altitudes for the one fix, but with a STEP of 0, it's not going to work with steps. Just because you're overriding the econ step points doesn't mean you should set STEP 0. So, that one bit might be something we need to look into, but for now: fly the plane like it's expecting to be flown.

As i said. It was the same behavior with STEP at 2000.

Share this post


Link to post
Share on other sites

Hi,

 

It is quite simple actually, in the first case where it doesn't work, you have entered a step to a level that is higher than you max level (fl350S, max FL346).

In the second case, you have still entered a S/C to FL350 but your max level is now FL353.

 

It happens when you enter a S/C at a waypoint where the FMC computes that this S/C would be above the max level.

 

Another thing that could prevent the FMC to compute the S/C correctly would be if you enter a S/C too close to the computed TOD.

  • Upvote 2

Share this post


Link to post
Share on other sites

I don't see that you're doing anything wrong.  Try entering the long form for the waypoint (N6100.0E00700.0) and see if that makes a diff... my guess is that there is something in the way of differences between waypoints that act and don't act as expected. Once you've gone about as far with this as you can, please document with steps to repeat on a trouble ticket at PMDG product support to get it entered into bug tracking system (if that is what it is).

 

EDIT:  I think Romain found a solution. I missed that, but I'm not sure that's a valid reason... many long flights have steps working as expected in the LEGS although they are all above current maximum level.  I got one right now KJFK to EGLL initial FL330 max FL340 and my forced step to FL360 on the NAT works as expected.

 

EDIT2:  I noticed that the forced step to FL360 is actually about 100 nm further along route that the waypoint where FL360S is entered; therefore, I agree with Romain totally on this one.

Share this post


Link to post
Share on other sites

The waypoint im trying to program the step climb is about 1800nm ahead. So the max alt should have change by then :)

 

And in post #3 you can see that it works with a waypoint that is closer, but not the the next waypoints further away. So that do not make any sense for me.

 

I did some tests again on the same route, but without the N61E007 (N6114.3 E00722.8) and the behavior is the same.

 

So. Im not a pilot, so ofcourse I can have done something wrong. But what is the correct way to enter manually step climbs without the FMC to calculate it?

I wanna use step climbs from my own flightplan. 

 

If I set the step size to RVSM, ICAO or 2000 the FMC is calculating it for me. And i have turned of the "Auto Step Climbs" in the FMC settings

 

 

Romain:

Another thing that could prevent the FMC to compute the S/C correctly would be if you enter a S/C too close to the computed TOD.

 

My step climb is about 300nm before computed TOD.

Share this post


Link to post
Share on other sites

 

 


My step climb is about 300nm before computed TOD.

 

Ah, there you go. The B777 doesn't step within 500 nm of TOD. Realistically, there's no savings to be had.

Share this post


Link to post
Share on other sites

 

 


The waypoint im trying to program the step climb is about 1800nm ahead. So the max alt should have change by then :)
 
And in post #3 you can see that it works with a waypoint that is closer, but not the the next waypoints further away. So that do not make any sense for me.

 

My point - which a guess here because I cannot check it for now on my computer - is that if the S/C you enter is above the calculated max level at the time of the waypoint, then the FMC will keep a lower level after your forced S/C because it would not take into consideration a S/C higher than the max level.

I'm not talking about the max level at the time you enter the S/C but the max level at the time you would reach that waypoint.

 

But you are right, this makes no sense in your exemple.

However, reading again the FCOM v2 p 11.42.25 brings an interesting info.

The step to entry on the VNAV page (act econ crz) will be displayed if you have an active route, at more than 200nm from the T/D and more than 500nm from your destination.

 

In your case, your waypoint was at 300nm from the TOD, but was it at more than 500nm from the destination?

It could explain why the step climb was not accounted for on the leg page.


Ah, there you go. The B777 doesn't step within 500 nm of TOD. Realistically, there's no savings to be had.

 

You beat me here, Dan! I was writting my post when yours came.

Share this post


Link to post
Share on other sites

 

In your case, your waypoint was at 300nm from the TOD, but was it at more than 500nm from the destination?

It could explain why the step climb was not accounted for on the leg page.

 

About 424nm from the destination.

 

Ah, there you go. The B777 doesn't step within 500 nm of TOD. Realistically, there's no savings to be had.

 

That make sense. I used step climb from PFBX. Why it wanna have it so close to destination i dont know. ^^

 

 

Thanks to all that helped me with this. So it was a "user bug" . maybe  :wink:

 

But if it is correct as Kyle says that I shouldent enter "0" in step size even when entering manually step climbs. Can some explain me what the correct way to program own planned step climbs without FMC calculating them for me ?

Share this post


Link to post
Share on other sites

 

 


That make sense. I used step climb from PFBX. Why it wanna have it so close to destination i dont know. ^^

 

PFPX defaults to 300 nm for all aircraft. You can change that in the aircraft settings for any particular template or tail number.

Share this post


Link to post
Share on other sites

PFPX defaults to 300 nm for all aircraft. You can change that in the aircraft settings for any particular template or tail number.

 

I see. Mine is at 250nm. Will change that.

 

Learning something every day. 

Share this post


Link to post
Share on other sites

I think Romain basically hit the nail on the head with maximum flight level and range to TOD.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this