Sign in to follow this  
Kalamalka

how do you open and edit the fsx cfg file?

Recommended Posts

I have found the graphics section of the fsx cfg file, (in notebook) but cannot edit to add highmemfix=1. There doesn"t appear to be an option to insert any additional line or to edit existing information. Probably an easy explanation, but I have been unsucessful so far. Any suggestions, as I need to add the line to stabilize FSX graphics.

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

With explorer navigate to: "C:\Users\[you]\AppData\Roaming\Microsoft\FSX"

Right-click on fsx.cfg (you may need to check "file name extensions" in explorer view tab, to see the .cfg part) and in the popup menu choose Open with Notepad.exe.

 

in the graphics section

[GRAPHICS]

..

..

 

add the line

HIGHMEMFIX=1

 

 

also you can add (with original FSX Boxed edition) a bufferpools section, this doesn't exist normally in a .cfg like HIGHMEMFIX:

 

[bufferpools]

UsePools=1

Poolsize=2000

 

 

What processor do you have, and is HT enabled?

Share this post


Link to post
Share on other sites

With your four core CPU, if HT is enabled (there will be 8 logical processors showing in Task Manager) to the cfg add:

[JOBSCHEDULER]
AffinityMask=85


an alternative if you have a heavy list of exe addons:

[JOBSCHEDULER]
AffinityMask=116


if you've *not* enabled HT (4 logical processors showing), ignore the JOBSCHEDULER section completely. Or with a heavy addon load, use 14.

Share this post


Link to post
Share on other sites

I think I read somewhere that HT wasn't necessary with running FSX.  I have an i7-3770 @ 3.4GHz and have HT turned off.  Would I benefit by enabling HT?

 

Thanks.

Share this post


Link to post
Share on other sites

I think I read somewhere that HT wasn't necessary with running FSX.  I have an i7-3770 @ 3.4GHz and have HT turned off.  Would I benefit by enabling HT?

 

Thanks.

SteveW has published in these forums, detailed results of various configurations with HT on/off, although primarily for P3D31, the results in some instances, are applicable to FSX. It makes a very interesting read. The are arguments(many) about the pros/cons of HT.

 

It really comes down to a matter of choice.

Share this post


Link to post
Share on other sites

The AVSIM FSX Configuration Guide (see link in my signature), provides detailed guidance for tweaks and FSX settings.

 

Best regards,

Share this post


Link to post
Share on other sites

With explorer navigate to: "C:\Users\[you]\AppData\Roaming\Microsoft\FSX"

Right-click on fsx.cfg (you may need to check "file name extensions" in explorer view tab, to see the .cfg part) and in the popup menu choose Open with Notepad.exe.

 

in the graphics section

[GRAPHICS]

..

..

 

add the line

HIGHMEMFIX=1

 

 

also you can add (with original FSX Boxed edition) a bufferpools section, this doesn't exist normally in a .cfg like HIGHMEMFIX:

 

[bufferpools]

UsePools=1

Poolsize=2000

 

 

What processor do you have, and is HT enabled?

I can find the fsxcfg file in notepad, but the options in the task bar ---file  edit  format  view  help--- don't allow me to add or edit an entry. 

Share this post


Link to post
Share on other sites

If you open the file with Notepad, you are looking at a text file, right?

 

In it, you can make any changes you choose and save it after.

Share this post


Link to post
Share on other sites

I can find the fsxcfg file in notepad, but the options in the task bar ---file  edit  format  view  help--- don't allow me to add or edit an entry.

Do you mean these menu options on the task bar are greyed lighter in colour and do not respond to clicking on them?

Share this post


Link to post
Share on other sites

Do you mean these menu options on the task bar are greyed lighter in colour and do not respond to clicking on them?

Thanks for your response. The task bar options are not greyed out, but none will let me insert a line under Graphics. I can type beside the word Graphics or any other line, but placing the command there does not seem to have any affect on the overall FSXCFG file.

Share this post


Link to post
Share on other sites

OK I think you are nearly there.

 

I think you can scroll through the text of the file so that you can see the line [GRAPHICS]. You should, in theory, be able to make a new line by placing your cursor at the start of the next line and pressing Return, an empty line appears. Then you should be able to type in HIGHMEMFIX=1 under that line so that you can see:

 

[GRAPHICS]

HIGHMEMFIX=1

.. (other lines)

..

 

If you can do that, then can you go to the options now, click on "File", the menu drops down and the third option or so, should be "Save". Click that and then close with the top right red cross.

 

Let me know how that goes

Share this post


Link to post
Share on other sites

OK I think you are nearly there.

 

I think you can scroll through the text of the file so that you can see the line [GRAPHICS]. You should, in theory, be able to make a new line by placing your cursor at the start of the next line and pressing Return, an empty line appears. Then you should be able to type in HIGHMEMFIX=1 under that line so that you can see:

 

[GRAPHICS]

HIGHMEMFIX=1

.. (other lines)

..

 

If you can do that, then can you go to the options now, click on "File", the menu drops down and the third option or so, should be "Save". Click that and then close with the top right red cross.

 

Let me know how that goes

Thanks Steve. That was the fix I was looking for. There are now very few texture problems, and further settings tuning should fix the rest.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this