Sign in to follow this  
Sesquashtoo

FS9.CFG [Graphics] Auto_ Lod entry

Recommended Posts

In my Graphics section, I have an entry of: AUTO_LOD=0

 

Does anybody know what this does...and is there a numeral other than 0, that can be used?  What I would like to see, is autogen spawned further out on the tiles...and I wonder if this setting can achieve that?

 

Does anybody know exactly what this setting controls?

 

Thanks,

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It's going to be "1" = "True", or "0" = "False".

SO try it and see what it does in your sim!

 

A search returned a FS2002 discussion:

Automatic Loss Of Detail. It supposedly will lower detail settings to try and reach the desired frame rate setting, kind of the opposite of the way the sim normally does things.

Share this post


Link to post
Share on other sites

It's going to be "1" = "True", or "0" = "False".

SO try it and see what it does in your sim!

 

A search returned a FS2002 discussion:

Automatic Loss Of Detail. It supposedly will lower detail settings to try and reach the desired frame rate setting, kind of the opposite of the way the sim normally does things.

Oh dear...that is certainly NOT what I want to happen, LOL!

 

I guess, I can try it...and see exactly WHAT does happen, as you suggest....can always go back to what it is right now =0

 

Thanks for the comeback. Much appreciated!

Share this post


Link to post
Share on other sites

Autogen popping up can be lowered by shifting other windows programs to other cores, and applying other tweaks which improve performance (eg TEXTURE_BANDWIDTH_MULT=4096        
and TEXTURE_MAX_LOAD=4096 . There is an option in FS-Copilot that does that. You can also make FS9 large address aware using this link:  http://forums.techpowerup.com/showthread.php?t=112556  Download laa204.zip and follow instructions. I'm not sure if this works, but many claim positive effects. You can PM me and I'll help you with some configs as soon as I have some time.

 

Cheers,

Sascha

Share this post


Link to post
Share on other sites

Well...I just took my first flight with:

 

Auto_Lod=1

 

Actually, this doesn't drop tile resolution, in favor of maintaining FPS at all on my system....it has kept all my 15 mile-out scenery and tiles...fully in focus.

 

I had never played with this .cfg setting before...and so decided to see what happens with it set to something other than off(0).

 

Give it a go..and then take a flight....

 

For myself, it is now a set to 1, and forget.  Also, my 30 FPS locked did not changed one iota.  Only, no more out-of-focus scenery, as I climb out...

 

This .cfg activation is highly recommended by this user.

 

Post Edit>..I just tried three different scenery locations.  As I climbed out of each, near-tile focus maintained.  Much better than before.  So, try or not...always your choice! :)

 

autolod.png

 

autolod2.png
 
autolod3.png
 
 
 

 

Ses

Share this post


Link to post
Share on other sites

Just curious ......

 

Why would you demonstrate "near-tile focus maintained" by showing us screenshots at night .... when you really can't see anything?

 

Lights are nice, but .....

Share this post


Link to post
Share on other sites

Just curious ......

 

Why would you demonstrate "near-tile focus maintained" by showing us screenshots at night .... when you really can't see anything?

 

Lights are nice, but .....

I enjoy running nights...and the second shot of Toronto, with a custom urban downtown underlay graphic is a hard one to focus in.  In this scene, none of the different colors are blending out into the other neighbor.  This was always a sort of soft collage. No longer...

 

I suggest that you change this setting to 1...and then go fly some daytime scenery that you are most familiar with..and see if it has any better effect upon your system.

Share this post


Link to post
Share on other sites

Mitch, I tried this yesterday evning and it works. Far detail seems better and it doesn't jump but stays focused. FPS seem to be more stable too! I took some screenshots but was too tired to upload them. WIll attach them to the thread later.

 

Thank you!
Sascha

Share this post


Link to post
Share on other sites

Mitch, I tried this yesterday evning and it works. Far detail seems better and it doesn't jump but stays focused. FPS seem to be more stable too! I took some screenshots but was too tired to upload them. WIll attach them to the thread later.

 

Thank you!

Sascha

Hi Sascha,

 

That's exactly what I found as well...especially looking aft of either wing.  I know for one thing, it stays as =1 on my system.  My FPS, never moved from 29.x (out of a locked 30) no matter what scene...and that is basically why I took those night shots...whereby some were having FPS droppage with using EVO autgen 3D lights at night. No FPS degradation whatsoever. :)   

 

That Toronto sub-mask for downtown night life, is a killer for blur, usually, but as can be seen, each 'light' color block is well defined. 

 

Also, for the very first time ever, I see that UTX railway yards, actually have burnt in trains upon the tracks...that before, only looked like blurred color splotches.  Nope..they are trains upon the tracks (burnt in...not 3D).

 

As you confirm, it works...and is a keeper setting.

 

Cheers,

 

Mitch'er

Share this post


Link to post
Share on other sites

Are you using the EVO railroads? Or do UT default also have trains? Can't remember..

Share this post


Link to post
Share on other sites

Are you using the EVO railroads? Or do UT default also have trains? Can't remember..

Well, that is a good question...I do have UT railroads on as enhanced.  But either way, Sascha, anything on those railways, or yards, were just color blur, other than the line of the rail line.  But now..I can see the roofs of train cars sitting on the tracks, or on an off-side rail.  Before the setting of Auto_Lod to 1...I could not.

 

Mitch

Share this post


Link to post
Share on other sites

As almost always, the effect of changing this value seems to be different from system to system. What I experienced when changing to Auto_lod=1 was a slight FPS drop without other (visible) effects... (perhaps a question of GPU?)

 

However, it is nice that it works for you, Mitch and Sascha.

Share this post


Link to post
Share on other sites

As almost always, the effect of changing this value seems to be different from system to system. What I experienced when changing to Auto_lod=1 was a slight FPS drop without other (visible) effects... (perhaps a question of GPU?)

 

However, it is nice that it works for you, Mitch and Sascha.

Harald, I really now think that it could be a quite system-specific quandary for both this...as well as when you engage EVO 3D lighting...and your also drop in FPS performance when those are called upon.  Hopefully, when you decide to upgrade your system, to whatever, this FPS hit will be a thing of the past!!!

 

Cheers,

 

Mitch 

Share this post


Link to post
Share on other sites

Yes Mitch, I hope so. I tested quite a lot and found out a coincidence of the FPS drop with Evo lights with ground shadows... but this is some off-topic. I think that my decision for an AMD GPU has to do a lot with my problems. Nevertheless, I enjoy my sim very much!

Share this post


Link to post
Share on other sites

Yes Mitch, I hope so. I tested quite a lot and found out a coincidence of the FPS drop with Evo lights with ground shadows... but this is some off-topic. I think that my decision for an AMD GPU has to do a lot with my problems. Nevertheless, I enjoy my sim very much!

Yeah, it might not be ground shadows that was causing it, per se...but that all of these add up to an over-stress of your card?  Well...perhaps you can at some point in time, switch out to an nVidia product, and perhaps, (hopefully) that will end these performance against feature drops.  Happy flying, Harald! :)

 

Cheers,

Share this post


Link to post
Share on other sites

Have waited to comment my results lest I be labeled an anti-whatever again.  Changed value and saw no visual change.  Observed some drop in frame rate and well as increase in stutters in certain areas.

Intel I3 with ATI Radeon HD5750 graphics.

Have changed value back to "0".

 

So glad at least one other person saw no merit to this change on their system.

Share this post


Link to post
Share on other sites

Here are some screenshots showing distant terrain. Mitch's tweak along with terrain max vertex forced to 25 and mip maps forced to 12. Some with SweetFx HDR, some without. SweetFx lumasharpen also set. What isn't working well at the moment is anti-aliasing, it removes my 2D panels when active. But this was already before changing autolod to 1.

 

Costa%2BSmeralda_2016.jpg

 

Costa%2BSmeralda_2016_2.jpg

 

Grand_Canyon_2016.jpg

 

Autogen_2016.jpg

 

Autogen_2016_2.jpg

 

Lowi_2016_Ground.jpg

 

Lowi_2016.jpg

 

Cheers,

Sascha

Share this post


Link to post
Share on other sites

Here are some screenshots showing distant terrain. Mitch's tweak along with terrain max vertex forced to 25 and mip maps forced to 12. Some with SweetFx HDR, some without. SweetFx lumasharpen also set. What isn't working well at the moment is anti-aliasing, it removes my 2D panels when active. But this was already before changing autolod to 1.

 

Costa%2BSmeralda_2016.jpg

 

Costa%2BSmeralda_2016_2.jpg

 

Grand_Canyon_2016.jpg

 

Autogen_2016.jpg

 

Autogen_2016_2.jpg

 

Lowi_2016_Ground.jpg

 

Lowi_2016.jpg

 

Cheers,

Sascha

Wow...that really looks good, Sascha...I'm going to try Mip Bias now set to 12 from my usual setting of 5, and see what happens.  I also ran the other at 21...but now have it set to 25 as well.

Share this post


Link to post
Share on other sites

 

 


Wow...that really looks good, Sascha...I'm going to try Mip Bias now set to 12 from my usual setting of 5, and see what happens. I also ran the other at 21...but now have it set to 25 as well.

 

Mitch, you have to use a batch file to start FS9 or else change that each time. FS9 reverts to default of max 8 for mip maps and 21 for max vertex levels. COuld be you need to upscale max vertex, I'll have to check for the config line.

 

Cheers,

Sascha

Share this post


Link to post
Share on other sites

Mitch, you have to use a batch file to start FS9 or else change that each time. FS9 reverts to default of max 8 for mip maps and 21 for max vertex levels. COuld be you need to upscale max vertex, I'll have to check for the config line.

 

Cheers,

Sascha

Hi Sascha,  can you share your already written batch file in a PM? :)

Share this post


Link to post
Share on other sites

Mitch, I sent you a mail. I'm sorry, I can't figure out how to attach a file to the PM.

 

Cheers,

Sascha

Share this post


Link to post
Share on other sites

Mitch, I sent you a mail. I'm sorry, I can't figure out how to attach a file to the PM.

 

Cheers,

Sascha

Thank you!  Got it...and am tweaking to your spec's as I type... :)

 

I just edited the batch files file point-to's...and just now need just an explanation as to, when running the batch files for day or night...exactly what action will they take?  

 

Thanks, Sascha.  BTW...going to 12.5 from 9.5 really brought up the visual clarity, even more, on the terrain_xxxx files.

Share this post


Link to post
Share on other sites
On 29.2.2016 at 0:32 PM, sascha said:

 

 

 

Mitch, you have to use a batch file to start FS9 or else change that each time. FS9 reverts to default of max 8 for mip maps and 21 for max vertex levels. COuld be you need to upscale max vertex, I'll have to check for the config line.

 

Cheers,

Sascha

FS9 could be tricked quite easy

MipBias=12
//MipBias=7

TERRAIN_MAX_VERTEX_LEVEL=25
//TERRAIN_MAX_VERTEX_LEVEL=21

that way it did not change back the vertex 25 or the mipbias 12 when closing the Sim but I did not know if that works also when changing a ingame setting and close sim think I have to run a test for that ;)

Share this post


Link to post
Share on other sites

can now confirm these values stay intact for the max-vertex when changing settings ingame the mip-bias jumped back to 8:cool:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this