Sign in to follow this  
Pe11e

Is this normal?

Recommended Posts

p3d_zpsrky6gvjg.jpg

 

 

Reinstalled P3D from scratch, v3.2.2 version. I had this "issue" also in V3.1, before reinstall. I thought something was wrong with the installation, but no, Core 0 is still peaking at 100% all the time while sim is running. This is without any tweaks in prepar3d.cfg. Is this normal for 4 core i7 with HT on? I'm asking this because I'm pretty sure I saw Core 0 at 10-20% before in v3/v3.1, which should be normal since Core 0 is for fibers? If it is for fibers, why it is stucked at 100% while the airplane is staionary on runway for 5 minutes?

I notices some pretty nasty stutters before complete reinstall in both 3.1 and 3.2.2, first I though it is ASN but the stutters were prominent also without it, with A2A C172, Bonanza, locked or unlimited frames. Now the flight is smooth but I didn't installed nothing so far, this is vanilla state.

 

Any thoughts?

 

Thanks!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

If your flight is now smooth, why worry. In my experience, your always going to have one core pretty much maxed.

 

On 3.2.2 this morning (after ASN new patch and new GTN 750 patch and running both with A2A Cherokee)

I had to adjust the GTN 750 to core 2 instead of 5 {running P3D with AM 116} and now core 3 is maxed instead of 1. But flight is smooth.

 

If your running smooth now, just go fly

Share this post


Link to post

If your flight is now smooth, why worry. In my experience, your always going to have one core pretty much maxed.

 

On 3.2.2 this morning (after ASN new patch and new GTN 750 patch and running both with A2A Cherokee)

I had to adjust the GTN 750 to core 2 instead of 5 {running P3D with AM 116} and now core 3 is maxed instead of 1. But flight is smooth.

 

If your running smooth now, just go fly

 

I'm still not sure which AM to use if I see stutters, I suppose it is recommended to free Core 0 with AF tweak? I used 84 on my i3770k, will check out 116.

I'm currently in process installing ORBX stuff, then other stuff and will test for stutters after the sim is fully loaded with addons as pre-reinstall.

Share this post


Link to post

If your running smooth now, just go fly

Now THAT is great advice and should be encased in plastic and mounted on everyone's computer.

 

:)

 

 

@Pe11e - FWIW, I'm using 116 on my 3770 and have no issues.

 

Vic

  • Upvote 1

Share this post


Link to post

Now THAT is great advice and should be encased in plastic and mounted on everyone's computer.

 

:)

 

 

@Pe11e - FWIW, I'm using 116 on my 3770 and have no issues.

 

Vic

 

:Tounge:  Yeah, my sim is smooth, but without addons! 

And thank you for the tip on AF, good to know that you have same CPU.

 

cheers

Share this post


Link to post

Now THAT is great advice and should be encased in plastic and mounted on everyone's computer.

Indeed. With a minor grammatical correction. :Tounge:

 

True enough we are so completely fixated on the technicalities that we sometimes forget what the end goal is. Me included.

Share this post


Link to post

The first core will always be the one peaking since it's running the main thread. The second core is the one running the fibers.

 

If in 3.1 your first core was at 10-20% you must have had messed the affinity somehow. Maybe with an external program.

Share this post


Link to post

The first core will always be the one peaking since it's running the main thread. The second core is the one running the fibers.

 

If in 3.1 your first core was at 10-20% you must have had messed the affinity somehow. Maybe with an external program.

 

Hm, what is main thread? Rendering, physics? So if Core 0 is main thread and core 1 is for fibers, what other cores do because there is a lot of activity while flying?

Anyway, I will leave it without AF, and if I see stutters as before will try 116 for example.

Share this post


Link to post

The main thread as far as I know is responsible for all the rendering of AI, your own aircraft, physics and scenery complexity too if I'm right. The second thread is for the fibers as you say and all other other cores after this two are for scenery rendering.

 

Your right about the cores doing the scenery rendering. I've noticed that they are used a lot more now in 3.2 and I'm actually getting blurris with unlimited frames now for some reason.

 

Guess I need to redo some tweaks and settings.

Share this post


Link to post

Just to note - in 3.1 I was running great with AM of 85 and the GTN 750 set at core 5.

After 3.2 85 was having problems, so I went to AM 116 and moved the GTN 750 to core 2 - everything is fine now.

Share this post


Link to post

Cool, thanks guys. I'm currently running the sim without AM, smooth as butter, no blurries. Tested with ASN, MyTraffic, ORBX. Only test left is PMDG and A2A flights.

Share this post


Link to post

Just to note - in 3.1 I was running great with AM of 85 and the GTN 750 set at core 5.

After 3.2 85 was having problems, so I went to AM 116 and moved the GTN 750 to core 2 - everything is fine now.

That's the weird part, I'm having blurries with 116. Which is supposedly one of the best AMs for a 4 core HT CPU.

 

Then again it could have something to do with the shaders rebuilding. I'll give it time and see how it goes.

Share this post


Link to post

The 116 AM takes care of positioning P3D - what have you done about any add ons or other process running? The idea is to keep THEM OFF the cores you assign to P3D.

 

 

Vic

Share this post


Link to post

So second test flight and same issues with blurries. Might have to try a new AM. Yes I already have all other addons on Cores (or LPs) 0 and 1.

 

I thought it may have something to do with objectflow but even after the update nothing has changed.

 

The only setting/tweak change from 3.1 was removing 2XSGSS from NI.

Share this post


Link to post

I have an issue with ASN without AM, huge stutters. Added AM=116 but I must deal with ASN high CPU usage that is causing stuttering even with 116, probably by assigning ASN only to Core 0.

Share this post


Link to post

I have an issue with ASN without AM, huge stutters. Added AM=116 but I must deal with ASN high CPU usage that is causing stuttering even with 116, probably by assigning ASN only to Core 0.

 

Core 0-1 would be better. As long as you keep it off the cores that P3D use. In this case (00,01,11,10) so cores 0-1 would be fine for ASN, Ezdok etc. 

 

I don't have stuttering issues with this config just blurries oddly.

Share this post


Link to post

Worked like a charm! Never understood the importance of AffinityMask until now. AM=116 and assigning ASN to Core0/1 = smooth as ice. 1 hour BIG pattern flight around FlyLogic Grenchen with A2A C172, MyTraffic GA at 100%, ASN, cloud shadows, water reflections - smooth 50-60fps all the time. Happy camper!  :smile:

Share this post


Link to post

Worked like a charm! Never understood the importance of AffinityMask until now. AM=116 and assigning ASN to Core0/1 = smooth as ice. 1 hour BIG pattern flight around FlyLogic Grenchen with A2A C172, MyTraffic GA at 100%, ASN, cloud shadows, water reflections - smooth 50-60fps all the time. Happy camper!  :smile:

Thats good to hear. I've solved the blurries but am still getting some odd trees popping in the scenery. Need to look into that.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this