Sign in to follow this  
Dragonmount

FSLOptions.dll warning?

Recommended Posts

I've gone back and forth on this with the FSL people, but nothing on their website seems to help, and I can't for the life of me think of anything else to do, so I ask here in a vain hope that someone has an idea for anything at all to try? I'd be willing to try almost anything at this point.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Do you have any other information other than the name of the warning?  Can you post the DLL contents?  Is the warning coming up in a popup box, or how is it displayed, in a pop up box?  If so, is it an FSX popup box?  Any other info would also be helpful.

Share this post


Link to post
Share on other sites

It simply states that there was a problem with a .dll, and in order to be able to use this program normally you shouldn't run it. Click yes to run, click no to not. If I click yes FSX crashes immediately.

Share this post


Link to post
Share on other sites

Dragonmount, you really have to provide more information to this problem but more importantly post your problem on the official FS Labs forum.

 

As a paying customer you will get help from Lefteris. Have you actually posted there and if so, under what name?

Share this post


Link to post
Share on other sites

Can you try the following to see if it resolves the issue (I had a totally identical issue with another software, this seems to indicate a dll conflict in your DLL.XML) this is from a thread in FSUIPC a year ago or so:

 

1) start regedit

2) goto key HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
3) delete the key "C:\\Games\\FSX\\fsx.exe"="$~ RUNASADMIN IgnoreFreeLibrary<FSLOptions.dll>"
4) if you would like to run FSX as an administrator you need to activate that again as you removed that in step 3

 

If you still get that error afterwards, try editing your XML.DLL file - after making a backup of it! - located here (C:\Users\your_user_name\AppData\Roaming\Microsoft\FSX\ folder) put all dlls on manual load so that you have to accept them one by one to start FSX, after loading them by batches check if FSX starts normally, when you get the error message most likely it will be the culprit and it may not necessarily be the FSLOptions one.

 

This problem has been happening with many other add-ons DLLs and in some cases resolved by the relevant developer after isolating the DLL responsible for the message.

 

Good luck.

Share this post


Link to post
Share on other sites

Can you try the following to see if it resolves the issue (I had a totally identical issue with another software, this seems to indicate a dll conflict in your DLL.XML) this is from a thread in FSUIPC a year ago or so:

 

1) start regedit

2) goto key HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

3) delete the key "C:\\Games\\FSX\\fsx.exe"="$~ RUNASADMIN IgnoreFreeLibrary<FSLOptions.dll>"

4) if you would like to run FSX as an administrator you need to activate that again as you removed that in step 3

 

If you still get that error afterwards, try editing your XML.DLL file - after making a backup of it! - located here (C:\Users\your_user_name\AppData\Roaming\Microsoft\FSX\ folder) put all dlls on manual load so that you have to accept them one by one to start FSX, after loading them by batches check if FSX starts normally, when you get the error message most likely it will be the culprit and it may not necessarily be the FSLOptions one.

 

This problem has been happening with many other add-ons DLLs and in some cases resolved by the relevant developer after isolating the DLL responsible for the message.

 

Good luck.

Thanks a bunch! This helped it!! Now I can finally start flying this thing.

Share this post


Link to post
Share on other sites

Actually it helped for about a week, now it's back, I'm just going to uninstall this bird and consider it a waste of money.

Share this post


Link to post
Share on other sites

Right-

 

so you're going to consider the FSL Concorde-X a waste of money because something else is causing a crash in FSLOptions.DLL ?

 

Something worked for a week, then something caused it to fail - you need to find what it was.

Share this post


Link to post
Share on other sites

It would be a pity to write off your excellent FSLabs Concorde because of this dll problem which can be resolved! It only takes some careful investigation and I can help you through that eventually since I was myself caught in a similar situation with other DLLs (not FSLabs). This is a known FSX problem that happened with many DLLs most of which were wrongly identified as problematic by FSX.

 

In my first post above I indicated that this problem could come back and FSX would again ask you to approve or reject the loading of that DLL, did you approve and loaded it? If not, please do so and confirm if your FSLab software works normally. Then after closing FSX, check  if the registry key mentioned in my first post is back or not. If it is, make sure to follow the same procedure as per my first post, then go to the next step as follows:

  1. Go to your C: /Users/Yourname/AppData/Roaming/Microsoft/FSX/ dll.xml
  2. Open it with Notepad and ensure that the sequencing of the FSLabs DLLs is as follows:
    1. FSLOptions.dll
    2. FSLEvents.dll
    3. FSLSounds.dll
  3. If it is not the case, rearrange them in that order, save your XML file and start FSX

If the problem is gone, you're good to go, if you still have the error message, you have a DLL conflict with another FSX software, it will be longer to process but here is the method to identify the offending DLL:

  1. In the same FSX DLL.XML, you will notice that each DLL can be loaded manually, so for all your ADD-ONS (except the following FSUIPC, GSX bglmanx, as_btstrp.dll for ASN, VimaCore for AES and PMDG three DLLs which would unlikely be part of the problem) , on the fourth line of each entry, select ManualLoad True
    • Each entry of that file looks like this:
      • <Launch Addon>
      • <Name> FSLOptions </Name> 
      • <Disabled>False</Disabled> 
      • <ManualLoad>False (change to True)</ManualLoad>
      • <Path>FSLabs/DLLs/FSLOptions.dll</Path>
      • <LaunchAddon>
  2. Save your XML file
  3. Start FSX and load your three FSL.dll listed above only and reject all the others when asked by FSX=== Does FSX start normally? If yes, then close it
  4. Start FSX again and this time load your three FSL.dlls with any other of your other DLL, but only a new one at a time, let FSX load and check that you have no error message.
  5. If no error message, proceed again with another FSX start, adding another DLL to the previous list each time, and this until you get an error message, you will then know which DLL creates the conflict.
  6. With that information you may contact the developer and seek assistance to resolve the issue, chances are that FSLabs may not be involved in the issue at all.

Credit for this process should be given to the excellent support of Ben from MCE.

 

Good luck in your hunt, it might sound lengthy, but it does bring results, and you will be able to use your FSLabs software.

Share this post


Link to post
Share on other sites

I figured it out, I had to delete the same property in the registry again. I really hope I don't have to do this every so often, I tried to delete my last post, but couldn't figure out how, sorry, I was having a pretty bad day.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this