Sign in to follow this  
Panxua1

TBM850 v2 - Autopilot non functionning

Recommended Posts

I have installed today the new version of the TBM 850

Although the former version was working perfectly well with its AP, it is impossible to actuate it in the new version.

When passing the mouse on the various keys (hdg, nav, AP, FD etc...) the marker is not modified, and clicking or double clicking does not give any result.

If it is indeed possible to move the various knobs, either heading knob or course knob, this does not induce any modification in the heading or course indicators on the PFD.

Altitude remains on 0000 without any possibililty to move.

Anybody has experimented the same problems? AFCS unit seems not functionning.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Guys

 

Open tickets in Carenado Support. (The more the better chances of getting this and other bugs fixed by them)

Share this post


Link to post
Share on other sites

Will they accept a support ticket if I didn't buy the TBM directly from them, but from PC Aviator?

Share this post


Link to post
Share on other sites

I can get the autopilot working (see below, hope it helps) except for one thing, the Yaw Damper.

 

It is ON by default, and clicking the button for it does not turn it off, even if the autopilot is off.

 

**They went with dynamic mouse wheel buttons for the MFD and PFD. Try using mouse wheel on the VC PFD and MFD buttons?

 

And if you do shift-2 and shift-3 to get the 2D versions for use on another window, those won't turn the buttons unless you click the same button in the VC window. Annoying, but can deal with it.

Share this post


Link to post
Share on other sites

 

 


Will they accept a support ticket if I didn't buy the TBM directly from them

Yes they will, i bought my CJ2 from SImmarket and provided a copy of my invoice attached to the ticket, they replied within an hour and my problem was solved.

Share this post


Link to post
Share on other sites

Yes they will, i bought my CJ2 from SImmarket and provided a copy of my invoice attached to the ticket, they replied within an hour and my problem was solved.

Thanks, Rick. Will do.

Share this post


Link to post
Share on other sites

The reply to my support ticket was duly answered within the hour.

The answer is that it is necessary to uninstall version 1 properly before installing V2.

The uninstall program is located at FSX root folder.

Once it is done, you have to reinstall V2.

I did it this morning successfully.

It remains that the AP is functionning differently, and that, for example, I did not find the solution to tune altitude per hundred of feet. Only per thousand.

To be continued!

Share this post


Link to post
Share on other sites

For the hundreds  of feet use shift 4 for the auto pilot.Click on the altitude button in the centre for  the thousand and the bottom for the hundred.

Mine works fine on the VC as well.Once the yaw damper is on,you cannot disengage it.Also the batterie shows 28volts but always 0 amps.

if you do shift 1 you will get the pop up PFD and it will switch off the copilot PFD.

 

AlainV

Share this post


Link to post
Share on other sites

The reply to my support ticket was duly answered within the hour.

The answer is that it is necessary to uninstall version 1 properly before installing V2.

The uninstall program is located at FSX root folder.

Once it is done, you have to reinstall V2.

I did it this morning successfully.

It remains that the AP is functionning differently, and that, for example, I did not find the solution to tune altitude per hundred of feet. Only per thousand.

To be continued!

I used the Control Panel to uninstall version 1.  Shouldn't that have worked just as well?

For the hundreds  of feet use shift 4 for the auto pilot.Click on the altitude button in the centre for  the thousand and the bottom for the hundred.

Mine works fine on the VC as well.Once the yaw damper is on,you cannot disengage it.Also the batterie shows 28volts but always 0 amps.

if you do shift 1 you will get the pop up PFD and it will switch off the copilot PFD.

 

AlainV

Alain,  For some reason this doesn't work for me.  I have no control over the altitude bug in the pfd.  The knob just spins around with no effect on the altitude bug.

Share this post


Link to post
Share on other sites

I would unistall it and clean the register and check that there is no files left under carenado.

 

Alainv

Share this post


Link to post
Share on other sites

Sounds like plan.  I thought I had uninstalled all of V1, but perhaps not.  The plane flies fine in V2, just this altitude bug problem.

 

Edit to add:  Alain, your idea was a good one.  I completely uninstalled V2, found a couple of entries that had not been deleted, cleaned the registry and re-installed V2.  All is working normally now, including the altitude bug, both by increasing/decreasing by 1000s or by 100s (left clicking or right clicking on the altitude knob).  So thank you for your suggestions.

Share this post


Link to post
Share on other sites

Once the yaw damper is on,you cannot disengage it.

 

 

For those still fighting it.... after a little more research in the FSX controls..... CTRL-D will disengage the Yaw Damper, although it does not extinguish the light next to its button on the AP.

Share this post


Link to post
Share on other sites

Glad it's ok now.I noticed another thing.On the pilot PFD top left hand corner,the speed indicator in blue has the arrow showing the wrong way.

Also it is not working too well unless I put the ani ice on.Anybody noticed it?

 

AlainV

Share this post


Link to post
Share on other sites

Glad it's ok now.I noticed another thing.On the pilot PFD top left hand corner,the speed indicator in blue has the arrow showing the wrong way.

Also it is not working too well unless I put the ani ice on.Anybody noticed it?

 

AlainV

Yes, I've noticed this also. In fact, I don't think the indicator should remain at 0000 either.

Share this post


Link to post
Share on other sites

Further test this morning.

The altitude knob functions indeed two ways. A first click on the right button of the mouse, and activating the wheel makes hundred of feet steps, another click with the right button, and you are making thousand of feet steps wihile activating the wheel.

Share this post


Link to post
Share on other sites

Further test this morning.

The altitude knob functions indeed two ways. A first click on the right button of the mouse, and activating the wheel makes hundred of feet steps, another click with the right button, and you are making thousand of feet steps wihile activating the wheel.

That's correct.  It works as advertised.

Share this post


Link to post
Share on other sites

Further testing this afternoon.

In particular, the VS setting of the autopilot, when aiming at a targeted preset altitude.

The VS button, which illuminated when actuated in V1, doesn't do it anymore...

But! It is actually functionning.

The AP mode is announced on top of the PFD; And when actuated, the VS setting is announced on the PFD. Some new indication in V2 : the rate of vertical speed is now mentionned in the announcement. You have to check if the target altitude is also announced in white letters.

Another thing I am not sure was already existing in V1 : by right clicking in the HDG knob, you change the targeted heading by increments of either ten or one degree.

Share this post


Link to post
Share on other sites

I'm not sure about the VS setting either and how it works specifically.  I've managed through trial and error to get it to work, but I'm still not sure about it.  More "fiddling" necessary, I'm afraid.

Share this post


Link to post
Share on other sites

I beleive the VS works with the FLC to maintain a constant speed ( equivalent of CTRL T) and the speed will show up on the top left hand corner of the PFD in blue:I haven't got the combination right yet.

 

AlainV

Share this post


Link to post
Share on other sites

From what I could see, the SPD button which allowed to keep a determined speed while descending is now switching between IAS and mach speed.

Share this post


Link to post
Share on other sites

Seems like quite a few new issues were introduced with v2. I've also struggled with the autopilot and trying to make it climb to a target altitude and then level off. I think it's made more confusing because some of the buttons no longer light up on the AP itself so it's not as obvious what mode you're in.

Also of course it's impossible to toggle the yaw damper using the button.

 

Do Carenado perform any beta testing at all? Any news on a v2.1 patch?

Share this post


Link to post
Share on other sites

I've found that you first set the altitude in the pfd by rotating that altitude knob.  Then, once you are in climb out and roughly on course, hit AP and then NAV, then press VS and scroll the "wheel" on the right-hand side until you reach the vertical speed you want (by looking at the vs indicator on the pfd), then you're set.  At least this is how I remember doing it.  It was a trial and error routine, however, but I think I finally got it to work correctly.  As usual, Carenado's documentation leaves something to be desired.  But I enjoy flying the TBM on medium distance flights, so I had plenty of time to mess with the vs setting.  Btw, if the Nav setting leaves you trying to track a VOR, cycle the CDI button until it comes back to GPS.  Then you should be tracking your GPS course, rather than a VOR, unless you want to track a VOR frequency tuned on your NAV1 receiver.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this