Sign in to follow this  
Blackrat100

Low FPS in P3D with MSI GTX 1070

Recommended Posts

I do hope someone can point me in the right direction here.

 

I've just upgraded from a GTX 970 to a GTX 1070 and my P3D frame rate has dropped considerably. Not what I was expecting at all.

 

I removed my 970 and installed the 1070, completely removed the Nvidia drivers with Display Driver Uninstaller (DDU) and clean installed 368.81.

Everything went fine with Valley Benchmark showing a healthy increase in score from 1967 to 2890.

Fine so far, until I ran P3D.

 

Before the change at Orbx KPSP in a Lancair Legacy I was getting 42 fps.

Running with the same settings with the 1070 I'm now getting 23 fps.

 

My system is:

6700k,

32GB ram,

MSI GTX1070 Gaming X,

Win10 Home on an M2 SSD and

P3D on a 500GB 840 EVO SSD.

 

Thanks for your advise.

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm not an expert, but know my way around...

You should delete your shaders folder

 

type this in your Windows Start menu, and press enter.

%localappdata%\Lockheed Martin\Prepar3D v3

 

delete the Shader subfolder.

 

Come back if it didn't help.

Share this post


Link to post
Share on other sites

I'm not an expert, but know my way around...

You should delete your shaders folder

 

type this in your Windows Start menu, and press enter.

%localappdata%\Lockheed Martin\Prepar3D v3

 

delete the Shader subfolder.

 

Come back if it didn't help.

 

To add to that, I'd probably also delete the config and let the game recreate it.

Share this post


Link to post
Share on other sites

Thanks for that.

I had remembered to delete the shaders folder but not Prepar3D.cfg.

 

I'll give it a go.

Share this post


Link to post
Share on other sites

Thanks for that.

I had remembered to delete the shaders folder but not Prepar3D.cfg.

 

I'll give it a go.

 

 

So, tell us if it works ;)

Share this post


Link to post
Share on other sites

Well, tried all that. No luck.

I'm still getting poor fps, most annoying.

 

With the GTX970 and Flyinside I was getting a usable 30/90 fps, now with the GTX1070 and new driver it's down to 20/12 fps.

 

I'm hoping it's a new driver problem that'll be fixed soon.

Share this post


Link to post
Share on other sites

Rather stupid guess: are you sure that P3D uses the GTX-1070 or did P3D somehow select the iGPU of your 6700K while you removed the 970 and deleted the drivers. BTW: if I switch from nVidia to nVidia, I NEVER delete the driver, why should I? The only thing I do: install the newest possible nVidia driver still using the old card, turn off, replace the card, reboot and that's it. In the worst case, you can still select "perform new installation" afterwards.

 

Then, you have to monitor your GPU clocks. It might also be that somehow using P3D, the 1070 remains in a wrong P-State, not throttling up. This you could avoid by selecting "prefer maximum performance" in the nVidia driver menue under "power managment" specifically for p3d.exe or globally, as you wish.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks for letting us know that it didn't help.

I'm sure it's something stupid and logic (like most IT problems) but right now it's over 30°C here and it's hard to think... :P

 

I hope AnkH is pointing you in the right direction.

 

Good luck.

Share this post


Link to post
Share on other sites

Great :smile:

 

Got it working fine now thanks to AnkH's suggestion of clicking "prefer maximum performance" in the nVidia driver menu under "power management".

Flyinside now running at 24/92 fps

 

Thanks all.

  • Upvote 1

Share this post


Link to post
Share on other sites

Great :smile:

 

Got it working fine now thanks to AnkH's suggestion of clicking "prefer maximum performance" in the nVidia driver menu under "power management".

Flyinside now running at 24/92 fps

 

Thanks all.

 

Please delete this reply, thank you.

 

Bob

Share this post


Link to post
Share on other sites

Load at up the pmdg 777 Please turn on the dome light a few times and see what happens. Failing that click on the left fmc a few times see what happens.

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this