Sign in to follow this  
St0rmy

EzDok Middle Mouse working keys are not

Recommended Posts

I recently just made the switch from EzDok to P3D and I am attempting to install EzDok however when I am in the cockpit I can use mouse 3 to look around hwoever whne I try to use num 2, all the direction keys, the page keys, etc they just don't work.

 

First time I installed and found this problem I uninstalled EzDok completely, I removed all of the registry entries I had for both my previous versions of FSX (SE) and P3Dv3 and reinstalled. This did not fix it so then I searched and found the "check conflicting hotkeys" option in config.exe. I ran this and nothing now I am confused.

 

By the way I am running EzDok as admin at all time throughout the installation process and loading it into the game.

 

Running version 1.18.7

 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

 

 

Where did you get v1.187 - if you updated using the zip from the forum it may be your problem.

 

It is better to

1. delete the primary ezdok folder EZCA in C:/Program Files (x86) and the ezdokcam1 lic

File in c:/ezdok software

 

2. Download the latest all in one installer from the flight1 website and run it

 

This will replace the deleted files and reset the licence to rescan your PC hardware

3. do NOT use - run as administrator - on file EzCA.exe - try it without first

4 DO use - run as administrator on Prepar3d.exe.

 

This allows the sim to control ezdok permission level when running the sim

 

Kevin H

  • Upvote 1

Share this post


Link to post

 

 


Kevin H

 

Hello there Kevin  :smile:    This is the same Kevin from the SimForums ? 

 

Love your work  :hi:

  • Upvote 1

Share this post


Link to post

Where did you get v1.187 - if you updated using the zip from the forum it may be your problem.

 

It is better to

1. delete the primary ezdok folder EZCA in C:/Program Files (x86) and the ezdokcam1 lic

File in c:/ezdok software

 

2. Download the latest all in one installer from the flight1 website and run it

 

This will replace the deleted files and reset the licence to rescan your PC hardware

3. do NOT use - run as administrator - on file EzCA.exe - try it without first

4 DO use - run as administrator on Prepar3d.exe.

 

This allows the sim to control ezdok permission level when running the sim

 

Kevin H

 

Thanks for your contribution Kevin unfortunately this did not make a difference.

FYI I sourced EzDok 1.18.7 from the flight1 website here.

Share this post


Link to post

the issue described is almost always related to a permission mismatch being read by windows when opening the software

Have you added exclusions for ezdok camera - EZCA.exe and folder location within your Anti virus software and UAC slider set to  - never notify

 

The Ezdok camera wrapper/installer has a limited number of activations (3 or 4 attempts) before the Licence fails and a reset is needed

 

Have you used the automated process before -

on the flight1 website > support > - there is an Option - re-activate my order

I use it regulalry due to problem solving ezdok often messing up the install /licence

 

you add your ezdok order number - E-mail used for the purchase and password  - then an automated e-mail is sent (inside is a click link)

click on the link to reset the licence -

 

Then try running the ez config tool from the desktop shortcut using - right mouse button - select run as admin

 

don't run the registry option in the config tool

then run the sim as normal

  • Upvote 1

Share this post


Link to post

the issue described is almost always related to a permission mismatch being read by windows when opening the software

Have you added exclusions for ezdok camera - EZCA.exe and folder location within your Anti virus software and UAC slider set to  - never notify

 

The Ezdok camera wrapper/installer has a limited number of activations (3 or 4 attempts) before the Licence fails and a reset is needed

 

Have you used the automated process before -

on the flight1 website > support > - there is an Option - re-activate my order

I use it regulalry due to problem solving ezdok often messing up the install /licence

 

you add your ezdok order number - E-mail used for the purchase and password  - then an automated e-mail is sent (inside is a click link)

click on the link to reset the licence -

 

Then try running the ez config tool from the desktop shortcut using - right mouse button - select run as admin

 

don't run the registry option in the config tool

then run the sim as normal

 

Alright I have done all of the above, no change. Am I supposed to uninstall and reinstall EzDok after I reactivate my code?

Also is it strange that EzDok is not running on its own accord (not booting with the game) and once I am in the cockpit of a plane I have to navigate to C:\Program Files (x86)\EZCA and open it myself.

 

Cheers

Share this post


Link to post

Alright I have done all of the above, no change. Am I supposed to uninstall and reinstall EzDok after I reactivate my code?

Also is it strange that EzDok is not running on its own accord (not booting with the game) and once I am in the cockpit of a plane I have to navigate to C:\Program Files (x86)\EZCA and open it myself.

 

Cheers

you need to read Poppet's tutorial guide , see post #3 above,

Share this post


Link to post

 

Ezdok should be allowed to install the various files and folders it chooses - users should not select

Alternative locations

 

The ez config tool is responsible for adding the entry for ezdok to your sim EXE.xml file - it does not check the install path for ezdok and it will not recognise a path other than

 

C:/Program Files (x86)/EZCA It won't auto open

 

If you have installed ezdok anywhere else - just move the folder EZCA to that location

The lic fiile and ezdok -setup v1.187.exe file should be in

 

C:/Ezdok Software

 

Kevin

Share this post


Link to post

Hi Elaine

 

Yes it is me. Thanx, i do my best - seems it's not so great in this instance, hopefully we can resolve the issue for the OP.

 

I'm very impressed with your knowledge base, Avsim has excellent contributors, your guides are excellent.

 

Kevin

Share this post


Link to post

Alright I have done all of the above, no change. Am I supposed to uninstall and reinstall EzDok after I reactivate my code?

Also is it strange that EzDok is not running on its own accord (not booting with the game) and once I am in the cockpit of a plane I have to navigate to C:\Program Files (x86)\EZCA and open it myself.

 

Cheers

 

 

Check your EXE.XML file (in users/local/roaming/p3d). It should say this:

 

<Launch.Addon>
    <Name>EZdok camera addon</Name>
    <Path>C:\Program Files (x86)\EZCA\EZCA.exe</Path>
  </Launch.Addon>

Share this post


Link to post

At 72 years old, I'm often prone to errors, like forgetting to set the Num Lock on.  Regards.

 

M.

Share this post


Link to post

Kevin

 

Thank you very much Kevin  :smile:   Yes Avsim is a fantastic spot,  I'm on loads of sites but Avsim is my drug of choice.

 

 

 

I recently just made the switch from EzDok to P3D and I am attempting to install EzDok however when I am in the cockpit I can use mouse 3 to look around hwoever whne I try to use num 2, all the direction keys, the page keys, etc they just don't work.

 

Stormy,  So Ezdok Launch's Ok when you start Prepar3D ?  And you can see the Ezdok Control Panel and you can see it in your Add On's in Prepar3D "Top of page" ?

 

I'm not sure how familiar you are with EZdok so please excuse the Question But..........

 

Have you tried Pressing the NUM LOCK button on your key pad ?   When NUM Lock is On and by pressing NUM 3 you will Turn Off the Ezdok Control Panel,  So when your View is set Turn Off NUM lock  and then you can operate your directional keys   You will know EZdok is On by looking at the top of the EZdok Control Panel,  Is Active Yellow Or Black ? 

 

Also, When you have confirmed this Make Sure the PTP and POV are on so you can use the Directional Keys

Share this post


Link to post

Where did you get v1.187 - if you updated using the zip from the forum it may be your problem.

 

It is better to

1. delete the primary ezdok folder EZCA in C:/Program Files (x86) and the ezdokcam1 lic

File in c:/ezdok software

 

2. Download the latest all in one installer from the flight1 website and run it

 

This will replace the deleted files and reset the licence to rescan your PC hardware

3. do NOT use - run as administrator - on file EzCA.exe - try it without first

4 DO use - run as administrator on Prepar3d.exe.

 

This allows the sim to control ezdok permission level when running the sim

 

Kevin H

Kevin, wanted to say thank you!!! The fact that the keyboard did not work was driving me crazy for the past week.

 

You gave me two pieces of info that solved my issue.

 

1) I changed EzCA.exe to NOT run as administrator - This fixed the issue.

2) I did not follow your advice here (shame on me) but you did give me what I needed to edit the EXE.XML file so that it loads ezdok when P3D loads so that is awesome, and it works. If I have issues in the future I will uninstall and install to C; but I am trying to keep the OS on C, Flight Sim on E and File transfer and logs on F (if you have not figured it out by that format I am an old Wintel IT guy). That also makes me stubborn :)

 

Anyway appreciate the post and the solution it lead to. Maybe we can introduce the developer to variables in their code so they can place the right path in the XML file in the next version LOL!!

Share this post


Link to post

Glad to hear you have resolved the problem.

 

The location of ezdok is not locked to the default folder for those users familiar with how it operates and able to make the appropriate adjustment to the sim EXE.xml file

In testing I have not found there to be any operational benefit to using an alternate location if anyone is thinking it may be worth trying.

 

The problem with the current beta v1.187 version of ezdok is that it is an amalgamation of very old elements from earlier editions with no flexibility hence your issue when installing ezdok on your E:/drive

 

Unfortunately given the history of ezdok development I don't expect any updating of the code

But you never know ... Lol

 

Kevin

Share this post


Link to post

Alright thank you everyone particularly KevinHuser, my game is now working.

 

I can't be certain of what fixed this all the entries in my dll.xml and exe.xml were correct. My directories were correct.

I'm not certain if this could have caused it but the whole time I was attempting to use EzDok in the compability section of EZCA.exe I had it to run as admin.

 

Thank you for everyone's help all solved.

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this