Sign in to follow this  
masaki

NVIDIA display setting

Recommended Posts

Hi all,

 

Maybe I'm stating the obvious, but, new to x-plane here.. Changing "Multi-display/mixed GPU acceleration" to "Single display performance mode" provided an great frame rate boost, 50% or so.

Noted this on a GTX970 and a new 1070

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I do not think that is your imagination. I changed this setting after reading a post a while back. I have multiple monitors but setting this to single display yielded noticeable improvement. Not 50% for me but probably 5 to 10 fps. I will see if I can dig up a link to the post as it had the why this was the case in it which I do not recall off hand.

Share this post


Link to post
Share on other sites

Where is the setting please, in the nvidia?

In Windows, right-click on desktop to get menu.  Open nVidia Control Panel.  On the left, under 3D Settings, click on Manage 3D settings.  Click on Program Settings tab.  Choose X-Plane as a single program and make settings there for just X-Plane (not Global Settings tab).

Share this post


Link to post
Share on other sites

Make sure you select Max performance in power settings as well.

Share this post


Link to post
Share on other sites

 

 


In Windows, right-click on desktop to get menu.

 

In Windows 10, you have to go into the Windows Control Panel and then into the nVidia Control Panel.

 

John

Share this post


Link to post
Share on other sites

Hey Masaki thanks for your tip. That's a great post for a newbie to XPL! I got a boost of about 6 fps which is welcome since I keep my settings pretty high.

Share this post


Link to post
Share on other sites

 

 


In Windows 10, you have to go into the Windows Control Panel and then into the nVidia Control Panel.

 

This is wrong...  Sorry... The computer I was using at the time I checked did not have an nVidia card.

 

John

Share this post


Link to post
Share on other sites

Hey Masaki thanks for your tip. That's a great post for a newbie to XPL! I got a boost of about 6 fps which is welcome since I keep my settings pretty high.

Glad it worked for you! It helped me keep shadows at "Global High", I really like this (very expensive) setting.

Share this post


Link to post
Share on other sites

Another pair of tricks is:

 

1) Under V-Sync, choose 1/2 display rate or whatever suits your monitor, and Vertical Sync tear control to "Adaptive";

2) Make sure you disable Threaded Optimization to "Off" in Nvidia Inspector or Nvidia Control Panel;

 

I usually set X-Plane at HDR, and a AA that my PC supports, and then in Nvidia Inspector also set the mode as "Enhance Application settings", and in SGSS 2xSGSS or 4xSGSS ( usually 2 only )....

 

With this settings I get a stutter-free ride, good AA and 30 fps almost all of the time :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this