Sign in to follow this  
Murfman

Trouble with JustSim Nice LFMN

Recommended Posts

Hi,  I just bought this scenery today, but I'm having trouble with runway lights not displaying.  According to the brief documentation, SODE  is responsible for  some lighting effects.  It is mentioned that the exe.xml file must have certain lines in it for SODE to function with this airport.  I looked in the file, and there is a reference to SODE, but several of the lines that the documentation says are necessary are missing.  I'm hoping that editing this file will solve the problem.

 

Can anyone recommend an effective but cheap XML editor?

 

Thanks,

 

Tom

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Let me check if it is working on my system as I have the scenery too...

Will get back here.

Share this post


Link to post

Justsim Nice + France VFR PACA 2 v2 + Nightenvironment France v2

Nice.jpg

Share this post


Link to post

Hi there Tom!

 

I had issues with the lights as well when I first installed this scenery and in my case the solution in the end after trying lots of other things was to first uninstall Nice, then uninstall SODE and then reinstall first Nice including SODE making sure to activate/register SODE right away during the installation using the SODE Platform Manager that is launched automatically during installation of Nice.

 

After doing this and making sure I had working lights I also updated to the latest version of SODE.

 

However looking at the runway lights for this airport even when they are working they are still not particularly good compared to many other airports out there. UK2000 airports for example have amazingly realistic runway lights IMO!

 

As you can see from this screenshot the centerline lights at Nice look more like taxiway lights while IRL the same lights look like seen in this video clip. As you can see they are very similar to the edge line lights in both look and intensity.

 

I had a rather long discussion with the developer about this and I was told they do have this on their list to be addressed in a future update of the scenery.

 

As for SODE and to make sure you have a working installation make sure you have a SODE menu in P3D and that you will see a couple of options in there. I don't remember the exact wording of those menu options out of my head but I think one of them is something like "Reload all".

 

Hope some of this helps you and let us know how it goes!

Share this post


Link to post

What happen to your airport lights? I see you have runway lights but airport buildings is completely dark?

Share this post


Link to post

What happen to your airport lights? I see you have runway lights but airport buildings is completely dark?

Not sure who you are directing your question to but if it's me and my screenshot I'm not really sure honestly.

 

This is what it looks like over here but will have another closer look at the airport buildings later on today during night time to see what it looks like.

 

Maybe you could share a screenshot if you're saying it looks different for you?

Share this post


Link to post

Hi Richard,

 

Here how it looks on my system..

 

Nice%202.jpg

Share this post


Link to post

As already stated, SODE is necessary to get airport lighting at LFMN. There have been previous posts on this. However, it appears that while some people find SODE installs as part of the Nice installation process, others have problems. In my case, using P3D 3.2.3,  SODE did not install initially. Result, no lighting.

 

The readme notes about checking and amending the xml file seemed not very clear and proved not to be necessary.

 

In the main P3D folder, locate the LFMN Nice folder, which in my case was under the SimMarket folder, and click on it. You will find inside that LFMN folder a SODE installer file. This is labelled Installer SODE v1.33.

Just click on this and follow the instructions for SODE installation. No xml editing was needed and all lighting then operated correctly. 

 

Share this post


Link to post

Does this airport not have any runway centreline lights or approach lights?? :huh:

Share this post


Link to post

Does this airport not have any runway centreline lights or approach lights?? :huh:

That I am wondering too. At Simmarket looking at the screenshots I do not see them either.

I just sent an email to the developer with a link to this thread..

Share this post


Link to post

That I am wondering too. At Simmarket looking at the screenshots I do not see them either.

I just sent an email to the developer with a link to this thread..

 

All the runways have centerline lights in yellow, at lower intensity than the white ones. Check your SODE installation.

Cheers, Ed

Share this post


Link to post

Hi Ed,

Can you post a screenshot how it looks as I could not find one screenshot with centerlighting..

SOD1.3 is installed on my pc..

Thanks

Share this post


Link to post

When being very close to the runway , indeed there is center lighting, but way to dim.

It also should be visible from 5 mls away..

 

Nice%203.jpg

Share this post


Link to post

Here you go

 

 


Sorry, did not attached the screenshots.

 

https://www.dropbox.com/s/34zjy9pk5i9qaqb/LFMN%202.JPG?dl=0

 

Cheers, Ed


Here you have another one:

 

https://www.dropbox.com/s/iqw5s4tjlvbn0md/LFMN%201.JPG?dl=0

 

I would look into your exe.xml file located in C:\ProgramData (not in the %AppData% folder), and add MANUALLY the lines eventually missing in the SODE section, as per indicated by JustSim in the LFMN manual (check typos). It should work.

 

Cheers, Ed

Share this post


Link to post

Hi Ed,

 

Here you go :

 

<?xml version="1.0" encoding="Windows-1252"?>
 
<SimBase.Document Type="AceXML" version="3,0" id="exe">
    <Descr>AceXML Document</Descr>
    <Filename>exe.xml</Filename>
    <Launch.Addon>
        <Name>SODE</Name>
        <Path>D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SODE\SimObjectDisplayEngine.exe</Path>
        <CommandLine>P3Dv3</CommandLine>
    </Launch.Addon>
    <Launch.Addon>
        <Name>Couatl</Name>
        <Path>fsdreamteam\couatl\couatl.exe</Path>
    </Launch.Addon>
    <Launch.Addon>
        <Name>XHT.APController</Name>
        <Path>D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Aerosoft\AirportController\APController.exe</Path>
    </Launch.Addon>
</SimBase.Document>
 
 
SODE Platform Manager :
Module Registration Status : SODE REGISTERED
MODULE Activation Status : SODE ACTIVE
 
SODE log :
[15:19:47.592] INFO  : Targetting Platform 'P3Dv3'
[15:19:47.592] DEBUG  : Initializing Text Menus...
[15:19:47.592] DEBUG  : Initializing Seasonal Object Handler...
[15:19:47.592] DEBUG  : Initializing SimObject Lists...
[15:19:47.592] DEBUG  : Initializing QuadTree...
[15:19:47.592] DEBUG  : Initializing Sound Engine...
[15:19:47.617] INFO SODE.SOUNDENGINE : SoundEngine initialized.
[15:19:47.617] DEBUG  : Initializing Sim Bubble...
[15:19:47.617] DEBUG  : Initializing AI Monitor...
[15:19:47.617] DEBUG  : Initializing Jetway Handler...
[15:19:47.617] DEBUG  : Initializing VDGS Handler...
[15:19:47.617] WARN  : VDGS Pack is not found/installed!
[15:19:47.617] DEBUG  : Start Main Initialization!
[15:19:47.617] DEBUG  : Trying to read Settings from SimObjectsDisplayEngine.ini file...
[15:19:47.619] DEBUG SODE.SETTINGS : All Settings successfully read.
[15:19:47.619] DEBUG SODE.SETTINGS : CurrentSettings -> SoundEngine=1; WatchDog=1; UserJetwaySound=1; SecMenuHotKey=SHIFT+VK_MINUS; AIDetection=0; AIJetwaySound=0
[15:19:47.619] DEBUG  : Trying to find Custom Configuration files...
[15:19:47.619] DEBUG SODE.XML : Finding SDX CFG Files...
[15:19:47.619] WARN SODE.XML : \cfg\ not found. Code(2) [C:\ProgramData\12bPilot\SODE\cfg\*.sdx]
[15:19:47.619] DEBUG  : Trying to build SimObject List out of Custom Config files...
[15:19:47.619] WARN SODE.XML : No SDX Files found! Lists are empty.
[15:19:47.619] DEBUG  : Trying to find XML Definition files...
[15:19:47.619] DEBUG SODE.XML : Finding XML Files...
[15:19:47.619] INFO SODE.XML : xml File Found: LFMN.xml!
[15:19:47.619] INFO SODE.XML : xml File Found: LOWS.xml!
[15:19:47.619] INFO SODE.XML : xml File Found: MKSTUDIOS_Jetways.xml!
[15:19:47.619] DEBUG  : Trying to build SimObject List out of XML definition files...
[15:19:47.619] DEBUG SODE.XML : Building List from File 'C:\ProgramData\12bPilot\SODE\xml\LFMN.xml'
[15:19:47.621] DEBUG SODE.XML : Building List from File 'C:\ProgramData\12bPilot\SODE\xml\LOWS.xml'
[15:19:47.623] DEBUG SODE.XML : Building List from File 'C:\ProgramData\12bPilot\SODE\xml\MKSTUDIOS_Jetways.xml'
[15:19:47.625] WARN SODE.XML : Jetway SimObject 'Gate 412 422 MK': Model 'MK Jetway Low' has no StaticSimTitle Attribute defined!
[15:19:47.625] WARN SODE.XML : Jetway SimObject 'Gate 410 MK': Model 'MK Jetway Low' has no StaticSimTitle Attribute defined!
[15:19:47.625] WARN SODE.XML : Jetway SimObject 'Gate 503 MK Outer': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 503 MK Inner': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 505 MK Outer': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 505 MK Inner': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 507 MK Outer': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 507 MK Inner': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 509 MK Outer': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 509 MK Inner': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 518 508 MK': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 508 528 MK': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 432 MK': Model 'MK Jetway Low' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 701 MK Inner': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 701 MK Outer': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 702 MK Inner': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 702 MK Outer': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 703 MK Inner': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 703 MK Outer': Model 'MK Jetway High Grey' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 704 MK Outer': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 704 MK Inner': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 705 MK Inner': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 705 MK Outer': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 706 MK Inner': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 706 MK Outer': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 707 MK Inner': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.626] WARN SODE.XML : Jetway SimObject 'Gate 707 MK Outer': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.627] WARN SODE.XML : Jetway SimObject 'Gate 708 MK Inner': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.627] WARN SODE.XML : Jetway SimObject 'Gate 708 MK Outer': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.627] WARN SODE.XML : Jetway SimObject 'Gate 709 MK Inner': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.627] WARN SODE.XML : Jetway SimObject 'Gate 709 MK Outer': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.627] WARN SODE.XML : Jetway SimObject 'Gate 710 MK Inner': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.627] WARN SODE.XML : Jetway SimObject 'Gate 710 MK Outer': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.627] WARN SODE.XML : Jetway SimObject 'Gate 711 MK Inner': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.627] WARN SODE.XML : Jetway SimObject 'Gate 711 MK Outer': Model 'MK Jetway High' has no StaticSimTitle Attribute defined!
[15:19:47.627] DEBUG SODE.XML : XML Data successfully read and List created.
[15:19:47.627] DEBUG  : List generated! Trying now to insert into QuadTree...
[15:19:47.627] DEBUG  : QuadTree populated with SimObject references.
[15:19:47.627] DEBUG  : Trying to generate Aircraft Parameter Map from the INI file...
[15:19:47.632] DEBUG SODE.ACFTPARAMS : Door Parameters read for 26 ICAO Aircraft Types.
[15:19:47.632] DEBUG  : SDX/XML/INI Handling done! Start FS Processing...
[15:19:47.632] DEBUG  : Initializing Internal Sounds...
[15:19:47.632] DEBUG  : All Initialization Done!
[15:19:47.632] DEBUG SODE.FSPROCESS : Trying to connect to FS...
[15:19:47.633] DEBUG SODE.FSPROCESS : Connected to FS!
[15:19:47.633] DEBUG SODE.FSPROCESS : Secondary Text-Menu Hotkey set -> SHIFT+VK_MINUS
[15:19:47.633] DEBUG SODE.FSPROCESS : Setting up Connection Watchdog...
[15:19:47.633] DEBUG SODE.FSPROCESS : Entering FS Dispatch Loop.
[15:20:45.889] INFO SODE.FSLOOP : SODE connected to Simulator...
[15:20:45.891] DEBUG SODE.ACFTEXITS : No Custom Data Found for D:/Program Files (x86)/Lockheed Martin/Prepar3D v3/SimObjects/Airplanes/Prosim 737-800 Regular/. Using original aircraft.cfg exit data!
[15:20:45.892] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in C:\ProgramData\12bPilot\SODE\SimObjects\
[15:20:45.895] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SODE\data\SimObjects\
[15:20:45.895] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SimObjects\Airplanes\
[15:20:45.895] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SimObjects\Avatars\
[15:20:45.896] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SimObjects\Rotorcraft\
[15:20:45.896] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SimObjects\GroundVehicles\
[15:20:45.910] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SimObjects\Boats\
[15:20:45.918] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SimObjects\Animals\
[15:20:45.918] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SimObjects\Misc\
[15:20:45.947] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SimObjects\Submersible\
[15:20:45.947] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SimObjects\Weapons\
[15:20:45.964] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SimObjects\Countermeasures\
[15:20:45.964] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\MyTraffic Professional\MyTraffic\Aircraft\
[15:20:45.971] DEBUG SODE.FOLDERMANAGER : Looking for sim.cfg files in D:\Program Files (x86)\Lockheed Martin\Addon Scenery/Aerosoft\Mega Airport Zurich V2.0\simobjects\
[15:20:45.972] INFO SODE.FOLDERMANAGER : SODE SimObjects Map Building completed. Size=24
[15:20:45.972] INFO SODE.FSLOOP : Successfull Registration of Reserved Key -> s Tab+S
[15:28:18.555] INFO SODE.FSLOOP : SeasonalObjectHandler: Variables initialized!
[15:28:19.921] INFO SODE.FSLOOP : ### FILTERING OBJECTS WITHIN SIM RADIUS OF 24000m
[15:28:19.921] INFO SODE.FSLOOP : ### Active SimObjects: 2; Active Wind Data Probes: 1
[15:28:19.942] ERROR SODE.FSLOOP : SimConnect EXCEPTION! ID=31
[15:28:19.947] INFO SODE.FSLOOP :  + SimObject LFMN:LFMN [12bPilot_SODE_Environmental_Data_Probe]. ID: 152
[15:28:19.953] INFO SODE.FSLOOP :  + SimObject LFMN:LFMN_SVET [LFMN_SVET]. ID: 153
[15:28:19.957] INFO SODE.FSLOOP :  + SimObject LFMN:LEGE_RAIN [LFMN_RAIN]. ID: 154
[15:28:53.354] INFO SODE.FSLOOP : SeasonalObjectHandler: Refreshing Season/Time Data...
[15:29:54.896] INFO SODE.FSLOOP : SeasonalObjectHandler: Refreshing Season/Time Data...
[15:44:32.225] INFO SODE.FSLOOP : SeasonalObjectHandler: Refreshing Season/Time Data...
[15:44:40.988] INFO SODE.FSLOOP : SODE disconnected from Simulator!
[15:44:40.989] DEBUG SODE.FSPROCESS : Cleaning up Memory...
[15:44:40.990] DEBUG SODE.FSPROCESS : Closing Connection to FS.
[15:44:41.090] INFO  : Terminate SODE.
 
 

Share this post


Link to post

Hi Gerard:

 

This is mine (exe.xml in C:\ProgramData):

 

<?xml version="1.0" encoding="windows-1252"?>
<SimBase.Document Type="AceXML" version="3,0" id="exe">
  <Descr>AceXML Document</Descr>
  <Filename>exe.xml</Filename>
  <Launch.Addon>
    <Name>SODE</Name>
    <Path>C:\Program Files (x86)\12bPilot\SODE\SimObjectDisplayEngine.exe</Path>
    <CommandLine>P3Dv3</CommandLine>
  </Launch.Addon>
  <Launch.Addon>
    <Name>Couatl</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>fsdreamteam\couatl\couatl.exe</Path>
  </Launch.Addon>
</SimBase.Document>

 

You see the difference?. My SODE was installed in a different way than yours, mine is in another folder, outside P3D. I'm not a guru to tell if that makes a difference. If you like, and you're not as me, that does not like to be messing around with uninstalls/installs processes, you could uninstall SODE from the Control Panel remove programs and try to run the SODE installer and register again for P3Dv3.

 

There's also a recommendation to install P3D outside the system folders to avoid issues. But if the rest of P3D is working well for you, I think you could live with that. I always install P3D in another drive, different that my OS drive.

 

Cheers, Ed

Share this post


Link to post

SODE probably was installed there by either AS Rome or AS Zurichv2..

At those airports the nightlighting is working fine...

 

From closeup my centerlights look the same as yours.

It is only from further away that they they disappear.

 

How do your centerlights look from 2-3 mls away ... ?

I guess that they are not visible too..

 

 

 

 


 

That looks like the default Nice..

 

I have more buildings and much more detail..

Share this post


Link to post

 

 


How do your centerlights look from 2-3 mls away ... ?

I guess that they are not visible too..

 

I'll try out later today and will post.

Cheers, Ed

Share this post


Link to post

I played with the texture a bit and reized the centerlight and its bloom.

From up close they are bigger and better to be seen.

Unfortunately it looks like it is not coded to be seen from far away..

 

That seems to be the case as no centerlights are used in the Afcad file...

I will play with that ..

Share this post


Link to post

That looks like the default Nice..

Oops! SimStarter NG. The North American sceneries are active, not Europe. My mistake (one of many so far today.)

 

JustSim LFMN showing the same detail as in Ed's photos so I won't include them. They're faint, but there.

Share this post


Link to post

Just modified the Afcad file, so it includes dim centerlights

Nice%204.jpg

 

From up close you can see the texture version lights and the Afcad version lights

Nice%205.jpg

Share this post


Link to post

I believe someone asked and this is what the terminal buildings look like over here. As far as I can tell they seem fine.

 

The main issue for lighting is the missing/very vague centerline lights not even close to what they look like IRL.

 

Night%20lighting%20at%20JustSim%20LFMN%2

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this