Sign in to follow this  
RW1

P3d Gsync users headsup..

Recommended Posts

So browsing the Nvidia forums today looking for any fix related to tearing with Gsync with the release of the new 373.06 driver i found this info that will help anyone using the 144hz refresh rate in P3d which will prevent tearing.

 

Quote "Setting Vsync to "on" in the NVCP, it stops tearing now. Nvidia have changed how Gsync worked by default a few driver versions ago...it used to automatically kick in at all times, so all you had to do was set the game vsync to "off", but now you need to enable Vsync for Gsync both in game and the NVCP for it to work as well, otherwise games will tear."

 

And i tested it today after a complete driver update using DDU and confirm this is now working again correctly. Sheesh i wish Nvidia would tell us about these changes when they implement them instead of 2 months of end users testing and finding the correct settings.

 

Cheers

  • Upvote 2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

So browsing the Nvidia forums today looking for any fix related to tearing with Gsync with the release of the new 373.06 driver i found this info that will help anyone using the 144hz refresh rate in P3d which will prevent tearing.

 

Well done Rick - on a whim I installed this new driver and turned on vsync in P3D global settings in NCP and of course I have it on in P3D - very nice even though I dont have a gsync monitor AA looks excellent - gotta luv 4k monitors

  • Upvote 1

Share this post


Link to post
Share on other sites

 

 


I was going nuts trying to figure this one out.

 

I hear yah... me too, capped my fps at 30.. unlimited... all the usual tweaks did nothing.. but yeah this seems to have cured it, running 4K, 144 hz and unlimited and 3.4 is smooth as and no tearing now. :smile:


 

 


gotta luv 4k monitors

 

I hear yah brother, i have to wait until after Xmas(Direct orders from my Commander in Chief) for a new 4K monitor, i heard a rumour ASUS are releasing a new G-sync 4k early 2017 so i can ditch the DSR and go hard core 4k.....

Share this post


Link to post
Share on other sites

I hear yah brother, i have to wait until after Xmas(Direct orders from my Commander in Chief) for a new 4K monitor, i heard a rumour ASUS are releasing a new G-sync 4k early 2017 so i can ditch the DSR and go hard core 4k.....

 

You will luv it guaranteed  :wink:

Share this post


Link to post
Share on other sites

 

 


So we need to have Gsync and Vsync ON in NCP?

 

Yes that`s correct and also in the Game, tick the vsync box in P3d also.

  • Upvote 1

Share this post


Link to post
Share on other sites

I have a weird problem in P3D 3.4

 

I just fresh installed it on my new system. Tested with no addons and all is good.

 

But now, if i opne P3D and start a flight FPS are 10-15. If i open another windows, like Task Manager, Chrome etc FPS increase to 60-70 (Aerosoft A320 and LEMG)...If i click in P3D window to use it FPS decrease back to 10-15. Any idea?

 

EDIT: Solved by a reboot.

Share this post


Link to post
Share on other sites

Tested the tip by the OP and it works very good. Now i have a pretty smooth 3.4 with payware airport and aircraft. Only see some minor stutters when panning to one side while flying, but i think is impossible to get rid of these in P3D?

Share this post


Link to post
Share on other sites

Rick,

 

Sorry but cannot see any tearing with G-Sync on at 144Hz, Vsync off in P3D and NCP.

Nvidia driver 373.06

 

Cheers,

Share this post


Link to post
Share on other sites

I have a weird problem in P3D 3.4

 

I just fresh installed it on my new system. Tested with no addons and all is good.

 

But now, if i opne P3D and start a flight FPS are 10-15. If i open another windows, like Task Manager, Chrome etc FPS increase to 60-70 (Aerosoft A320 and LEMG)...If i click in P3D window to use it FPS decrease back to 10-15. Any idea?

 

EDIT: Solved by a reboot.

Experienced same problem a couple of times since I updated to 3.4

With 373.06 driver problem seems solved, but not sure.

Also in my case, reboot solved the issue.

Never seen such weird behaviour in previous releases of P3D, but again, not sure if related to the sim itself. Any suggestion is very welcome.

Share this post


Link to post
Share on other sites

Quote "Setting Vsync to "on" in the NVCP, it stops tearing now. Nvidia have changed how Gsync worked by default a few driver versions ago...it used to automatically kick in at all times, so all you had to do was set the game vsync to "off", but now you need to enable Vsync for Gsync both in game and the NVCP for it to work as well, otherwise games will tear."

 

Ok, that's new. Thanks for the heads-up! Although I do not use G-Sync in P3D (as I am always around 30FPS, but never constantly above 30FPS), this is a good and useful tip for all my other games. Even though on a 144Hz monitor, tearing is extremely unlikely...

Share this post


Link to post
Share on other sites

I read now through several threads in the Geforce Forums and also asked this in the forum and I can not find it. Where did you get the information, that with the new drivers, you need to activate V-Sync ingame for G-Sync to work?

Share this post


Link to post
Share on other sites

I use AM=85, as I have a 3770K with HT on. But honestly, I do not see how there should be any connection between AM and G-Sync?

Share this post


Link to post
Share on other sites

I use AM=85, as I have a 3770K with HT on. But honestly, I do not see how there should be any connection between AM and G-Sync?

Yes...but i am testing my new rig on P3D 3.4 and trying to get it smooth.

 

I can't for now...I always have stutters but i don't know whats is the cause. 

 

I have NCP at 144hz, and for P3D Gsync, Vsync ON, Max power, Single Display... In game i have Vsync ON like the tip here but tested also without Vsync on.

 

Now i am testing Process Lasso, assigening Cores 0 to 5 to P3D and 6,7 to addons but i have stutters also... I think is impossible to have a smooth like butter P3D experience...

 

Seems that AM=85 and Gsync on and FPS unlimited gives me the best experience, but always note a bit of microstuttering

Share this post


Link to post
Share on other sites

I would not depend on G-Sync for P3D. In my case, with appropriate settings, I always have between 25 and 35FPS (I have the nVidia Inspector frame limiter set to 35FPS). As G-Sync only works above 30FPS, this resulted in a mess between G-Sync on and off for me, so I completely deactivated G-Sync for P3D. However, I do not have any stutters, something in your setup must be wrong then. Did you use the P3D guide available here on avsim?

Share this post


Link to post
Share on other sites

I would not depend on G-Sync for P3D. In my case, with appropriate settings, I always have between 25 and 35FPS (I have the nVidia Inspector frame limiter set to 35FPS). As G-Sync only works above 30FPS, this resulted in a mess between G-Sync on and off for me, so I completely deactivated G-Sync for P3D. However, I do not have any stutters, something in your setup must be wrong then. Did you use the P3D guide available here on avsim?

Will try to deactivate Gsync so...I can see it working very good with default aircraft and scenery at 100FPS but in payware no...

 

What options do you have configured in NvInspector? Vsync to Adaptive?

 

At the same setup, Vsync 1/2, Gsync off, 60hz, i have a solid 30FPS and smooth like butter X-Plane10...I think P3D will never run like this...

Share this post


Link to post
Share on other sites

As a matter of fact, I had to send my settings to a good friend yesterday evening, so you are lucky: here are my settings for the graphics preset called "VFR High", self explanatory, I only use it for VFR flights. For IFR flights with tubeliners, I have an "IFR medium" preset, where mostly autogen sliders are further back, LOD is reduced and shadows are only medium. NVI and nVidia driver settings remain the same for all profiles in my case. Here we go:

 

p3d_1_reduziert6bsyo.jpg

 

p3d_2_reduziertmqsa8.jpg

 

p3d_3_reduziertzzsm9.jpg

 

p3d_4_reduziertirs5n.jpg

 

p3d_5_reduziertfsswv.jpg

 

nvi_1n8scb.jpg

 

nvi_2f7shy.jpg

 

driver_1otskg.jpg

 

driver_25rs6e.jpg

Share this post


Link to post
Share on other sites

I thought you should only use NVI or NCP individually... not both at the same time as they fight each others settings and priority?

 

Just curious.

 

Thanks,

 

JD

Share this post


Link to post
Share on other sites

I thought you should only use NVI or NCP individually... not both at the same time as they fight each others settings and priority?

 

 

Not exactly.

They both change the video driver settings

but obviously NI gives access to more of those settings.

 

For the settings that are common to both

priority is just given to the last used app, ie either NVCP or NI,

So if you say turn off vsync in NVCP and then open NI you will see that it is off there too.

If you then turn it back on in NI and then open NVCP you will see vsync back on in NVCP.

 

gb.

Share this post


Link to post
Share on other sites

Good to know. If you're really not changing many settings NCP would be fine then, but like you mentioned, NI does have more settings to play with if desired.

 

Thanks,

 

Jd

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this