Sign in to follow this  
benibene12

Chaseplane keeps moving the camera / Bug create new camera (from Middle Mousewheel menu)

Recommended Posts

Hello

 

From time to time Chaseplane keeps moving the view. It won't stop until I have restarted the computer. Somehow it always starts whenever I move the camera by pressing the arrow keys on the keyboard. I do not use a gamepad. I think Chaseplane even triggers these commands in Windows as you can see in this Video that I took:

Another Problem that is not related to this Issue is, sometimes when I want to setup a new camera via the Middle Mousewheel selecter, it doesn't allow me to change the name of the new camera. The text isn't highlighted as usuall and when I try to click on it nothing happens. I am only able to click cancel/back and create a new camera via the chaseplane UI.

Both problems still happen in version 0.1.17 Alpha.

Edited by Jim Young
link to sendvid.com removed. I checked it out and it did not appear to contain malware but advised member to use YouTube instead.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Warning  do not open the link in the op   post

Thanks.  I have been in contact with the OP via separate correspondence and he stated the video he linked to did not contain malware or a virus and the video service (sendvid.com) states they screen all videos for malware/viruses.  Still, when I clicked on the link and then tried to start the video I got a popup from Verizon asking me to complete a survey about their service (I have Verizon FIOS).  I got a nag when I tried to close the survey without completing the survey but that's all.  Thanks for your concern though and bringing this to my immediate attention.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

I would like to apologize to everyone whom I have caused trouble. My intention has never been to spread malware or anything similiar. I was just too impatient to upload my proof videos to youtube and instead I googled and found that service to upload videos to without having to create an account. Nevertheless I still want to report the bugs I have found in order to get Chaseplane as quick as possible bug free.

Right now I am still fighting with the bug that chaseplane keeps triggering hotkeys. In the first video that is attached it shows chaseplane triggering the back arrow key on my keyboard. It also does this in the Windows UI as you can see by the automatic scrolling down of the taskmanager. Second video shows chaseplane hitting numpad 1 key which is assigned to my default cockpit view.

Both Videos are now uploaded to youtube

Video 1:


Video 2:

Share this post


Link to post
Share on other sites

Just popped in for my early afternoon "catchup" and find I can now view the vids.  Thanks. Regards.

 

M.

Share this post


Link to post
Share on other sites

Just popped in for my early afternoon "catchup" and find I can now view the vids.  Thanks. Regards.

 

M.

Was my fault, I uploaded the clips on youtube with wrong privacy settings. sorry for that.

 

Now to the bug, I have since found out that chaseplane not only triggers hotkeys but can also triggers various other keys on my keyboard. For instance I tried switching on the FPS counter in P3D and chaseplane triggered that in the same manner as in the videos. As I said, this will only stop if I reboot the computer. Closing chaseplane does not solve it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this