Sign in to follow this  
Keven Menard

[Explanations] WideViewAspect and Ideal zoom settings

Recommended Posts

We decided to make WideViewAspect=true mandatory while using ChasePlane to ensure everyone gets the same results regardless of display size. It also gives more options to the user as they can now zoom out to a very large point of view. This is sometimes required for Ultrawide monitors or multi-screen setups. This is not achievable if the flag is set to false.

 

There is a Youtube video made by Almost Aviation explaining what the ideal zoom (focal) setting is for your simulator and the mathematics behind between WideViewAspect true/false

 

 

Enjoy!

 

Keven

  • Upvote 2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Good stuff Keven. I was scratching my head about this in another post but it all makes sense now.

 

Regards,

Share this post


Link to post
Share on other sites

In the VC I always have my zoom set to 0.65 and this works well also with ChasePlane focal setting too.

Share this post


Link to post
Share on other sites

Hi Keven!

I'm hugely enjoying your great product! :-)

The appearance of my ChasePlane views initially was similar to that obtained by using a wide angle lens on a DSLR (I only fly 744s, which look extremely distorted and unrealistic in that presentation). After thinking about this, I checked out <username>AppData\Roaming\Microsoft\FSX\Cameras.cfg and found that three ChasePlane cameras had been added to the start of the file, all of which had their InitialZoom figures set to 0.4000333000. <gulp> Which would certainly account for the "wide angle" effect that I was seeing. 88-)

Using the formula in the second video to which you kindly directed us, I plugged in the figures for my setup and the answer came back that in my case a zoom factor of 1.5 was applicable. So I edited the camera.cfg file and simple-mindedly substituted 1.5000 as the InitialZoom figure in all three cases.

On starting FSX the distortion had completely gone (I had to move the viewpoint back a bit to compensate, obviously). :-)

So I'm not sure where that initial zoom fiigure of 0.4000333000 came from, but it certainly had the effect of making an aircraft the size of a 747-400 look very strange indeed! However, now that I have changed the InitialZoom figures for all three types of ChasePlane view I'm finding that new presets added seem to inherit the figure from the previous preset, so presumably the problem has gone away.

I just thought I'd mention it in case others had the same experience. :-)

(Incidentally, does the "Focal" camera control have any bearing on this? It didn't seem to have any effect when I tried it).

Cheers,

Brian

Share this post


Link to post
Share on other sites

(Incidentally, does the "Focal" camera control have any bearing on this? It didn't seem to have any effect when I tried it).

 

Actually yes, the zoom should be controlled by the focal slider and you should not be able to zoom using the controls assignments in the simulator.

While we find a solution for this, make sure you enable the "Disable Smooth Zoom and Static Mode" in the Preferences.

Share this post


Link to post
Share on other sites

Ah — thank you, that's very helpful.

 

I wasn't using the zoom controls in FSX, though, I rather naughtily edited the file directly (whilst FSX wasn't running).  <*cough*>   8-º

 

> "...make sure you enable the "Disable Smooth Zoom and Static Mode" in the Preferences"

 

Roger, Wilco, and all that jazz.   :-)

 

Many thanks,

 

Brian

Share this post


Link to post
Share on other sites

Great video. What it doesn't explain is how important the physical size of your display is - not just the ratio of it. Getting a true sense of scale and speed on a tiny 27" monitor is impossible. It will always feel like flying in a micro world. For anyone who hasn't tried it yet, try hooking up your livingroom LCD TV and feel the difference. The closer you get to 1:1 scale, the more real it gets. Ideally one should use a projector, but most simmers will not have room for it. I get by using a 65" at the moment. Having instruments that are close to 1:1 in scale makes them so much easier to read, and the size of the buildings at the airport really comes to life when you taxi by them. Even the height from the cockpit down to the ground feels a lot more real when switching from a 737 to a 747.  

Share this post


Link to post
Share on other sites

In cinematic view, there was a noticeable slight twitching of the aircraft, which looked almost as though some random turblence effect (head movement? engines?) was creeping in. That effect in cinematic mode has also been remarked upon by a fellow Admin at my VA, so I thought it might be worthwhile mentioning it to you.

 

What prompted me to do so now is that, further to your suggestion to disable Smooth Zoom and Static Mode, having done that I found that the twitching effect in cinematic mode was gone (although some shaking of the ground still occurs, but since it only happens in low views as the camera moves upwards I think that's probably a different problem?). 

 

Cheers,

 

Brian

Share this post


Link to post
Share on other sites

...Getting a true sense of scale and speed on a tiny 27" monitor is impossible. It will always feel like flying in a micro world.

...I get by using a 65" at the moment. ...

 

I've heard it all now: A 'tiny' 27" monitor and to 'get by' with a 65" display. I entirely agree with your sentiment, just couldn't help but laugh at the word choice. I still consider my 24" display to be big after years of CRT monitors, but for simming I would love something larger of course. Maybe one day.

 

Back to topic, pre-Chaseplane (with no other camera add-ons) I always used a default zoom of 0.7 with wideaspect=true. Any less would feel too 'fisheye' and I'd struggle to land as the runway ahead would be tiny. If the aircraft cockpit allows, I zoom in to 0.8 or 0.9 as I find it more realistic (if a little 'blinkered'). GA aircraft are usually OK, but for airliners you're often forced to use a wider view to get the displays in as well as the view out of the window, especially if the HSI/navigation display is below the PFD. This is all on a 24" display at a physical distance of about 2.5ft.

 

In my cameras.cfg, Chaseplane also set the default zoom to 0.4000333000 but so far the camera seems fine when I load up a new aircraft. The only thing I've noticed is the default downward-tilted view, which I don't like. A topic for another thread though...

Share this post


Link to post
Share on other sites

I've heard it all now: A 'tiny' 27" monitor and to 'get by' with a 65" display. I entirely agree with your sentiment, just couldn't help but laugh at the word choice. I still consider my 24" display to be big after years of CRT monitors, but for simming I would love something larger of course. Maybe one day..

My 65" TV cost 1/3 of my 27" Monitor... Lets face it. Monitors are becoming tiny compared to the standard TV sizes these days, and the cost is shockingly low. My 65" cost a lot less than my first 25" that I bought in the early 1990s, and then I havent taken into account inflation.

Share this post


Link to post
Share on other sites

In understand the goal and meaning of this, but on my setup with several very demanding VFR sceneries, the "Wide view" option is performance killer, and I'm unable to fly with it.

 

So Is it possible in the near future that you add an option to leave it untouched please?

 

Thanks

  • Upvote 1

Share this post


Link to post
Share on other sites

In understand the goal and meaning of this, but on my setup with several very demanding VFR sceneries, the "Wide view" option is performance killer, and I'm unable to fly with it.

 

have you tried zooming in to a similar level as you were previously?

Share this post


Link to post
Share on other sites

Yes I did: at 0.7 which seems visually equivalent to the 0.3 w/o Wide view (with screen setup), but actually it don't have the same effect on scenery performance load.

 

I'm running P3D and spend lot of time to understand the behaviour while using Wide view aspect: it appears that the disk radius in which the scenery objects are loaded in the sim (around the aircraft position) is roughly twice. So the scenery surface (proportionnal to square of the radius) to load and display is now 4 times the initial value.

 

Even more in P3D v3, if you zoom in, then it loads and display more far scenery objects.

  • Upvote 1

Share this post


Link to post
Share on other sites

 

 


Great video. What it doesn't explain is how important the physical size of your display is - not just the ratio of it. Getting a true sense of scale and speed on a tiny 27" monitor is impossible. It will always feel like flying in a micro world. For anyone who hasn't tried it yet, try hooking up your livingroom LCD TV and feel the difference. The closer you get to 1:1 scale, the more real it gets.

 

Nice explanation This has been my experience as well, whether using x3 23 inch monitors in NVIDIA Surround but especially with a 55 inch Samsung 4k TV.  Of course my performance was better with the 55 inch over x3 23 inch monitors in surround.

 

 

 


I'm running P3D and spend lot of time to understand the behaviour while using Wide view aspect: it appears that the disk radius in which the scenery objects are loaded in the sim (around the aircraft position) is roughly twice. So the scenery surface (proportionnal to square of the radius) to load and display is now 4 times the initial value.

 

Roland,

 

Thank you for this information/observation. I suspected something similar for some time, but have never had the time to investigate this.  I'm looking forward to trying to follow up on this and possibly get some hard data on this in the next week, as I have some time off from regular flight sim testing and what not.  Thanks again for the info!

Share this post


Link to post
Share on other sites

Hello.

I like chaseplane really.

But is it possible to deactivate the overwriting of my cfg.?

I don't like the wide vie aspect. Normaly i fly with a zoom of 0.4.-0.6.

When i zoom in to 0.8 (for wide view aspect, i have to do this, to avoid the fisheye-effect),

the world looks blurry. In normal aspect with zoom 0.4 the world looks sharp like a razorblade. Please let me decide by myself, if i will fly with wideview or without wideview.

 

Kind regards,

Stefan Muehlemann

Share this post


Link to post
Share on other sites

We are working on an alternative to this requirement but there is no way to remove this requirement right now.

  • Upvote 1

Share this post


Link to post
Share on other sites

I have tried both: Wide view and normal view, and it seems that chase plane works in both setting very well. Since there is documented perfomance hit when using wide view, I use normal view at zoom level 0.3 - using a 55 inch TV at 4K - and just override the chase plane setting in the P3D profile. The only annoying thing is the message each time I start Chase plane...but as Keven mentioned above, he is working on that.

Share this post


Link to post
Share on other sites

I'm having an issue in that I'm not able to adjust the zoom at all, so I'm stuck at 0.4, which doesn't look good with wide-aspect. Don't really know what to do about that. I'm using version 0.1.97 by the way. Besides that it works great.

Share this post


Link to post
Share on other sites

I have tried both: Wide view and normal view, and it seems that chase plane works in both setting very well. Since there is documented perfomance hit when using wide view, I use normal view at zoom level 0.3 - using a 55 inch TV at 4K - and just override the chase plane setting in the P3D profile. The only annoying thing is the message each time I start Chase plane...but as Keven mentioned above, he is working on that.

Same here, I prefer Wide View disabled and it works fine. And I agree that the user should be able to decide what he/she prefers. So far, ChasePlane has been a great investment.

Share this post


Link to post
Share on other sites

I use Three screens, simple reality is that Wide Aspect -True causes screen stretching on the side monitors, but it is resolved with Wide Aspect - False, but less vertical view is the compromise

 

Now developing a program to resolve this and FSFX would make a fortune as it's constantly on the forums as a major issue with multiple screens which are now generally everywhere.

 

Anthony

Share this post


Link to post
Share on other sites

Hi .. how I can disable WideViewAspect ?

 

  1. Zooming it
  2. Disabling it from the Menus in P3D or in the CFG file for FSX

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this