Sign in to follow this  
lopentan

All planes drifting right any solution?

Recommended Posts

I have a new problem detect in P3D all planes ( dedault and payware) drifting to right on runways to take off and on air too.

 

-SAtiket pro yoke and rudder ( same problem)

-thrustmaster t.flight hotas x ( Same problem)

-Only keyborad (Same problem)

- Whather no wind and clear (Same problem)

- desactive all axes (Same problem)

- Autorudder on/off (Same problem)

-More dead zone (Same problem)

-All devices calibrates in windows and in prepar3d calibration (Same problem)

-Fsuipc calibration (Same problem)

-Fsuipc disabe (Same problem)

-deleting al axes (Same problem)

-Realism change to easy  (Same problem)

 

The big problem in in air becasue the planes turn a lot to the right and in VFR y have to do many corrections because i dont use Auto Pilot

 

Anyone can help me to this problem?

Sorry for my english and thanks a lot.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

 

 


-Realism change to easy  (Same problem)

 

Sorry, I obviously missed the above.

Apologise for the answer.

 

Cheers,

Share this post


Link to post

Can you record 2 or 3 movies showing this issue on various aircrafts? I find it hard to believe that it's not flight model nor hardware related. Anyway - would help to see how serious the problem actually is. If it is not engine thrust difference, brake lock difference, poor calibration, hardware issue, sh#$%# flight model, then last thing which comes to mind is delete P3D CFG and let it rebuild.

 

Also, what addons do you have installed? Did you try vanilla sim?

Share this post


Link to post

Can you record 2 or 3 movies showing this issue on various aircrafts? I find it hard to believe that it's not flight model nor hardware related. Anyway - would help to see how serious the problem actually is. If it is not engine thrust difference, brake lock difference, poor calibration, hardware issue, sh#$%# flight model, then last thing which comes to mind is delete P3D CFG and let it rebuild.

 

Also, what addons do you have installed? Did you try vanilla sim?

Im not try a vanilla sim, because i know that peple has this issue before.

Calobration is Ok in both yoke and Joistick in sim and in windows, i use for other sims and works fine.

My joistick and Yoke use only one for both engines.

 

i can try delete ped.cfg but im sure will be as now.

Share this post


Link to post

 

 


i can try delete ped.cfg but im sure will be as now.

 

Don't delete it. Just rename it as prepar3d.cfg.original. That will allow you to look at which settings that you changed from default and maybe you can determine what is wrong. P3d will then rebuild the file and  the sim will start with the default scenario and default aircraft. If that aircraft pulls to the right, then you've really got something wrong with the P3d installation.

Share this post


Link to post

Don't delete it. Just rename it as prepar3d.cfg.original. That will allow you to look at which settings that you changed from default and maybe you can determine what is wrong. P3d will then rebuild the file and  the sim will start with the default scenario and default aircraft. If that aircraft pulls to the right, then you've really got something wrong with the P3d installation.

That was my idea, thanks a lot.

I test with a new P3D.cgf with no joke only keyboard in the default scenery and aircraft, and same result, drifting to the right. :nea:

Share this post


Link to post

I use to have that problem. I now use just fsuipc and turn off controllers in P3d. It was a pain when it did happened and I just about gave it all up. I did find if I went into the registry under controllers and deleted some of the entry's all went back to normal this was for only Saitek controllers. Here is the instructions for that process   Josh

 

Calibration Fix
 

If you are finding that the axes on your controller are not travelling through their full range of movement and/or are not centering correctly then try these fixes. The first fix deals specifically with Flight Sim. The second fix deals directly with the controller in Windows and should resolve any issues detected in Control Panel > Game Controllers > Properties.




To recalibrate in Windows, first remove the USB plug for your controller from the PC.

Press and hold the Windows key on your keyboard and then press the letter R. This will open the Run box. Type regedit and then click ok.

The Registry Editor will have a list of folders on the left hand side. Go down into the following folders in order by clicking the + next to the folder name.

+HKEY_LOCAL_MACHINE (CURRENT_USER if on Vista)
+System
+CurrentControlSet
+Control
+Media Properties
+Private Properties
+Direct Input

Delete any folder inside the Direct Input folder that begins VID_06A3.

Once deleted, close the editor, then plug the USB back into the original port. Move all the axes of the controller through their full range of movement four times.

Now go to Control Panel > Game Controllers > Properties to check the axes on the test screen. If the issue persists then test the controller on another PC to see if the issue is replicated. If it is replicated then it is most likely a fault with the controller which will need to be replaced if it is still within warranty.
 

Share this post


Link to post

I use to have that problem. I now use just fsuipc and turn off controllers in P3d. It was a pain when it did happened and I just about gave it all up. I did find if I went into the registry under controllers and deleted some of the entry's all went back to normal this was for only Saitek controllers. Here is the instructions for that process   Josh

 

Calibration Fix

 

 

If you are finding that the axes on your controller are not travelling through their full range of movement and/or are not centering correctly then try these fixes. The first fix deals specifically with Flight Sim. The second fix deals directly with the controller in Windows and should resolve any issues detected in Control Panel > Game Controllers > Properties.

 

 

 

 

To recalibrate in Windows, first remove the USB plug for your controller from the PC.

 

Press and hold the Windows key on your keyboard and then press the letter R. This will open the Run box. Type regedit and then click ok.

 

The Registry Editor will have a list of folders on the left hand side. Go down into the following folders in order by clicking the + next to the folder name.

 

+HKEY_LOCAL_MACHINE (CURRENT_USER if on Vista)

+System

+CurrentControlSet

+Control

+Media Properties

+Private Properties

+Direct Input

 

Delete any folder inside the Direct Input folder that begins VID_06A3.

 

Once deleted, close the editor, then plug the USB back into the original port. Move all the axes of the controller through their full range of movement four times.

 

Now go to Control Panel > Game Controllers > Properties to check the axes on the test screen. If the issue persists then test the controller on another PC to see if the issue is replicated. If it is replicated then it is most likely a fault with the controller which will need to be replaced if it is still within warranty.

 

Thanks a lot but i tested only with keyb no joke or joistick and same result. Default sacenery, default aircraft.

I used FSUIPC too and same result, i delete all axes with FSUIPC

I use to have that problem. I now use just fsuipc and turn off controllers in P3d. It was a pain when it did happened and I just about gave it all up. I did find if I went into the registry under controllers and deleted some of the entry's all went back to normal this was for only Saitek controllers. Here is the instructions for that process   Josh

 

Calibration Fix

 

 

If you are finding that the axes on your controller are not travelling through their full range of movement and/or are not centering correctly then try these fixes. The first fix deals specifically with Flight Sim. The second fix deals directly with the controller in Windows and should resolve any issues detected in Control Panel > Game Controllers > Properties.

 

 

 

 

To recalibrate in Windows, first remove the USB plug for your controller from the PC.

 

Press and hold the Windows key on your keyboard and then press the letter R. This will open the Run box. Type regedit and then click ok.

 

The Registry Editor will have a list of folders on the left hand side. Go down into the following folders in order by clicking the + next to the folder name.

 

+HKEY_LOCAL_MACHINE (CURRENT_USER if on Vista)

+System

+CurrentControlSet

+Control

+Media Properties

+Private Properties

+Direct Input

 

Delete any folder inside the Direct Input folder that begins VID_06A3.

 

Once deleted, close the editor, then plug the USB back into the original port. Move all the axes of the controller through their full range of movement four times.

 

Now go to Control Panel > Game Controllers > Properties to check the axes on the test screen. If the issue persists then test the controller on another PC to see if the issue is replicated. If it is replicated then it is most likely a fault with the controller which will need to be replaced if it is still within warranty.

 

I will try this solotion too but i not have +Direct Input into private Properties

Share this post


Link to post

I also found a fresh install always fixed my issues. It sure would be nice if there was a easy answer.  Josh

Share this post


Link to post

Its work fine now i delete the planes profiles in FSUIPC.INI and reasign all axes and works fine in hotas, now i will try in my Saitek hotas and rudder.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this