Pineapple_Wizard

[Explanations] Sound Issue with Majestic Q400

Recommended Posts

So here's quite an odd issue. Whilst using chaseplane views, the external sounds, especially the engine and APU sounds of the Q400 are really quiet. However, once I switch to the FSX spot view, the exterior sounds go back to normal. I'm not sure if this an issue on the Q400s side of things as it works perfectly fine until I start up chaseplane. 

Any help would be immensely appreciated as I am a huge fan of both the Q400 and chaseplane and it really breaks the immersion with the quiet sounds.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I just checked the version number of the Q400 and there was a patch I needed to download that supposedly fixes this issue. I'll delete this topic if it does. 

Share this post


Link to post
Share on other sites

I'm getting external sounds with the Dash-8, but some of the other planes are not giving me sounds. Do you have external sounds on all your planes when things are

working normally?

Share this post


Link to post
Share on other sites

So after talking with Majestic, they found it's a chaseplane issue, as the sounds work perfectly fine when chaseplane isn't running. The first version of ezdok had the issue as well, however ezdok v2 fixed that issue in P3D. So hopefully we get some word from the guys at fsfx about this.

Share this post


Link to post
Share on other sites

Running v4.1 with the Q400 and it loses the sound when switching between inside and outside views. Clicking the mouse on the screen resumes proper volume.

Share this post


Link to post
Share on other sites

Same issue here, but not limited to Dash8, also happens with PMDG 737 NGX.  Its like the sound 'loses focus' then requires a click to return to normal. 

 

Share this post


Link to post
Share on other sites

I can confirm the Dash sound problem and it is isolated to CP.

Switching views in the normal way works.

 

The NGX sound has nothing to do with CP, that is since day one. 747 and 777 are coded in a different way and do not lose certain sounds. But has nothing to do with CP.

 

With the A2A L049 I do not have any problems. Also not with any other addon I have.

Share this post


Link to post
Share on other sites

With the pmdg. When switching views you can have sound issues or not! If then, push the Q button twice on your keyboard!

Share this post


Link to post
Share on other sites

Alright, let's tackle this one. ChasePlane works the same way across all aircraft. We use documented or proven ways of achieving what we want to do in the sim. We try to stay out of coding specific fixes for specific aircraft because we try to stay as close as the SDK as possible.

Because Chaseplane works the same with all aircraft, we started searching in what way the Majestic Q400 is different from other aircraft.

Now, we have tested a few things, found 2 issues and arrived to the following observations and conclusions:

 

Muffled sounds

From the test we have made, sounds will be muffled when watching the aircraft from the outside using ChasePlane views..

  1. We use the Aircraft category in the camera definitions to store our Outside and Gimbal cameras.
  2. Majestic are using the Aircraft category as well to store 4 camera views that are window views from the cabin.
  3. Majestic arranged their sounds system to muffle cameras that are in the "Aircraft" category regardless of where the camera is located, resulting in the issue we are observing.
  4. What we're doing about it: Beta 0.4.0 will see those views removed from the Aircraft category and placed in the Outside section. It doesn't change much for us right now, I really hope other developers won't mess with the Outside category...

 

Missing sounds

From the test we have made, in some situations, sounds will be muted when you come back in the cockpit from an outside view while using ChasePlane.

  1. We have tested v0.3.69, v0.3.166 and v0.4.0 against the aircraft
  2. When ChasePlane is not running, changing between views is not a problem. The sounds remain audible as they should and everyone can go about their day.
  3. When ChasePlane is running, changing views from an outside (non-static) view to inside the cockpit will mute some of the sounds produced by the aircraft.
  4. The sounds that are muted are handled by a custom aircraft gauge while sounds handled by the simulator (not the aircraft) remain audible (like rain, wind, thunder and part of the engine sounds).
  5. To change view, ChasePlane sends a very simple command to the simulator (VIEW_CAMERA_SELECT_1,5,6 and 8). This command is provided by the FSX/P3D SDK and has been around forever. In the FSX SDK, it is the only way to change the camera view from outside the sim.
  6. To the simulator, the only different between ChasePlane running or not is the fact that we ask the simulator to send us data when the aircraft moves in order to calculate motion effects and for our upcoming Instant Replay system.
  7. v0.4.0 uses a new technique that goes around the SDK to send camera positions. This removes the possibility of SimConnect being overwhelmed by requests.
  8. We are continuing to research the issue but I fear this ball is not falling into our camp this time. This is the only aircraft with this issue.

 

If anyone has some theories about why the missing sound occurs, I am open to test new things and come up with solutions.

Best Regards,
Keven

 

  • Upvote 2

Share this post


Link to post
Share on other sites

Hi, I'm really a newbie both to ChasePlane and to the q400pro. I recently bought both. There is another element that happens when switching views and flying with the q400: If I first enter the plane or switch from outside view, I get a normal cockpit sound. Ie some background noise, but not like you're standing outside. If I however click on the FMS or something in the cockpit, I will get what appears to be external sound, ie lot of engine noise and airstream noise. If I switch to outside view, it will be _almost_ quiet (very distant engine sound), and switching back to PIC position, I will get the normal low noise cockpit situation. If I then press one of the buttons again, I will get the external sound again. This was not like this before 0.4 beta. Before there used to be this error where you had to click inside the cockpit to get the proper sound after switching views. Not really a big issue.

Share this post


Link to post
Share on other sites
On 11/27/2017 at 1:51 PM, Carlos Pancorbo said:

Majestic has released an update that seems to fix this problem. This can be downloaded in their page in the user area

Works perfectly. Thanks for the info.

Share this post


Link to post
Share on other sites

Latest Chaseplane patch and Majestic Dash version.

The sound via the Majestic views is normal. With CP it is still quit but perceptible. Like it was before. For me not the big problem. The bigger one are the square contrails(FSX)..you know Keven:ampun:

 

Max

Share this post


Link to post
Share on other sites

Well I have latest patches for everything and Chaseplane has completely knackered my Dash 8 sounds - stutters, crackles and pops... inside and outside.

Even shutting down Chaseplane doesn't stop it happening. As it's completely modified the Cameras.cfg file, I will have to use Simstarter to replace the original pre-Chaseplane cameras file whenever I use the Dash, so I can at least fly the Dash 8 normally with default cameras - hopefully this will work !!!

 

When Chaseplane is installed, is a copy of the original cameras.cfg file made anywhere ? I cannot see one, so will have to rely on my own backup folders.

Is it just the cameras.cfg and the Dash 8 aircraft.cfg files that are changed by Chaseplane ?

 

EDIT: disabled Chaseplane, and replaced original Dash 8 aircraft.cfg file, and the cameras.cfg file, but the sound is still broken … why is this and how do I fix it ?

 

Thnx

 

 

Edited by Gabe777

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now