BrianT

LOD issue....I think?

Recommended Posts

Hi all, 

be gentle now! I'm new to p3d and the QOTS but have been FSX'ing for what seems like century's. I have an i7 6400 running at 4.5 and 32gb of Memory. Graphics is an MSI 980ti. running 382.53  WHQL

Software running is P3dv4 and I have the ORBX suite of Global and LC as well as all the regions. I also have Pilots Global ultimate next gen mesh.

Sitting on the tarmac at EGKK all looks good out of the window and as you can see from the first screen shot all looks good from outside as well and I have a reasonable frame rate with no stutters. After about 15 - 20 minutes of flying however the view out of the window becomes less pleasing (2nd screenshot) with the ground detail disappearing altogether by the time I get to EGPH.

I did also try this with a flight from KDEN to KLAS and had exactly the same problem

If anybody can point me to where my detail is going I'd be grateful

 

TIA

Brian

2017-06-17_zpsyvwajwkc.png

2017-06-17%201_zpsczbwkznv.png

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi,

i had that problem today too, don´t know where that came from. But deleting the Prepar3d.cfg file solved it for me. 

 

Regards

 

Felix

 

Share this post


Link to post

Would you happen to have added any Affinity Mask settings that stops the sim from using the first core?

Share this post


Link to post

I have yes I read somewhere on here for a 4

2 minutes ago, Sethos1988 said:

Would you happen to have added any Affinity Mask settings that stops the sim from using the first core?

core with HT on I should set it to 116...... bad advice?

Share this post


Link to post

Do you run any AI-Traffic?

 

And yes, don't tinker with the cfg. This is P3D it runs best without any manual tinkering in the cfg.

Share this post


Link to post
Just now, BrianT said:

I have yes I read somewhere on here for a 4

core with HT on I should set it to 116...... bad advice?

I believe 116 means you remove all rendering from the first core, both the physical and logical. While many of the technical wiz posters seem to advocate for that, I highly suggest you don't do that. I've found the second I don't use my primary core, I get the exact same problem as your screenshot. It stops rendering the terrain for some reason and suddenly, the terrain just turns to complete blur and just gets progressively worse. So while that first core might be used by other processes in Windows, I have very bad personal experience removing the sim's processing from it. 

I assume you have a 4 core with HT? Then I'd look at something like 253 instead. That uses all your cores except the first logical core, which the main process doesn't utilise properly anyways I've found. Then you can move all your addon's affinity off to core 3 to 8, leave 1 and 2 alone. 

Just my humble suggestion. Could also remove the "[JOBSCHEDULER]" section completely and let the sim use all your cores. 

  • Upvote 1

Share this post


Link to post
1 minute ago, Sethos1988 said:

Just my humble suggestion. Could also remove the "[JOBSCHEDULER]" section completely and let the sim use all your cores. 

Trying that now :)

 

2 minutes ago, Farlis said:

Do you run any AI-Traffic?

 

And yes, don't tinker with the cfg. This is P3D it runs best without any manual tinkering in the cfg.

I am running AI (UT Live) forgot to mention that in OP. If Michael's suggestion doesn't fix it I'll drop the AI next and see what happens. I've got the flight saved so I can recreate the same settings each time

Share this post


Link to post
Just now, BrianT said:

Trying that now :)

 

I am running AI (UT Live) forgot to mention that in OP. If Michael's suggestion doesn't fix it I'll drop the AI next and see what happens. I've got the flight saved so I can recreate the same settings each time

Hm.. UT runs outside the usual AI-Routines, so that should not be a problem.

I noticed that sometimes the AI-Routine can get stuck during reloading. It seemingly reloads when you reset your time for example, but then the terrain stops refreshing. When you then try to refresh the scenery via the command the reloading stops at 22% and you have to restart the sim.

Share this post


Link to post

Well so far so good, losing the "[JOBSCHEDULER]" section (it only had affinity mask in it anyway) seems to have resolved that issue but now I have the micro stutters. grrrr :angry: that I can almost live with. As I said in the OP this sim is all new to me so it's almost like going back to school :biggrin:

Share this post


Link to post

You microstutters are most likely from the fact that your terrain and autogen are now actually rendering. Before, none of it rendered properly thus it would feel smoother. So it's a bit of a crummy performance boost :P 

As I mentioned, you could try;

[JOBSCHEDULER]
AffinityMask=253

I've personally found that removing the first logical thread from the equation, even if the sim isn't using it, does make the experience smoother. There's something about that first logical, like the sim is trying to use it but can't. However that could just be subjective or placebo. In any case, that core isn't utilised so there's no harm in disabling it. 

Share this post


Link to post

 

5 minutes ago, Sethos1988 said:

As I mentioned, you could try;

[JOBSCHEDULER]
AffinityMask=253

Thanks I'll give it a try. As I said it's early days and so a bit of experimentation is in order. Currently looking at my cpu usage and core 1 is at 100% with the other 7 at anything from 60% to 100%

but more importantly the view out of the window is superb!

Share this post


Link to post

253 is what I use as well and I may have even started (a couple of days ago) being of seeing Michael lobby for it.

I saved a test flight of the PMDG777 flying at about 4000 feet over the new KMSP in cloudy conditions at about 220 knots or so. I must have run this dumb test flight at least 3 dozen times and finally sought to find out if AM made any difference. For the longest time I've just turned HT off but in P3Dv4 I've noticed that scenery and terrain paging (as you've noticed as well) and autogen will start to suffer. Speaking of the latter, keep your autogen draw distance in check. It's one of the few settings I've learned to moderate. I use 15500 which is a custom setting in between P3D's "medium" and "high" (it's still plenty high and unless you're flying in unlimited visibility, you likely won't see the "autogen line").

Anyway, I find that HT off and AMs that turn off cores seem to yield better CPU-bound performance (as my test scenario showed) but at the expense of the aforementioned. So the point of my test scenario was to find a balance between performance and scenery paging and I think I did that. HT on with no AM seems to give the best scenery and terrain paging and my test flight showed that at a certain point of rendering KMSP, some ground textures and redrawing autogen past the airport, the terrain cores would max out no matter what the setting. It was my goal to find the AM setting that not only yielded the best FPS but also limited the "terrain core max throughput time" (I can explain how I measure this... it's super scientific).

And like others have said, don't jack your CFG file too much. The only setting/tweak that I've applied that isn't in the P3D GUI is the AM and the custom draw distance (the latter isn't really a tweak so much as getting a draw distance that the GUI doesn't allow you to select).

  • Upvote 1

Share this post


Link to post
2 minutes ago, garrett_frank said:

253 is what I use as well and I may have even started (a couple of days ago) being of seeing Michael lobby for it.

I saved a test flight of the PMDG777 flying at about 4000 feet over the new KMSP in cloudy conditions at about 220 knots or so. I must have run this dumb test flight at least 3 dozen times and finally sought to find out if AM made any difference. For the longest time I've just turned HT off but in P3Dv4 I've noticed that scenery and terrain paging (as you've noticed as well) and autogen will start to suffer. Speaking of the latter, keep your autogen draw distance in check. It's one of the few settings I've learned to moderate. I use 15500 which is a custom setting in between P3D's "medium" and "high".

Anyway, I find that HT off and AMs that turn off cores seem to yield better CPU-bound performance (as my test scenario showed) but at the expense of the aforementioned. So the point of my test scenario was to find a balance between performance and scenery paging and I think I did that. HT on with no AM seems to give the best scenery and terrain paging and my test flight showed that at a certain point of rendering KMSP, some ground textures and redrawing autogen past the airport, the terrain cores would max out no matter what the setting. It was my goal to find the AM setting that not only yielded the best FPS but also limited the "terrain core max throughput time" (I can explain how I measure this... it's super scientific).

And like others have said, don't jack your CFG file too much. The only setting/tweak that I've applied that isn't in the P3D GUI is the AM and the custom draw distance (the latter isn't really a tweak so much as getting a draw distance that the GUI doesn't allow you to select).

Thanks for the detailed explanation! The AM was the only "tweak" I had in the config so I'll try the 253 next and see how that goes.

Autogen draw is 1 down from Max on mine (V.High)

Share this post


Link to post
2 minutes ago, BrianT said:

Autogen draw is 1 down from Max on mine (V.High)

Lower it. I know, it sucks.

I'm using a 6700K at 4.7Ghz with 3333Mhz RAM at CAS14 but with no AI (even if the AI program runs outside the simulator and injects models into the sim, the sim is still rendering the polygons and calculating their paths and such). And I found I needed to dial the draw distance down.

[SCENERY]

AUTOGEN_DRAW_DISTANCE=15500.000000

  • Upvote 1

Share this post


Link to post

Hi,

I have that same experience and have been investigated this issue for some days. I come to the conclusion that this causes  by the AM  tweek setting. When enable AM i have rock steady 30 FPS, but the ground texture looks terrible.

I'm running I7-3930 @3.20 clocked to 4700 with HT on. Still haven't found any AM that works for my system.
Remove AF in p3d.cfg and see if you back to normal. 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now