Sign in to follow this  
sidfadc

Weird shadow problem in P3Dv4

Recommended Posts

Take a look at this, I use ezdok 2.0 for my camera controls.  Everytime I hold middle mouse and pan the view the cloud shadows draw/disappear at the same time? 

Any ideas?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I'm going to shamelessly barge in without helping because I don't know the answer to your question and I apologize, but I just wanted to ask about the dark blue top part of the sky, should it look round like this? I always wonder about this and meant to ask before.

Share this post


Link to post

Shadow display distance is causing it, as I use medium setting I have the same "issue"

 

Rado

Share this post


Link to post
55 minutes ago, radorabatin said:

Shadow display distance is causing it, as I use medium setting I have the same "issue"

 

Rado

Indeed, this is typical for low or medium shadow draw distance.

If set to High (not Ultra) and your weather program handles the weather, then the haze will mask this shadow draw border.

Share this post


Link to post

cheers fella I'll give that a go.  I do have it on medium, is there a big performance penalty going to high or ultra?  Either way I'll give it a go.

Share this post


Link to post

Depends on what other shadow options you have enabled and where you're flying. Big US metropoles or medium sized European capitals.

I fly only in the EU, and medium to high did not have signicant fps impact. I do not cast building shadows. All the other stuff I cast and the shadow quality is set to medium.

But as they say.... your mileage may vary... ;)

Share this post


Link to post

Changing shadow draw to high resolved the problem thanks.

Share this post


Link to post

Do you guys know what impact shadows have on CPU usage?

Share this post


Link to post

i don't monitor GPU/CPU usage. When I notice that the sim is struggling, I temporarly lower some settings like shadows.

Share this post


Link to post
4 hours ago, Piotr007 said:

Do you guys know what impact shadows have on CPU usage?

I would run P3D on your system with the shadows turned on to the max.  Check the FPS and/or set up FSUIPC to log your flights and check the avg fps usage during the flight.  Now, start the same flight with the shadows turned off and check the FPS and/or set up FSUIPC like I suggested before.  For me there is a major hit on performance and FPS but my system can handle it without any stuttering, blurriness, or other anomalies.  Still I keep the settings low. 

On your system, the hit may be greater depending on your other settings and addon's you have enabled and loaded. 

Share this post


Link to post

I have found that shadows are a huge hit to FPS, especially shadow Cast. With my gtx 670, I was only able to run aircraft cast and receive shadows, as cloud shadows pummeled my system. I recently upgraded to a 1080ti and now am able to enjoy shadows in all their glory. At first I ran all shadows to cast and receive, and although the system was able to handle it, the FPS would dip to the low 20s on takeoff roll and climb out in the VC. So I played around with the settings, and I unchecked vegetation and building shadows cast, and have them only receiving. That alone saved me 10 fps in external view, and 5 in the VC. If I also uncheck receive for building and vegetation, it only saved me 1 frame or so. And it looks weird having overcast conditions and the trees and buildings look like they are in the sunlight but everything else is under cloud shadow, so that 1 frame is worth having those objects receive shadows. 

Share this post


Link to post

I installed P3Dv4 yesterday and have the same issue.

I have shadow draw distance set to max.

whathever shadow quality I use i get the disappearing shadows when rotation the view, inside the cockpit and in external view.

I tried with as16 for v4  and without, same issue.

Any ideas ? 

Share this post


Link to post

I thinh there is no solution right now. Its a common issue coming from P3D v2. We have to wait if LM have any solution in further versions.

Regards,

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this