Sign in to follow this  
buzzard2008

Stuttering in Xplane 11 ruining my experience :(

Recommended Posts

Heya guys just wondering if anyone has had bad micro stuttering in Xplane 11 and fixed it? If so what did you do, Ive tried lowering my sliders and messed around with different Vsync settings between Nvidia Control panel and in game, have even swithched all Vsync off in both and played in offline mode. It comes right every now and then, then it just goes back to stuttering, especially on the runway taking off its driving me balmy because its such a great looking sim but the stutters are ruining it for me. Ive been dogged by this with FSX and Prepar3d and I cant believe Im still gettin it on a 64bit game. My specs are i7 7770 GTX1050Ti 4GB and 8 GB of ddr4 ram, any help would be much appreciated. If I cant fix this I will go back to Aerofly FS2 where I,m getting around 250-300 FPS whenever and wherever I fly with awesome graphics, cant beat that lol, its a shame because Xplane is so alive with moving traffic n all, bummer man

Andy

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you tried disabling all AI traffic to see if it's the culprit?

Share this post


Link to post
Share on other sites

I think your graphics card and ram are borderline for a good experience in X-Plane 11.

Share this post


Link to post
Share on other sites

Yep, try disabling AI traffic has advised above, and turn off shadows on scenery.

Also, what is your monitor resolution?

If you're still getting stutters, it might be that you're right at the minimum spec for system RAM (8GB). The recommended spec is 16-24 GB of RAM or more.

Your video card VRAM might be borderline, but I'm running a GTX970 with even less VRAM (only 3.5 GB usable), and I don't get any stutters on my system with 32 GB of RAM installed. That's on a 1920x1200 monitor though. The higher you push the resolution, the more GPU VRAM you'll want. And it never hurts to have a lot of system RAM installed, especially if you're also running other programs in the background.

Share this post


Link to post
Share on other sites

Look to other programs running in the background for your perceived XP animation experience.  I'd turn off all virus programs, run all other processes at 'game option' if you have such an option, so they won't sniff out upon the Net, etc.

That might be what is your problem. If it was inherent in XP, then all of us would have this commonality.  I don't have any stutter...but I DO manage my Task Manager, and have such things as my 'system protector' features and software in 'Game Mode', when flying any of my platforms...

Ses

Share this post


Link to post
Share on other sites

I'm on an i5 2500 @ 3,3 Ghz, GTX 960 4 GB graphics card, and I get 40+ fps, with HDR, 3rd notch of antialiasing, 4 flight models per frame...

Try:

.) turning off VSyn

.) In Nvidia Inspector, setting threaded optimization to OFF/None

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Heya guys much thanks for the replies, Ive reduced the amount of AI traffic an it seems to have done the trick for now anyway lol, cheers for the suggestions dudes/gals

Andy

Share this post


Link to post
Share on other sites
2 hours ago, buzzard2008 said:

Heya guys much thanks for the replies, Ive reduced the amount of AI traffic an it seems to have done the trick for now anyway lol, cheers for the suggestions dudes/gals

Andy

There are some "AI packs" of airliners made by Morten Melhuus available on x-plane.org. You can use them as AI aircrafts (instead of the default X-Plane aircrafts), since they're optimized and should give better frame rates and hopefully less stutters.

Here they are:

http://forums.x-plane.org/index.php?/profile/2374-morten/content/&type=downloads_file

 

Share this post


Link to post
Share on other sites

I too have found that turning OFF the Vsync in both the sim and on the video card (GTX 980) seems to help increase my frames per second and reduce the micro stutters. This then allows me to run more eye candy and higher quality  (resolution) video.

 

Terry

 

 

Share this post


Link to post
Share on other sites

Hi Andy

I had the same problems with micro stuttering in Xplane 11 and i tried to change all the graphic settings in x-plane and changing the nvidia graphic settings but it all helped nothing. So then i found i youtube video which solved my micro stutters a lot and now x-plane makes even more fun! 

With Process Lasso you can optimize win 7 64 bit and it's really a big difference to x-plane micro stutters. I changed the priority class of x-plane to high and the I/O-priority to high and set process lasso to gaming mode and classified x-plane as a game. This changes helped me really a lot. Maybe they help you too. Here is the link for the video and thanks to this guy!!

Tobi

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this