AresOcana

PMDG 737 HUD/HGS not working

Recommended Posts

i recently bought the PMDG 737. Everything works fine except for the HUD/HGS

What can i do for fixing it? i already tried reinstalling but still happening

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

have  enabled  it  in the  fmc  options  since  you  can  have  it  installed  or  not

Share this post


Link to post
Share on other sites
42 minutes ago, pete_auau said:

have  enabled  it  in the  fmc  options  since  you  can  have  it  installed  or  not

yes i have it enabled. but when i pull it down nothing is shown

Share this post


Link to post
Share on other sites
35 minutes ago, Aresito said:

yes i have it enabled. but when i pull it down nothing is shown

take it  you pressed  the clr  button  and  adjusted  the brigtness   since  it  was  mentioned   awhile  ago

Share this post


Link to post
Share on other sites
7 minutes ago, pete_auau said:

take it  you pressed  the clr  button  and  adjusted  the brigtness   since  it  was  mentioned   awhile  ago

i don't mentioned it,but i also tried that and doesn't worked

Share this post


Link to post
Share on other sites
4 hours ago, faris shala said:

Many of the 

Many of the steps are too complicated and simply can't be done. Has someone made a video or showing how to fix the HUD?

Full names in the forum. They're really not that hard if you try them, honestly.

Share this post


Link to post
Share on other sites

I went through each and every DLL.XML file using notepad++ to find that none of the files were corrupted. Is there anything else I can do?

  • Upvote 1

Share this post


Link to post
Share on other sites
11 hours ago, faris shala said:

I went through each and every DLL.XML file using notepad++ to find that none of the files were corrupted. Is there anything else I can do?

Real name at the forums please as Kyle wrote.

 

Did you check if the following line is shown on the dll.xml file?

 

<Launch.Addon>
        <Name>PMDG HUD interface</Name>
        <Disabled>False</Disabled>
        <Path>PMDG\DLLs\PMDG_HUD_interface.dll</Path>
        <DllStartName>module_init</DllStartName>
        <DllStopName>module_deinit</DllStopName>
    </Launch.Addon>

Share this post


Link to post
Share on other sites
2 hours ago, Olympic260 said:

Real name at the forums please as Kyle wrote.

 

Did you check if the following line is shown on the dll.xml file?

 

<Launch.Addon>
        <Name>PMDG HUD interface</Name>
        <Disabled>False</Disabled>
        <Path>PMDG\DLLs\PMDG_HUD_interface.dll</Path>
        <DllStartName>module_init</DllStartName>
        <DllStopName>module_deinit</DllStopName>
    </Launch.Addon>

I went to that file and I couldn't find any of these texts I would attach a screenshot of the file, but there is no way to insert it.

I have also uninstalled the ngx and reinstalled it to no avail. 

 

I don't understand what you mean by "real names on the forum please"?

Share this post


Link to post
Share on other sites
3 minutes ago, faris shala said:

I went to that file and I couldn't find any of these texts I would attach a screenshot of the file, but there is no way to insert it.

I have also uninstalled the ngx and reinstalled it to no avail. 

 

I don't understand what you mean by "real names on the forum please"?

Real names I mean that you need to sign your real name, first and last at the bottom of your post or edit your signature to have it permanent.

Which simulator are you using?

  • Upvote 1

Share this post


Link to post
Share on other sites
1 minute ago, Olympic260 said:

Real names I mean that you need to sign your real name, first and last at the bottom of your post or edit your signature to have it permanent.

Which simulator are you using?

FSX Steam Edition

Faris Shala

  • Upvote 1

Share this post


Link to post
Share on other sites

In that case from the moment that the above entry is not in your dll.xml file this is why you do not see any indication on the HYD.

You must go to C:\Users\[USER]\AppData\Roaming\Microsoft\FSX Open dll.xml and add the following

<Launch.Addon>
        <Name>PMDG HUD interface</Name>
        <Disabled>False</Disabled>
        <Path>PMDG\DLLs\PMDG_HUD_interface.dll</Path>
        <DllStartName>module_init</DllStartName>
        <DllStopName>module_deinit</DllStopName>
    </Launch.Addon>

With notepad++ you must be able to enter the above and save the file. If you can't then please go to https://support.precisionmanuals.com/ an open a ticket so someone from support can assist you further.

 

 

 

 

Share this post


Link to post
Share on other sites

strange  issue  this  one  doing  a  re install  which  he  has  done  will normally  fix  the issue.

Share this post


Link to post
Share on other sites
3 minutes ago, Olympic260 said:

In that case from the moment that the above entry is not in your dll.xml file this is why you do not see any indication on the HYD.

You must go to C:\Users\[USER]\AppData\Roaming\Microsoft\FSX Open dll.xml and add the following

<Launch.Addon>
        <Name>PMDG HUD interface</Name>
        <Disabled>False</Disabled>
        <Path>PMDG\DLLs\PMDG_HUD_interface.dll</Path>
        <DllStartName>module_init</DllStartName>
        <DllStopName>module_deinit</DllStopName>
    </Launch.Addon>

With notepad++ you must be able to enter the above and save the file. If you can't then please go to https://support.precisionmanuals.com/ an open a ticket so someone from support can assist you further.

 

 

 

 

I will try to add the code, but I would like to know which DLL.XML file to open since I have many files under the name DLL.XML

Is it the once called "PMDG_HUD_interface.dll"?

  • Upvote 1

Share this post


Link to post
Share on other sites
2 minutes ago, pete_auau said:

strange  issue  this  one  doing  a  re install  which  he  has  done  will normally  fix  the issue.

I agree it's very strange that I have reinstalled it about three times to no avail.

Share this post


Link to post
Share on other sites
7 minutes ago, pete_auau said:

strange  issue  this  one  doing  a  re install  which  he  has  done  will normally  fix  the issue.

Not necessary, that is why uninstalling is not recommended unless someone from PMDG explicitly asks to

  • Upvote 1

Share this post


Link to post
Share on other sites
10 minutes ago, faris shala said:

I agree it's very strange that I have reinstalled it about three times to no avail.

 

 

12 minutes ago, faris shala said:

I will try to add the code, but I would like to know which DLL.XML file to open since I have many files under the name DLL.XML

Is it the once called "PMDG_HUD_interface.dll"?

you need  to  go  here  there  is  only  one  

C:\Users\[USER]\AppData\Roaming\Microsoft\FSX Open dll.xml

  • Upvote 1

Share this post


Link to post
Share on other sites
6 minutes ago, faris shala said:

I will try to add the code, but I would like to know which DLL.XML file to open since I have many files under the name DLL.XML

Is it the once called "PMDG_HUD_interface.dll"?

You need to open the dll.xml (there should be only one dll.xml) file under C:\Users\[USER]\AppData\Roaming\Microsoft\FSX

  • Upvote 1

Share this post


Link to post
Share on other sites
3 minutes ago, Olympic260 said:

Not necessary, that is why uninstalling is not recommended unless someone from PMDG explicitly asks to

true  but   since  he  has  done  it  should  have  fixed  it

Share this post


Link to post
Share on other sites
23 minutes ago, Olympic260 said:

You need to open the dll.xml (there should be only one dll.xml) file under C:\Users\[USER]\AppData\Roaming\Microsoft\FSX

Since I am using Steam Edition the dll.xml file doesn't exist in that location.

Sorry to have wasted your time

Share this post


Link to post
Share on other sites

When it wasn‘t added to the dll on the first installation it won‘t be add on a second, third, n time either...

  • Upvote 1

Share this post


Link to post
Share on other sites
4 minutes ago, faris shala said:

Since I am using Steam Edition the dll.xml file doesn't exist in that location.

Sorry to have wasted your time

Check here

 

C:\Users\*name*\AppData\Roaming\Microsoft\FSX-SE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now