arnava1304

P3D v4.1 physics issue

Recommended Posts

Hi All,

 

I've been off simming for a while and as I just got back from boarding school for October break, I just updated to 4.1. Of course, she doesn't work right. I have a wierd issue with the physics in the sim that even when I have full control deflection, all aircraft pitch, roll and yaw excruciatingly slow. It isn't a controls issue, when I go into the PMDG 737 SYS EICAS page, the flight controls display show full deflection. Despite this, the aircraft behaves as if I am on 1/4 deflection. This happens on every aircraft, even default. I have ASP4 installed, but it happens even when it isn't running.

 

Any suggestions?

Thanks,

Arnav

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Have you tried calibrating your controls with FSUIPC ?  

Share this post


Link to post

Hi Tony,

9 minutes ago, Tony P said:

Have you tried calibrating your controls with FSUIPC ?  

Thanks for the reply. Yes I did, and all my axes go direct through FSUIPC calibration.

Share this post


Link to post

Have you still got your axes enabled in the default sim 'controls' section?

 

If so, might be the reason, calibration conflicts between FSUIPC and P3D.

 

Hope this helps

 

Stu

Share this post


Link to post

Yes,  try disabling the controllers in P3D setup.  I do and have all axis setup in FSUIPC.

Share this post


Link to post
4 minutes ago, Tony P said:

Yes,  try disabling the controllers in P3D setup.  I do and have all axis setup in FSUIPC.

Yup, already did.

Share this post


Link to post

Check that you are running in real time not slow time. Try hitting R++ ( R key once and PLUS key twice) - you should see 4x in upper right corner. Then hit R-- (R key once and MINUS key twice) to bring you back to normal speed.

Vic

Share this post


Link to post
2 hours ago, vgbaron said:

Check that you are running in real time not slow time. Try hitting R++ ( R key once and PLUS key twice) - you should see 4x in upper right corner. Then hit R-- (R key once and MINUS key twice) to bring you back to normal speed.

Vic

will try soon

Share this post


Link to post

Are you using the most recent version of FSUIPC 5.121b?

Share this post


Link to post
9 minutes ago, jabloomf1230 said:

Are you using the most recent version of FSUIPC 5.121b?

Yup

Share this post


Link to post

Try renaming FSUIPC5.ini. Let FSUIPC rebuild the file. All your joystick settings will be lost. Run P3D4. In FSUIPC, try calibrating the axes that were problematic.

If they now work, great. You can either add back all other joystick settings via the FSUIPC UI or try using a text editor to copy the relevant lines from the renamed version of FSUIPC5.ini.

If this doesn't work your other option is to contact Pete Dowson via the official FSUIPC forum.

Even though you've disabled controllers in the P3D4 UI, I would also make sure that the mode is set to DirectInput and not Raw Input. For some setups, the latter mode may introduce hardware issues with both the mouse and joysticks.

Share this post


Link to post

Figured out that the problem is Ezdok v2. Anyone know how to fix it?

Share this post


Link to post
1 minute ago, jabloomf1230 said:

Try renaming FSUIPC5.ini. Let FSUIPC rebuild the file. All your joystick settings will be lost. Run P3D4. In FSUIPC, try calibrating the axes that were problematic.

If they now work, great. You can either add back all other joystick settings via the FSUIPC UI or try using a text editor to copy the relevant lines from the renamed version of FSUIPC5.ini.

If this doesn't work your other option is to contact Pete Dowson via the official FSUIPC forum.

Even though you've disabled controllers in the P3D4 UI, I would also make sure that the mode is set to DirectInput and not Raw Input. For some setups, the latter mode may introduce hardware issues with both the mouse and joysticks.

thanks anyways, but ezdok is the issue. not controls.

 

Share this post


Link to post
49 minutes ago, arnava1304 said:

thanks anyways, but ezdok is the issue. not controls.

 

What ezok version do you have? The latest is 2.5 build 21 which is for p3d4.1

Share this post


Link to post
2 minutes ago, arnava1304 said:

Oh lol, let me try that.

Yup that fixed it. Thanks!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now