LOELI12

Saitek Yoke - all axis working, but HAT not

Recommended Posts

Hi,
after a complete new installation of my rig, I am struggling with the HAT of Saitek Cessna Yoke. I am running P3Dv4.1. In VC, all axis of the yoke are working except the HAT. If I  switch in VC to slew mode, I can see an extremely slow movement on the monitor. If I switch to outside view (F11), HAT is working normally. New installation of P3D and Saitek drivers did not help. 
Any idea what may help ?
Thank you 
Bruno

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

You can look in the "controls" to see if P3D has assigned the switches in the hat to anything having to do with views, camera, pan, or look.. There should be a slider next to any assignment if it has. You'll need to move the slider to the right to indicate that the action should be repeated as you hold the hat to one side or aanother or to the up or down positions.

Alternatively, you can use FSUIPC to assign the hat switches (called buttons in FSUIPC) to the "pan" functions. Be sure to check the box to repeat the function as you hold the switch or it will simply "step" the view one little bit at a ti0me as you repeatedly push the switch around.

Share this post


Link to post

Hi,

"controls" in P3D are set as should be; i.e. slider is max right. To delete the HAT assignment setting and asign it new did not help. To use FSUIPC, the payware version is needed, which I dont own. The HAT was working before new installation of my machine. Than you anyway.

Bruno

Share this post


Link to post

Hmmm... in that case, I would start eliminating addons to see if they are interfering. Things that enhance camera views would be my first suspects...

Share this post


Link to post

You need to assign the POV hat in Chaseplane settings otherwise you get no hat elsewhere.

Share this post


Link to post

Another potential error source: if you have a default scenario using an A2A plane, this can also lead to issues with the hat. I thought they eliminated this (acknowledged) bug with the last update, but you never know...

Share this post


Link to post

I deactivated Chaseplane and took a P3D default aircraft, to see what the HAT is doing or not doing. I noticed now, that in VC, the HAT is indeed working. But head movement is so extremely slow, that you have to watch the border of the monitor to see that POV is indeed moving. Actual head movement may be one angular degree per second or less, despite the HAT slider is fully right.  As already mentioned, in outside view (Spot View, Locked Spot View) the HAT is working at normal speed in any direction.
edit:

I just detected that the camera.cfg created by Chaseplane causes the problem. I activated the original P3D camera.cfg and the HAT now works as any time before. 

I simply forgot to assign "pan" and "tilt" in Chaseplane Control Assignments

Thank you for your tips.

 

Share this post


Link to post

hey good news.i had a similar problem with ezdok.always going to be a cfg...just finding which one

 

 steve :-)

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now